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SAP License Agreement for STLport  
SAP License Agreement for STLport 

between 
 

SAP Aktiengesellschaft 
Systems, Applications, Products in Data Processing 

Neurottstrasse 16 
69190 Walldorf 

Germany 
( hereinafter: SAP ) 

 
and 

 
you 

( hereinafter: Customer ) 
 
 
1. Subject Matter of the Agreement 

a. SAP grants Customer a non-exclusive, non-transferable, 
royalty-free license to use the STLport.org C++ library 
(STLport) and its documentation without fee. 

b. By downloading, using, or copying STLport or any portion 
thereof Customer agrees to abide by the intellectual property 
laws, and to all of the terms and conditions of this 
Agreement. 

c. The Customer may distribute binaries compiled with 
STLport (whether original or modified) without any 
royalties or restrictions. 

d. Customer shall maintain the following copyright and 
permission notices on STLport sources and its 
documentation unchanged: 
Copyright 2001 SAP AG 

e. The Customer may distribute original or modified STLport 
sources, provided that: 
• The conditions indicated in the above permission notice 

are met; 
• The following copyright notices are retained when 

present, and conditions provided in accompanying 
permission notices are met: 

 
Copyright 1994 Hewlett-Packard Company 
Copyright 1996,97 Silicon Graphics Computer 
Systems, Inc. 
Copyright 1997 Moscow Center for SPARC 
Technology. 
Copyright 1999,2000 Boris Fomitchev 
Copyright 2001 SAP AG 
 
Permission to use, copy, modify, distribute and sell this 
software and its documentation for any purpose is 
hereby granted without fee, provided that the above 
copyright notice appear in all copies and that both that 
copyright notice and this permission notice appear in 
supporting documentation. Hewlett-Packard Company 
makes no representations about the suitability of this 
software for any purpose. It is provided "as is" without 
express or implied warranty. 
 
Permission to use, copy, modify, distribute and sell this 
software and its documentation for any purpose is 
hereby granted without fee, provided that the above 
copyright notice appear in all copies and that both that 
copyright notice and this permission notice appear in 
supporting documentation. Silicon Graphics makes no 
representations about the suitability of this software for 
any purpose. It is provided "as is" without express or 
implied warranty. 
 
Permission to use, copy, modify, distribute and sell this 
software and its documentation for any purpose is 
hereby granted without fee, provided that the above 
copyright notice appear in all copies and that both that 
copyright notice and this permission notice appear in 
supporting documentation. Moscow Center for SPARC 



 

Technology makes no representations about the 
suitability of this software for any purpose. It is 
provided "as is" without express or implied warranty. 
 
Boris Fomitchev makes no representations about the 
suitability of this software for any purpose. This 
material is provided "as is", with absolutely no 
warranty expressed or implied. Any use is at your own 
risk. Permission to use or copy this software for any 
purpose is hereby granted without fee, provided the 
above notices are retained on all copies. Permission to 
modify the code and to distribute modified code is 
granted, provided the above notices are retained, and a 
notice that the code was modified is included with the 
above copyright notice. 
 
Permission to use, copy, modify, distribute and sell this 
software and its documentation for any purpose is 
hereby granted without fee, provided that the above 
copyright notice appear in all copies and that both that 
copyright notice and this permission notice appear in 
supporting documentation. SAP makes no 
representations about the suitability of this software for 
any purpose. It is provided with a limited warranty and 
liability as set forth in the License Agreement 
distributed with this copy. SAP offers this liability and 
warranty obligations only towards its customers and 
only referring to its modifications. 

 
2. Support and Maintenance 

SAP does not provide software maintenance for the STLport. 
Software maintenance of the STLport therefore shall be not 
included. 
All other services shall be charged according to the rates for 
services quoted in the SAP List of Prices and Conditions and 
shall be subject to a separate contract. 

3. Exclusion of warranty 
As the STLport is transferred to the Customer on a loan basis and 
free of charge, SAP cannot guarantee that the STLport is error-
free, without material defects or suitable for a specific application 
under third-party rights. Technical data, sales brochures, 
advertising text and quality descriptions produced by SAP do not 
indicate any assurance of particular attributes. 

4. Limited Liability 
a. Irrespective of the legal reasons, SAP shall only be liable for 

damage, including unauthorized operation, if this (i) can be 
compensated under the Product Liability Act or (ii) if caused 
due to gross negligence or intent by SAP or (iii) if based on 
the failure of a guaranteed attribute. 

b. If SAP is liable for gross negligence or intent caused by 
employees who are neither agents or managerial employees 
of SAP, the total liability for such damage and a maximum 
limit on the scope of any such damage shall depend on the 
extent to which its occurrence ought to have anticipated by 
SAP when concluding the contract, due to the circumstances 
known to it at that point in time representing a typical 
transfer of the software. 

c. In the case of Art. 4.2 above, SAP shall not be liable for 
indirect damage, consequential damage caused by a defect or 
lost profit. 

d. SAP and the Customer agree that the typical foreseeable 
extent of damage shall under no circumstances exceed EUR 
5,000. 

e. The Customer shall take adequate measures for the 
protection of data and programs, in particular by making 
backup copies at the minimum intervals recommended by 
SAP. SAP shall not be liable for the loss of data and its 
recovery, notwithstanding the other limitations of the present 
Art. 4 if this loss could have been avoided by observing this 
obligation. 

f. The exclusion or the limitation of claims in accordance with 
the present Art. 4 includes claims against employees or 
agents of SAP. 

 



 

Typographic Conventions 
 

Type Style  Represents 

Example Text Words or characters that 
appear on the screen. These 
include field names, screen 
titles, pushbuttons as well as 
menu names, paths and 
options. 

Cross-references to other 
documentation 

Example text Emphasized words or phrases 
in body text, titles of graphics 
and tables 

EXAMPLE TEXT Names of elements in the 
system. These include report 
names, program names, 
transaction codes, table 
names, and individual key 
words of a programming 
language, when surrounded by 
body text, for example, 
SELECT and INCLUDE. 

Example text Screen output. This includes 
file and directory names and 
their paths, messages, names 
of variables and parameters, 
source code as well as names 
of installation, upgrade and 
database tools. 

Example text Exact user entry. These are 
words or characters that you 
enter in the system exactly as 
they appear in the 
documentation. 

<Example text> Variable user entry. Pointed 
brackets indicate that you 
replace these words and 
characters with appropriate 
entries. 

EXAMPLE TEXT Keys on the keyboard, for 
example, function keys (such 
as F2) or the Enter key. 

Icons 
 

Icon Meaning 

 
Caution 

 
Example 

 
Note 

 
Recommendation 

 
Syntax 
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SAP R/3 Enterprise ABAP Installation 
on Windows: Oracle 
Purpose 
This documentation explains how to install the SAP R/3 Core 4.70 Extension Set 2.00 
Service Release 1 (SAP R/3 Enterprise) on Windows when your database is Oracle. 

SAP R/3 Enterprise is based on SAP Web Application Server (SAP Web 
AS) 6.40 technology, which is the underlying technology of almost all solutions of mySAP 
Business Suite. For more information about the technology provided by SAP Web AS, 
see SAP Service Marketplace at service.sap.com/netweaver 

This documentation focuses on the ABAP part of the SAP R/3 Enterprise installation. The 
ABAP part is required for the installation of SAP R/3 Enterprise ABAP and SAP R/3 
Enterprise ABAP+Java. For more information, see basic system variants [Page 17]. 

If you want to install the Java part of SAP R/3 Enterprise, you have to install SAP Web AS 
6.40 Java. This is because the technology of the Java part of SAP R/3 Enterprise is the same 
as that of SAP Web AS 6.40. The installation of SAP Web AS Java 6.40 is described in the 
documentation Installation Guide – SAP Web Application Server Java 6.40 on Windows: 
Oracle on SAP Service Marketplace at service.sap.com/instguidesnw04 

Constraints 

 
You must only use the SAP installation tools according to the instructions and 
for the purposes described in the SAP installation documentation. Improper use 
of the SAP installation tools can damage files and systems already installed. 

You need consider the following constraints before you start your installation: 

• This documentation only applies if you are installing an Oracle database with a 
Windows operating system. 

• SAP system installations should only be performed by SAP Technical Consultants, 
who are certified for your operating system, your database, and the SAP system that 
you are installing. 

• Downward-compatible releases of DB/OS platforms for SAP products 

SAP plans to regularly release the newest database (DB) and operating-system (OS) 
versions of SAP products. These releases are downward-compatible with earlier SAP 
system releases.  

Be aware that, for already shipped SAP components, we only support the installation 
for database versions proposed by the installation tool. Therefore, you must install a 
SAP component or perform a system copy using a downward-compatible database as 
follows: 

 Install the component with the old proposed database version. 

 Upgrade the old database version to the downward-compatible new version. 
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1  Standard Installation 
This section describes how to perform a standard installation of SAP R/3 Enterprise.  

If you want to perform a cluster installation, see Cluster Installation with MSCS [Page 129]. 

1.1  General Information 
The following sections provide general information for the installation: 

• SAP R/3 Enterprise Architecture [Page 9] 

• New Features [Page 10] 

• Naming Conventions [Page 15] 

Before you start the installation, read Installation Checklists [Page 22]. 

1.1.1 SAP R/3 Enterprise Architecture 
SAP R/3 Enterprise is built on the principle of optimizing the stable and mature core 
processes and infrastructure and making new enhancements optional and deployable when 
needed. 

Optional new functional
enhancements
(SAP R/3 Enterprise Extensions)

Tuned core, optimized for 
performance – based on 4.6C
(SAP R/3 Enterprise Core) 

Application of NetWeaver
(SAP Web Application Server) 

 
 

This version of SAP R/3 Enterprise consists of: 

• SAP R/3 Enterprise Extension Set 2.00 SR1 

 
An SAP R/3 Extension Set includes all SAP R/3 Enterprise Extensions with the 
same release. 

• SAP R/3 Enterprise Core (4.70) 

• SAP R/3 Plug-In PI 2004_1_470 SP 1 and PI_BASIS 2004_1_620 SP 3 

• SAP Web Application Server 6.40 kernel 

• SAP Web Application Server 6.20 ABAP Basis 
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All SAP R/3 Enterprise Extensions get installed, but to use the functions contained in the SAP 
R/3 Enterprise Extensions or industry solutions each can be activated separately. This means 
you can implement only those new developments that you require. 

For more information about SAP R/3 Enterprise, see the SAP Service Marketplace at: 
service.sap.com/enterprise 

 

1.1.2  New Features 
New Features for SAP R/3 Enterprise 4.7 Ext. Set 2.00 SR1  

SAP System Installation 

Area Description 

Kernel SAP R/3 Enterprise Core 4.70 Extension Set 2.00 Service 
Release 1 (SR1) has a downward-compatible kernel from SAP 
Web AS 6.40.  

New SAPinst Features For the installation with SAPinst, you no longer have to create 
an installation directory as SAPinst normally creates 
automatically an installation directory directly below the 
Program Files directory. 

Integration of SAP 
Internet Transaction 
Server (SAP ITS) 

As of SAP Web AS 6.40 the SAP Internet Transaction Server 
(SAP ITS) is integrated into the kernel of the SAP Web 
Application Server 6.40 as an Internet Communication 
Framework (ICF) service. This service is called the Integrated 
ITS. 

Integration of the 
installation of SAP 
Internet Graphic 
Server (IGS) 

As of SAP Web AS 6.40 the installation of the SAP Internet 
Graphic Server (IGS) is integrated into the installation of SAP 
Web Application Server 6.40. 

Distribution of 
Components 

For SAP R/3 Enterprise ABAP+Java, the central services 
instance is always installed on the central instance host. 

Installation DVDs The installation is started from the SAP Installation Master DVD. 

Oracle Database Installation 

Area Description 

New functions in Oracle 
9i 

As of the installation of SAP R/3 Enterprise ABAP or ABAP+JAVA 
6.40, new functions of the Oracle 9i database release are used. 
For more information, see SAP Note 598678. 
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Operating System Support 

Area Description 

Operating system 
support 

• Only Windows 2000 Server and Windows Server 2003 are 
supported for the installation of SAP R/3 Enterprise. 

For more information, see SAP Service Marketplace at 
service.sap.com/platforms → Product Availibility 
Matrix 

• For information on Windows operating system security, see 
www.microsoft.com/security 

New Features before SAP R/3 Enterprise 4.70 Ext. Set 2.00 SR1 

SAP System Installation 

Area Description 

Installation CDs  The installation is started from the SAP Installation Master CD. 

New Java 
development 
environment 

The SAP NetWeaver Developer Studio introduces SAP’s own 
environment for developing Java-based, multiple-layered 
business applications. The new development environment is 
based on Eclipse, an open source product, whose open plug-in 
architecture provides a suitable platform for incorporating 
specific functions. For more information, see the SAP Library 
[Page 36] and choose Application Platform (SAP Web 
Application Server) → Java Technology in SAP Web Application 
Server → Developers’ Manual  → The SAP NetWeaver 
Developer Studio. 

New installation 
procedure 

The structure of the documentation and therefore the procedure 
to use it have changed significantly for this installation. 

New installation tool 
SAPinst 

SAP provides a new installation tool called System Landscape 
Implementation Manager, known for short as SAPinst. 

The main advantages compared with the previous installation 
tool R3SETUP are: 

• SAPinst does not abort due to errors. Instead, it stops the 
installation and you can retry the installation after having 
solved the problem. Alternatively, you can abort the 
installation manually if you want. 

• SAPinst continues an aborted installation directly from the 
point of failure. 

• SAPinst records installation progress in a single log file, 
called sapinst.log. 

• SAPinst has a graphical user interface (GUI) called the 
SAPinst GUI, which allows you to watch the progress of the 
installation and see all messages issued by SAPinst. As the 
SAPinst GUI is Java-based, you need a Java Runtime 
Environment (JRE) or a Java Development Kit (JDK).  
A What's this? help is integrated in the SAPinst GUI. To use 

this, choose , and click the field for which you want 
more information. 
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Area Description 

 
You can start SAPinst GUI on a remote computer if 
you want. 

Support of Unicode Unicode unifies the encoding systems for characters in 
computer systems by incorporating all characters of all character 
sets into a single encoding scheme. 

Without Unicode, there are hundreds of conflicting encoding 
systems. For example, two encoding systems can use the same 
numeric representation for two different characters, or use 
different numeric representations for the same character. Any 
given computer needs to support many different encoding 
systems. Whenever data is passed between different encoding 
systems or platforms, data needs to be transformed from one 
encoding scheme to another, risking data loss or corruption. 

Unicode removes this risk by providing a unique numeric 
representation for every character independent of platform, 
program, or language. 

We use a single-source approach for transparent Unicode 
support. The ABAP coding is the same and runs identically on 
both non-Unicode and Unicode SAP systems. The SAP kernel 
and executables, however, are built differently for non-Unicode 
and Unicode SAP systems. 

• Non-Unicode SAP system 

All characters are represented in binary with only one byte. 

• Unicode SAP system 

All characters are represented in binary with two or four 
bytes. 

 
This documentation describes the installation of a 
Unicode and a non-Unicode SAP system. 

You can find more information about Unicode SAP systems and 
their availability in SAP Note 79991 and on SAP Service 
Marketplace at service.sap.com/unicode 

Integration of J2EE 
Engine 

A Java 2 Enterprise Edition (J2EE) standards-based engine is 
provided and supported by SAP as a runtime environment for the 
Java-based components of mySAP.com. . It is an optional part of 
the SAP Web AS as of Release 6.20, which delivers a reliable and 
scalable e-business environment with native Java support that is 
fully J2EE-compliant.  

The J2EE Engine integrated into the SAP Web AS provides the 
following features: 

• J2EE compliance 

• Enterprise JavaBeans 

• Web and Internet enabling 
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Area Description 

• XML support 

For more information, see Application Platform (SAP Web 
Application Server) → Java Technology in SAP Web Application 
Server in the SAP Library [Page 36]. 

Support of Multiple 
Components on One 
Database 

SAP offers the Installation of Multiple Components on One 
Database [Page 36] (MCOD). That is, you can install an 
additional SAP system into an existing SAP system database. 

For an MCOD installation, you can only combine systems for 
which the MCOD feature is released by SAP. 

 

Oracle Database Installation 

Area Description 

Database schema ID The database schema ID (<SCHEMA_ID>) can be different from 
the SAP system ID (<SAPSID>). As a result, the name of 
SAP<SAPSID> changed to SAP<SCHEMA_ID>. 

Oracle database 
version 

You can find more information about the released database 
version for your installation on SAP Service Marketplace at  
service.sap.com/platforms 

svrmgrl no longer 
exists 

Server Manager svrmgrl has been replaced with sqlplus. 

If you enter sqlplus you are asked to enter your user name 
and password. To avoid this and to have the same behavior as 
with the previous command svrmgrl, enter the following to 
start the database administration tool: 
sqlplus /nolog 

If you have your own scripts using svrmgrl that connect to the 
database, you need to rewrite these accordingly: Replace the 
previous command svrmgrl command=@<sql_file_name> 
with sqlplus /nolog @<sql_file_name> 

Database user internal 
no longer exists 

User internal no longer exists in Oracle9i. To connect to the 
database as database administrator use the command connect 
/ as sysdba  

The previous command connect internal/<password> is 
no longer available. 

New Name for Oracle 
Failsafe Service 

The Oracle Failsafe Service from previous Oracle releases is 
now called OracleMSCSServices. You might still see the old 
name in certain SAP Notes. Be sure to always use the new 
name OracleMSCSServices 

Oracle sapdata file 
systems 

Only four sapdata file systems (sapdata1 to sapdata4) are 
required for the Oracle database. 

New backup file 
system for Oracle 
offline redo logs 

<drive>\oracle\<DBSID>\oraarch is the new standard file 
system for Oracle offline redo logs. 

The file system \oracle\<DBSID>\saparch still persists but 
now only contains brbackup log files. 
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Area Description 

Oracle tablespace 
implement. method 

As of SAP Web AS 6.10, a new, effective method of 
implementing tablespaces is used. With this new tablespace 
implementation, only the following three database tablespaces 
are created: 

• PSAP<SCHEMA_ID> 

• PSAP<SCHEMA_ID><RELEASE> 

• PSAP<SCHEMA_ID>USR 

All three tablespaces are created with AUTOEXTEND ON and 
EXTENT MANAGEMENT LOCAL AUTOALLOCATE. 

For more information, see SAP Note 355771. 

Database System ID In an MCOD installation, there is an Oracle database system ID 
<DBSID> that can be different from the SAP system ID 
<SAPSID>. The database owner name (the owner of tables) 
changed to sap<sapsid>. 

 

1.1.3  Naming Conventions 
In this documentation, the following naming conventions apply: 

Terminology 
The term SAP system is the same as SAP R/3 Enterprise. 

Variables 
Variables Description 

<SAPSID> SAP system ID in uppercase letters 

<sapsid> SAP system ID in lowercase letters 

<DBSID> Database ID in uppercase letters 

<dbsid> Database ID in lowercase letters 

<host_name> Name of the corresponding host 

<SAPinst_INSTDIR> Installation directory for the SAP installation tool SAPinst 

<INSTDIR> Installation directory for the SAP system 

<DVD_DIR> Directory on which a DVD is mounted 

<CD_DIR> Directory on which a CD is mounted 

<OS> Operating system name within a path 

<SCHEMA_ID Database schema ID 
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The following examples show how the variables are used: 

 
• Log on as user <sapsid>adm and change to the directory 

di\usr\sap\<SAPSID>. 
If your SAP system ID is C11, log on as user c11adm and change 

to the rectory \usr\sap\C11. 
• Change to the directory <DVD_DIR>\IM1\NT\<platform>. 

If the DVD is mounted on \sapdvd1 and your operating system 
is Windows x86, change to \sapdvd1\IM1\NT\I386. 
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1.2 Implementation Considerations 
Purpose 
You and your hardware partner generally plan the system configuration well in advance of the 
installation, using sizing information that reflects the system workload. You use factors such 
as the following to design a configuration that performs well: 

• The required applications 

• How intensively the applications are to be used 

• The number of users 

 
As the system configuration fundamentally influences the installation procedure, 
it is important to have a clear configuration plan before you start the installation.  

Process Flow 
... 

1. You choose the basic system variant [Page 17] of your SAP system. 

2. You choose the required installation components [Page 17]. 

3. You decide how to distribute the required installation components to the available 
hosts. This depends on your basic installation type: 

 Distribution of Installation Components SAP R/3 Enterprise ABAP [Page 20] 

 Distribution of Installation Components for SAP R/3 Enterprise ABAP+Java 
[Page 19] 

 Distribution of Installation Components for SAP Web AS Java for SAP R/3 
Enterprise [Page 21] 

1.2.1 Basic System Variants 
There are the following basic system variants of SAP R/3 Enterprise: 

• SAP R/3 Enterprise ABAP  

This system variant consists of the ABAP installaton of SAP R/3 Enterprise. There is 
no J2EE Engine. 

• SAP R/3 Enterprise ABAP+Java 

This system variant consists of the ABAP installaton of SAP R/3 Enterprise and the 
J2EE Engine. You can then operate both the ABAP Engine and the J2EE Engine on 
the SAP system. 

• SAP Web AS Java for SAP R/3 Enterprise 

This system variant consists of the J2EE Engine and auxiliary services. There is no 
ABAP Engine. 

1.2.2 Installation Components 
Definition 
A minimum SAP system consists of a central instance, a database instance, and – if you 
install a SAP system with the J2EE Engine – a central services instance. You can then install 
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optional dialog instances on different hosts after you have completed the installation of the 
central instance, the central services instance (if required), and the database. 

 
You can think of an SAP instance – central instance, central services instance, 
database instance, dialog instance, or gateway instance – as a group of 
processes that are started and stopped at the same time. Every instance has a 
two-digit identifier between 00 and 97 that must be unique on a computer. 

Use 
When you set up an SAP system, you need to install the main components that enable the 
system to operate: 

• Central Instance 

If you install a SAP system with the J2EE Engine, the Software Deployment Manager 
(SDM) is part of the J2EE Engine of the central instance.  

• Central services instance 

If you install an SAP system with the J2EE Engine, also a central services instance 
(SCS) is part of your SAP system. The central services instance forms the basis of 
communication and synchronization for the Java cluster. A central services instance 
consists of the message service and the enqueue service: 

 The message service keeps a list of the J2EE dispatchers and J2EE server 
processes of the Java cluster. It provides the infrastructure for data exchange 
(small datasets only) between the participating nodes. The message service 
also supplies information to the SAP Web Dispatcher about load balancing 
between multiple J2EE instances. 

 The enqueue service manages logical database locks, which are set by the 
executed application program in a J2EE server process. The enqueue service 
also synchronizes data across the Java cluster. 

For more information, see the following in the SAP Library [Page 36]: 

Application Platform (SAP Web Application Server) → Java Technology in SAP Web 
Application Server  → Architecture Manual → Java Cluster Architecture → Central 
Services 

• Database instance 

The J2EE Engine has its own database schema. Therefore, a database instance is 
also a mandatory installation component for the installation of an SAP Web AS Java 
system. 

For the installation of SAP R/3 Enterprise ABAP+Java, both the ABAP and the J2EE 
schema are installed in the same database. 

• Dialog instances, if required 

Dialog instances are SAP instances that include only: 

 Dispatcher, IGS, and CCMS agents 

 SAP R/3 Enterprise ABAP+Java and SAP Web AS Java: J2EE server 
processes 

 SAP R/3 Enterprise ABAP+Java and SAP R/3 Enterprise ABAP: gateway and 
certain ABAP work processes (dialog, batch, spool, or update) 

Dialog instances are installed on application servers. 
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The dialog instances of SAP Web AS Java for SAP R/3 Enterprise are called J2EE 
dialog instances. 

 
If information is valid for both dialog instances and J2EE dialog instances, 
(J2EE) dialog instance is written in this documentation. 

• Gateway instance, if required 

It is possible to install an SAP instance of an SAP system based on SAP R/3 
Enterprise ABAP exclusively as a standalone gateway. This type of instance does not 
contain normal work process types (dialog, background, update, enqueue or spool). 
Only the gateway process (gwrd) is started. If there is an SNA connection to an R/2 
system, gateway work processes (gwwp) are also started. 

• Front ends 

The installation of front ends for the SAP system is described separately in the 
documentation [Page 35] SAP Front End Installation Guide. 

• SAP NetWeaver Developer Workplace 

The SAP NetWeaver Developer Workplace consists of a special SAP Web AS Java 
system in addition to the SAP NetWeaver Developer Studio, SAP’s Java Integrated 
Development Environment (IDE). If required, you can install the Java IDE separately. 

 
The installation of the SAP NetWeaver Developer Workplace is not described in 
this installation documentation. For its installation, see the documentation [Page 
35] Installation Guide – SAP NetWeaver Developer Workplace. 

• SAP NetWeaver Developer Studio 

The SAP NetWeaver Developer Studio is SAP’s own environment for developing Java-
based, multi-layered business applications. The new development environment is 
based on Eclipse, an open source product. The open plug-in architecture of Eclipse 
provides a suitable platform for incorporating specific functions.  

For more information, see the following in the SAP Library [Page 36]: 

Application Platform (SAP Web Application Server) → Java Technology in SAP Web 
Application Server → Developers’ Manual → The SAP NetWeaver Developer Studio 

You can install the SAP NetWeaver Developer Studio in either of the following ways: 

 Separately 

For more information, see the documentation [Page 35] Installation Guide – 
SAP NetWeaver Developer Studio. 

 As part of the SAP NetWeaver Developer Workplace 

For more information, see the documentation [Page 35] Installation Guide – 
SAP NetWeaver Developer Workplace. 



1   Standard Installation   

1.2 Implementation Considerations 

20 August 2004 

1.2.3 Distribution of Installation Components: SAP R/3 
Enterprise ABAP 
Minimal Component Distribution 

The minimal system consists of all mandatory installation components [Page 17] installed on 
a single host. 

Central Instance

ABAP
Engine

J2EE SchemaABAP Schema

Database Instance

 

Maximal Component Distribution 

The maximal scenario consists of all mandatory installation components [Page 17] installed 
on separate hosts.  

Central Instance Host

Central Instance

ABAP
Engine

Database Instance Host

Database Instance 

ABAP Schema

 

1.2.4 Distribution of Installation Components: SAP R/3 
Enterprise ABAP+Java 

 
• ABAP and J2EE data normally reside in the same database. 

• For SAP R/3 Enterprise ABAP+Java, the central services instance is always 
installed on the central instance host. 

Minimal Component Distribution 

The minimal system consists of all mandatory installation components [Page 17] installed on 
a single host. 
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Database

Central Instance

ABAP
Engine

SAP J2EE
Engine

J2EE Schema

ABAP Schema

Central Services
Instance

 

Maximal Component Distribution 

The maximal scenario consists of all mandatory installation components [Page 17] installed 
on two hosts.  

Central Instance Host

Central Services
Instance

Central Instance

Database Instance Host

Database 

J2EE Schema

ABAP Schema

ABAP
Engine

SAP J2EE
Engine

 
 

1.2.5 Distribution of Installation Components: SAP 
Web AS Java for SAP R/3 Enterprise 
The distribution of installation components for SAP Web AS Java for SAP R/3 Enterprise and 
the installation of SAP Web AS Java are described in the documentation Installation Guide – 
SAP Web Application Server Java 6.40 on Windows: Oracle on SAP Service Markteplace at 
service.sap.com/instguidesnw04. 
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1.3  Installation Checklists 
Purpose  
You use the tables in the following sections as checklists to navigate through the installation 
when you install your SAP system.  

Prerequisites 
You have decided how to implement your SAP system [Page 17]. 

Process Flow 
... 

1. You choose and print out the relevant checklists for one of the following system 
variants: 

 SAP R/3 Enterprise ABAP: 

 

Installation Option Installation Checklist 

SAP R/3 Enterprise as a central 
system: 

Central instance and database 
instance of the SAP R/3 Enterprise 
system are installed on one host 

Installation Checklist for SAP R/3 
Enterprise (Central System) 
[Page 24] 

SAP R/3 Enterprise as a distributed 
system: 

Central instance and database 
instance of the SAP R/3 Enterprise 
system are installed on multiple hosts 

Installation Checklist for SAP R/3 
Enterprise (Distributed System) 
[Page 27] 

Dialog Instance(s) for SAP R/3 
Enterprise 

Installation Checklist for a Dialog 
Instance [Page 31] 

Gateway Instance(s) Installation Checklist for a 
Gateway Instance [Page 33] 

 

 SAP R/3 Enterprise ABAP+Java: 

 
For the installation of SAP R/3 Enterprise ABAP+Java, also see the installation 
checklists in the documentation Installation Guide – SAP Web Application 
Server Java 6.40 on Windows: Oracle. 
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Installation Option Installation Checklist 

SAP R/3 Enterprise as a central 
system: 

Central instance, central services 
instance and database instance of the 
SAP R/3 Enterprise system are 
installed on a single host 

1. Installation Checklist for SAP 
R/3 Enterprise (Central 
System) [Page 24] 

2. Installation Checklist for SAP 
Web AS – J2EE Add-In 
(Central System) from the 
documentation Installation 
Guide – SAP Web Application 
Server Java 6.40 on Windows: 
Oracle. 

SAP R/3 Enterprise as a distributed 
system: 

Central instance, central services 
instance and database instance of the 
SAP R/3 Enterprise system are 
installed on multiple hosts 

1. Installation Checklist for SAP 
R/3 Enterprise (Distributed 
System) [Page 27] 

2. Installation Checklist for SAP 
Web AS – J2EE Add-In 
(Distributed System) from the 
documentation Installation 
Guide – SAP Web Application 
Server Java 6.40 on Windows: 
Oracle. 

Dialog Instance(s) for the SAP R/3 
Enterprise system 

1. Installation Checklist for a 
Dialog Instance [Page 31] 

2. Installation Checklist for a 
Dialog Instance for SAP Web 
AS – J2EE Add-In available in 
the documentation Installation 
Guide – SAP Web Application 
Server Java 6.40 on Windows: 
Oracle. 

Gateway Instance(s) Installation Checklist for a 
Gateway Instance [Page 33] 

 

 SAP Web AS Java for SAP R/3 Enterprise 

The installation of the system variant SAP Web AS Java for SAP R/3 Enterprise 
is not described in this installation guide. Instead, see the documentation 
Installation Guide – SAP Web Application Server Java 6.40 on Windows: 
Oracle. You need to perform the installation option SAP Web AS – J2EE 
system. 

 

2. You follow the installation sequence exactly as shown in the checklists: 
... 

a. If a step is required for your installation, you follow the link for that step 
to the corresponding section. 

b. You perform the procedure described there. 

c. After successfully completing the installation step, you mark the 
corresponding entry in the printed table with ! to log the progress of 
your installation. 
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d. You proceed with the next step listed in the checklist. 

1.3.1  Installation Checklist for SAP R/3 Enterprise 
(Central System) 
Purpose 
You use the following checklist when you want to install a central system (you install a central 
instance and a database instance on the central system host). 

Process Flow 

Installation Planning 
! Action 

 You obtain the required documentation [Page 34] 

 
If you want to install a Unicode SAP system, make sure that you read 
SAP Note 544623 and perform the additional installation steps 
described there. 

 You decide, if you want to install multiple components on one database (MCOD) 
[Page 36] 

 
• If you decide to turn off database logging during the database 

load phase of the installation, you need to plan downtime for 
all connected database instances. 

• Be aware that you cannot install multiple components in one 
database in a cluster environment. 

• Be aware that you cannot install a Unicode SAP system with 
a non-Unicode SAP system in one database (MCOD). 

 You decide if you want to use Lightweight Directory Access Protocol (LDAP) [Page 
39] for SAP Logon or the Microsoft Management Console (MMC).  

 You decide on the optimal configuration for your system [Page 41] 

 You check the hardware and software requirements [Page 47] 

Installation Preparations 
! Action 

 Make sure that the front-end software is installed on at least one host machine in 
your system environment. To simplify administration of your SAP system, we 
recommend you to do this on the central instance host. 

For more information on installing the front-end software, see the separate 
documentation [Page 35]: 

• SAP Front End Installation Guide (English version) 

• SAP Frontend-Installationsleitfaden (German version) 

 Check for the Windows file system [Page 56] 
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! Action 

 If required, check the Windows domain structure [Page 56] 

 Reduce the size of the file cache [Page 57] 

 Grant user rights for the installation [Page 57] 

 If required, perform a domain installation without being a domain administrator 
[Page 58] 

 Choose the SAP system IDs [Page 61] 

 Prepare the SAP system transport host [Page 62] 

 You check SAP Note 306408 if you require an interim patch for the Oracle 
database installation. In this case, make sure you have the corresponding Perl 
version as stated in that SAP Note. 

 If required, you prepare your system for SAPinst [Page 64] 

 Prepare the installation CDs and DVDs [Page 66] 

 If you decided to use LDAP [Page 39], prepare the active directory for use with the 
SAP system [Page 39] 

Installation Process 
! Action 

 Install the Oracle database server software [Page 71] 

 Run SAPinst [Page 73] and select SAP R3E 4.7x200 SR1  ABAP System  
<Unicode or non-Unicode>  Install a Central Instance to install the central 
instance. 

 Check the input for the installation [Page 77] 

 Run SAPinst [Page 73] and select SAP R3E 4.7x200 SR1  ABAP System  
<Unicode or non-Unicode>   Install a Database Instance to install the database 
instance 

 
If you want to install an additional SAP system into an existing 
database (MCOD), see Installation of Multiple Components On One 
Database [Page 36]. 

 Check the input for the installation [Page 77] 

Post-Installation Activities 
! Action 

 Check that you can start and stop the SAP system [Page 92] 

 Check that you can log on to the SAP system [Page 93]. 

 Install the SAP license [Page 94] 

 Check the SAP system services [Page 94] 

 Install the SAP online documentation [Page 95] 

 Configure SAProuter and SAPNet − R/3 Frontend [Page 96]. 

 Configure the Transport Management System [Page 96]. 
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! Action 

 Perform basic operations [Page 97]. 

 Check and, if required, adapt the configured number of work processes [Page 97]. 

 If required, install additional languages [Page 98]. 

 You activate or deactivate the integrated Internet Transaction Server (ITS) [Page 
98]. 

 If required, you import Support Packages [Page 99]. 

 If required, set up Secure Single Sign-On [Page 99] or Kerberos Single Sign-On 
[Page 104]. 

 Perform the client copy [Page 109]  

 If you install SAP R/3 Enterprise as basis for an SAP component that uses the 
Knowledge Provider (KPRO) component (for example, SAP BW or SAP KW), 
you schedule asynchronous indexing and deindexing [Page 109] using the report 
RSTIRIDX. 

 If the Oracle security setup defined by the standard installation is not restrictive 
enough for your purposes, see SAP Note 186119 to configure the Oracle 
listener to accept only connections from specific hosts. 

 
... 

Unicode SAP system installation only: 

You perform the post-installation steps described in SAP Note 544623. 

 Perform a full installation backup [Page 111]. 

 
If you install SAP R/3 Enterprise ABAP+Java, you can perform the 
full installation backup after the installation of the J2EE Engine. 

 Change passwords of created users 

Additional Steps 
! Action 

 If you want to install SAP R/3 Enterprise ABAP+Java, perform the steps in the 
“Installation Checklist for SAP Web AS – J2EE Add-In (Central System)” 
available in the documentation Installation Guide – SAP Web Application Server 
Java 6.40 on Windows: Oracle 

 
SAP_BAS_620 and SAP_ABA_620 SP41 are prerequisites for the 
J2EE Add-In installation. 

 After the central system installation, you can install the following if required: 

• Dialog Instance [Page 31] 

• Gateway Instance [Page 33] 

 Once you have completed and checked the SAP system installation, you need to 
prepare the SAP system for using business applications. This process includes 
customizing the basis system and the various business components. For more 
information, see Solution Life Cycle Management → Customizing in the SAP 
Library [Page 36]. 
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1.3.2  Installation Checklist for SAP R/3 Enterprise 
(Distributed System) 
Purpose 
You use the following checklist when you want to install a distributed SAP system (you install 
a central instance on the central instance host and the database instance on the database 
instance host). 

Process Flow 
1. You perform the following steps on the central instance host: 

You perform the following steps on the central instance host: 

a. Installation Planning 

! Action 

 Obtain the required documentation [Page 34] 

 
If you want to install a Unicode SAP system, make sure that you 
read SAP Note 544623 and perform the additional installation 
steps described there. 

 Decide, if you want to install multiple components on one database (MCOD) 
[Page 36]. 

 
• If you decide to turn off database logging during the 

database load phase of the installation, you need to plan 
downtime for all connected database instances. 

• Be aware that you cannot install a Unicode SAP system 
with a non-Unicode SAP system in one database 
(MCOD). 

 Decide on the optimal configuration for your system [Page 41] 

 You decide if you want to use Lightweight Directory Access Protocol (LDAP) 
[Page 39] for SAP Logon or the Microsoft Management Console (MMC). 

 Check the hardware and software requirements [Page 47] 

b. Installation Preparations 
! Action 

 Make sure that the front-end software is installed on at least one host 
machine in your system environment. To simplify administration of your SAP 
system, we recommend you to do this on the central instance host. 

For more information on installing the front-end software, see the separate 
documentation [Page 35]: 

• SAP Front End Installation Guide (English version) 

• SAP Frontend-Installationsleitfaden (German version) 

 Check for the Windows file system [Page 56] 
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! Action 

 If required, check the Windows domain structure [Page 56] 

 Reduce the size of the file cache [Page 57] 

 Grant user rights for the installation [Page 57] 

 Choose the SAP system IDs [Page 61] 

 
This action is not required if you install a system into an existing 
database (MCOD). 

 Prepare the SAP system transport host [Page 62] 

 If required, prepare your system for SAPinst [Page 64] 

 Prepare the installation CDs and DVDs [Page 66] 

 If you decided to use LDAP [Page 39], prepare the active directory for use 
with the SAP system [Page 39] 

Installation Process 
! Action 

 If you install a system into an existing database (MCOD), make sure that the 
SYSTEM tablespace contains at least 350 MB of free space. If there is not 
enough space left, increase the size of this tablespace with brtools.exe. 

 Install the Oracle database client software [Page 71] 

 Run SAPinst [Page 73] and select SAP R3E 4.7x200 SR1  ABAP System  
<Unicode or non-Unicode>  Install a Central Instance to install the central 
instance. 

 Check the input for the installation [Page 77] 

 

2. You perform the following steps on the database instance host: 

 
If you want to install an additional SAP system into an existing database 
(MCOD), see Installation of Multiple Components On One Database [Page 36]. 

a. Installation Planning 
! Action 

 Check the hardware and software requirements [Page 47] 

b. Installation Preparations 
! Action 

 You check SAP Note 306408 if you require an interim patch for the Oracle 
database installation. In this case, make sure you have the corresponding Perl 
version as stated in that SAP Note. 

 Grant user rights for the installation [Page 57] 

 If required, you prepare your system for SAPinst [Page 64] 

 Prepare the installation CDs and DVDs [Page 66] 
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c. Installation Process 
! Action 

 If you install a system into an existing database (MCOD), make sure that the 
SYSTEM tablespace contains at least 350 MB of free space. If there is not 
enough space left, increase the size of this tablespace with brtools.exe. 

 Install the Oracle database server software [Page 71] 

 Run SAPinst [Page 73] and select SAP R3E 4.7x200 SR1  ABAP System  
<Unicode or non-Unicode>  Install a Database Instance to install the 
database instance. 

 
If you want to install an SAP system into an existing database, 
see Installation of Multiple Components on One Database [Page 
36] 

 Check the input for the installation [Page 77] 

d. Post-Installation Activities 
! Action 

 If the Oracle security setup defined by the standard installation is not restrictive 
enough for your purposes, see SAP Note 186119 to configure the Oracle 
listener to accept only connections from specific hosts. 

3. You perform the following steps on the central instance host: 

a. Post-Installation Activities 

To complete the installation, you have to perform a number of actions. Some of these 
actions are mandatory, others are optional and serve to activate features that might be 
useful. 

! Action 

 Start and stop the SAP system [Page 92] 

 Log on to the SAP system [Page 93]. 

 Install the SAP license [Page 94] 

 Check the SAP system services [Page 94] 

 Install the SAP online documentation [Page 95] 

 In a standalone database system, after you have installed the database 
instance, check the RFC destination [Page 95] 

 Configure SAProuter and SAPNet − R/3 Frontend [Page 96]. 

 Configure the Transport Management System [Page 96]. 

 Perform basic operations [Page 97]. 

 Check and, if required, adapt the configured number of work processes 
[Page 97]. 

 If required, install additional languages [Page 98]. 

 You activate or deactivate the integrated Internet Transaction Server (ITS) 
[Page 98]. 

 If required, you import Support Packages [Page 99]. 
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! Action 

 If required, set up Secure Single Sign-On [Page 99] or Kerberos Single Sign-
On [Page 104]. 

 
... 

Unicode SAP system installation only: 

You perform the post-installation steps described in SAP Note 544623. 

 Perform the client copy [Page 109]  

 If you install SAP R/3 Enterprise as basis for an SAP component that uses 
the Knowledge Provider (KPRO) component (for example, SAP BW or SAP 
KW), you schedule asynchronous indexing and deindexing [Page 109] using 
the report RSTIRIDX. 

 Perform a full installation backup [Page 111]  

 
If you install SAP R/3 Enterprise ABAP+Java, you can perform 
the full installation backup after the installation of the J2EE 
Engine. 

 Change passwords of created users [Page 112]. 

b. Additional Steps 
! Action 

 If you want to install SAP R/3 Enterprise ABAP+Java, perform the steps in 
the Installation Checklist for SAP Web AS – J2EE Add-In (Distributed 
System) available in the documentation Installation Guide – SAP Web 
Application Server Java 6.40 on Windows: Oracle. 

 
SAP_BAS_620 and SAP_ABA_620 SP41 are prerequisites for 
the J2EE Add-In installation. 

 After the central instance installation you can install the following if required: 

• Dialog Instance [Page 31] 

• Gateway Instance [Page 33] 

 
Make sure to install the standalone gateway instance on the 
database instance host for using the RFC functions, for example 
transaction DB13.  

 Once you have completed and checked the SAP system installation, you 
need to prepare the SAP system for using business applications. This 
process includes customizing the basis system and the various business 
components. 

For more information, choose Solution Life Cycle Management → 
Customizing in the SAP Library [Page 36] 
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1.3.3  Installation Checklist for a Dialog Instance  
Purpose 
You use the following checklist when you want to install a dialog instance on the dialog 
instance host. 

Process Flow 

Installation Planning 
! Action 

 Obtain the required documentation [Page 34] 

 Check the hardware and software requirements [Page 47] 

Installation Preparations 
! Action 

 If required, check the Windows file system [Page 56] 

 Check the Windows domain structure [Page 56] 

 Reduce the size of the file cache [Page 57] 

 Grant user rights for the installation [Page 57] 

 If required, you prepare your system for SAPinst [Page 64] 

 Prepare the installation CDs and DVDs [Page 66] 

Installation Process 
! Action 

 Install the Oracle database client software [Page 71] 

 Run SAPinst [Page 73] and select SAP R3E 4.7x200 SR1  ABAP System  
<Unicode or non-Unicode>  Install a Dialog Instance to install the dialog 
instance 

 Check the input for the installation [Page 77] 

Post-Installation Activities 
! Action 

 Start and stop the SAP system [Page 92] 

 Log on to the SAP system [Page 93]. 

 You activate or deactivate the integrated Internet Transaction Server (ITS) [Page 
98]. 

 If required, you import Support Packages [Page 99]. 

 If required, set up Secure Single Sign-On [Page 99] or Kerberos Single Sign-On 
[Page 104]. 

 Perform a full installation backup [Page 111]  

 When the newly installed SAP system goes into production, we recommend that 
you immediately change passwords of created users [Page 112] according to the 
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! Action 
SAP Security Guide. 

Additional Steps 
! Action 

 If you want to install a dialog instance for SAP R/3 Enterprise ABAP+Java, 
perform the steps in “Installation Checklist for a Dialog Instance for SAP Web AS 
– J2EE Add-In” available in the documentation Installation Guide – SAP Web 
Application Server Java 6.40 on Windows: Oracle. 

 
SAP_BAS_620 and SAP_ABA_620 SP41 are prerequisites for the 
J2EE Add-In installation. 

 After the dialog instance installation, you can install the following if required: 

• An additional dialog instance [Page 31] 

• Gateway Instance [Page 33] 
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1.3.4  Installation Checklist for a Gateway Instance 
Purpose 
You use the following checklist when you want to install a gateway instance on the gateway 
instance host.  

Planning 
! Action 

 Obtain the required documentation [Page 34]. 

 Check the hardware and software requirements [Page 47] 

Installation Preparations 
! Action 

 Check the Windows file system [Page 56] 

 Check the Windows domain structure [Page 56] 

 Grant user rights for the installation [Page 57] 

 Choose the SAP system IDs [Page 61] 

 If required, you prepare your system for SAPinst [Page 64] 

 Prepare the required installation CDs and DVDs  [Page 66] 

Installation Process 
! Action 

 Run SAPinst [Page 73] from the Presentation DVD and select Install SAP 
Gateway to install the gateway instance  

 Check the input for the installation [Page 77] 

Post-Installation Activities 
 Start and stop the Gateway instance. For more information, see, Start and stop 

the SAP system [Page 92] 

 Log on to the SAP system [Page 93]. 

 You activate or deactivate the integrated Internet Transaction Server (ITS) [Page 
98]. 

 If required, you import Support Packages [Page 99]. 

 Perform a full installation backup [Page 111] 

 When the newly installed SAP system goes into production, we recommend that 
you immediately change passwords of created users [Page 112] according to the 
SAP Security Guide. 
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1.4  Installation Planning 
 

Make sure that you read the Installation Checklists [Page 22] before you start 
the installation planning. 

1.4.1  Required Documentation 
The following sections describe the documentation you require for the installation. 

• SAP Installation Notes 

• Information on SAP Service Marketplace 

• Accessing the SAP Library 

1.4.1.1  SAP Installation Notes 
You must read the following SAP Notes before you start the installation. They contain the 
most recent information regarding the installation, as well as corrections to the installation 
documentation. 

Make sure that you have the up-to-date version of each SAP Note, which you can find on 
SAP Service Marketplace at service.sap.com/notes 

 

Note 
Number 

Title Description 

751411 INST: SAP R/3 Enterprise 
4.70 Ext. Set 2.00 SR1 on 
Windows 

Windows-specific information about the SAP 
system installation and corrections to this 
documentation. 

675940 SAP Web AS 6.40 
Installation on Windows: 
Oracle 

Oracle-specific information about the SAP 
system installation and corrections to this 
documentation 

675938 SAP Web AS 6.40 ABAP 
Installation on Windows 

Windows-specific information about the SAP 
system installation and corrections to this 
documentation. 

544623 New Installation of 
Unicode SAP systems 

This SAP Note contains supplementary 
information about Unicode-specific 
installation steps. 

611361 Hostnames of SAP 
servers 

Requirements concerning host name length 
and allowed characters for SAP server hosts. 

598678 Composite SAP Note: 
New functions in Oracle 9i 

Information about new functions in Oracle 9i 
that are used as of the installation of Web AS 
ABAP or SAP Web AS ABAP+Java 6.40. 

79991 Multi Language Support / 
Unicode 

Information about Unicode SAP systems and 
their availability. It is only required if you plan 
to install a Unicode SAP system. 
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Note 
Number 

Title Description 

73606 R/3 language 
combinations (non-
Unicode)  

Information about multiple languages on one 
SAP system 

42305 RSCPINST (NLS 
installation tool) 

Information about language and code page 
settings in your SAP system. 

 

1.4.1.2  Information on SAP Service Marketplace 
Information on the following areas is available on SAP Service Marketplace. 

Description Internet Address Title 

SAP Notes service.sap.com/notes – 

Released platforms service.sap.com/platforms – 

List of media for 
installation or upgrade 
of SAP R/3 Enterprise 

service.sap.com/instguides  
SAP Components  SAP R/3 Enterprise 

 SAP R/3 Enterprise Core 4.70 / Ext. 
Set 2.00 (SR1) 

Media Information for 
mySAP R/3 Enterprise 

Installation of the Java 
system for an SAP 
R/3 Enterprise system 

service.sap.com/instguidesNW04 
 Installation 

Installation Guide – SAP 
Web Application Server 
Java 6.40 on Windows: 
Oracle 

Patching of SAP 
Netweaver’04 
scenarios 

service.sap.com/instguidesNW04 
→ Operations 

Support Package Stack 
Guide – SAP 
Netweaver’04 Support 
Package Stack <current 
version> 

Upgrade to SAP R/3 
Enterprise 
Component 

service.sap.com/instguides  
SAP Components  SAP R/3 Enterprise 

 SAP R/3 Enterprise Core 4.70 / Ext. 
Set 2.00 (SR1) 

Upgrade to SAP Web 
Application Server 
<Platform>: <Database> 

Installation of a dialog 
instance (ABAP) or a 
gateway instance as 
part of an SAP system 
upgrade 

service.sap.com/instguidesNW04 
→ Installation 

Installation Guide – 
Additional Instances on 
<Platform> 

Installation of SAP 
NetWeaver Developer 
Workplace 

service.sap.com/instguidesNW04 
 Installation 

Installation Guide – SAP 
NetWeaver Developer 
Workplace 

Installation of SAP 
NetWeaver Developer 
Studio 

service.sap.com/instguidesNW04 
 Installation 

Installation Guide – SAP 
NetWeaver Developer 
Studio 

Installation of the SAP 
System Landscape 
Directory (SLD) 

service.sap.com/instguidesNW04 
 Installation 

Post-Installation Guide – 
SAP System Landscape 
Directory on SAP Web 
AS Java 6.40 
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Description Internet Address Title 

Unicode SAP systems 
and their availability 

service.sap.com/unicode 

See also SAP Note 79991. 

– 

Technical 
infrastructure –
configuration 
scenarios and related 
aspects such as 
security, load 
balancing, availability, 
and caching 

service.sap.com/ti – 

Network infrastructure service.sap.com/network – 

System sizing  service.sap.com/sizing Quick Sizer tool 

Front-end installation  service.sap.com/instguidesNW04 
→ Installation 

Front End Installation 
Guide (this guide is 
available on the SAP 
Presentation  DVD) 

High availability service.sap.com/ha – 

Homogeneous and 
heterogeneous 
system copy 

service.sap.com/instguidesNW04 
→ Installation 

Homogeneous and 
Heterogeneous System 
Copy for SAP Systems 
based on SAP Web 
Application Server 6.40 

Security service.sap.com/security 

 
For information on Windows 
operating system security, 
see 
www.microsoft.com/se
curity  

– 

Information on SAP 
Support Package 
Stacks 

Service.sap.com/sp-stacks – 

 

1.3.1.3  Accessing the SAP Library 
For more information on SAP NetWeaver, access the SAP Library from the SAP Help Portal 
at help.sap.com/nw04 
... 

1. Select the required language. 

2. Choose SAP NetWeaver. 

In the SAP Help Portal at help.sap.com you can also find online documentation for all SAP 
Solutions.  

http://www.microsoft.com/
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1.4.2  Installation of Multiple Components in One 
Database 
Use 
You can install multiple SAP systems in a single database. This is called Multiple 
Components in One Database (MCOD). 

 
You install an SAP R/3 central system and an SAP CRM central system in a 
single database. 

MCOD is scheduled to be available with all SAP components. We are releasing this 
technology on all the major databases for the SAP system, in line with our commitment to 
deliver platform-independent solutions. 

Using this technology is as easy as installing a separate component. No extra effort is 
required because the MCOD installation is fully integrated into the standard installation 
procedure. MCOD is not an additional installation service. Instead, it is an option of the 
database instance installation. 

Prerequisites 
• For more information on MCOD and its availability on different platforms, see SAP 

Service Marketplace at service.sap.com/mcod 

• Improved sizing required 

In general, you calculate the CPU usage for an MCOD database by adding up the CPU 
usage for each individual SAP system. The same applies to memory resources and 
disk space. 

You can size multiple components in one database by sizing each individual 
component using the SAP Quick Sizer and then adding the requirements together.  

For more information on the SAP Quick Sizer, see SAP Service Marketplace at 
service.sap.com/sizing 

Features 

 
We strongly recommend that you test MCOD in a test or development system. 

We recommend that you run MCOD systems in the same context. We do not 
recommend that you mix test, development, and production systems in the 
same MCOD. 

• Reduced administration effort. 

• Consistent system landscape for backup, system copy, administration, and recovery. 

• Increased security and reduced database failure for multiple SAP systems due to 
monitoring and administration of only one database. 

• In an MCOD landscape you can upgrade a single component independently from the 
other components running in the same database, assuming that the upgraded 
component runs on the same database version. However, if you need to restore a 
backup, be aware that all other components are also affected. 
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• Special MCOD considerations and differences from the standard procedure are listed 
where relevant in the installation documentation. 

Constraints 
• In the event of database failure, all SAP systems running on the single database are 

affected. 

• Automated support in an MCOD landscape for the following administrative tasks 
depends on your operating system and database: 

Copying a single component from an MCOD landscape to another database at 
database level 

De-installing a single component from an MCOD landscape 

You can use SAPNet – R/3 Frontend to request help with these tasks. 

• For UNIX systems only 

When you use stopsap in an MCOD system with two central instances, only one 
central instance and the database are shut down. Therefore, you must first stop the 
other SAP system with stopsap R3 or make sure that it has already been stopped. 

• A Unicode SAP system cannot be installed with a non-Unicode SAP system in one 
database (MCOD). 

Activities 

 
All differences in the installation procedure for MCOD are marked in the 
corresponding sections of this documentation. 

Installing the First SAP System into a New Database 
... 

1. Perform the central instance installation as usual. 

 
You install the central instance with SAP system ID C11. 

2. Start the database instance installation. 

3. When SAPinst prompts for Database Instance Type, choose Install (first) SAP 
System into a new database. 

 
You install the database instance C11.  

On some platforms, you can choose a database instance ID that is different 
from the SAP system ID, for example D11. 

4. Finish the installation. 

Installing an Additional SAP System into an Existing Database 
... 

1. Perform the central instance installation as usual. 

 
You install the central instance with SAP system ID C12. 
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2. When SAPinst prompts for the Name of the database instance, enter exactly the 
database instance <DBSID> of the existing – that is, the first – database. 

3. Start the database instance installation. 

4. When you are prompted for Database Instance Type, choose Install (additional) 
SAP System into an existing database. 

5. When SAPinst prompts you for the Name of the database instance, enter exactly 
the database instance <DBSID> of the existing (first) database. 

 
When SAPinst prompts for the database instance name, enter C11. 

6. Finish the installation. 

Due to the MCOD installation, some installation steps are not required and therefore do not 
appear. These steps are marked in section "Input for the Installation." 

1.4.3  Integration of LDAP Directory Services 
Use 
The Lightweight Directory Access Protocol (LDAP) is a feature of Windows 2000 or higher 
that allows important information within a corporate network to be stored centrally on a server. 
The advantage of storing information centrally for the entire network is that you need only 
maintain data once, so avoiding redundancy and inconsistency.  

If an LDAP directory is available in your corporate network, you can configure the SAP 
system to use this feature. For example, a correctly configured SAP system can read 
information from the directory and also store information there.  

This section explains the benefits of using the SAP system with the LDAP directory. In 
addition, it gives an overview of the configuration steps required to use an SAP system with 
the directory.  

 
The SAP system can interact with the Active Directory using the LDAP protocol, 
which defines: 

• The communication protocol between the SAP system and the directory 

• How data in the directory is structured, accessed, or modified 

If a directory other than the Active Directory also supports the LDAP protocol, 
the SAP system can take advantage of the information stored there.  

For example, if there is an LDAP directory on a UNIX or Windows server, you 
can configure the SAP system to use the information available there. In the 
following text, directories other than the Active Directory that implement the 
LDAP protocol are called generic LDAP directories. 

Integration 
In the SAP environment, you can exploit the information stored in an Active Directory or 
generic LDAP directory by using: 

• SAP logon 

• The Microsoft Management Console (MMC) 
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For more information on the automatic registration of SAP components in LDAP directories 
and the benefits of using it in SAP Logon and MMC, see the documentation R/3 System 
Information in Directory Services on SAP Service Marketplace at 
service.sap.com/msplatforms →  Microsoft → Windows Server 

Prerequisites 
You can only configure the SAP system for Active Directory services or other LDAP 
directories if these are already available on the network. The Active Directory is a feature of 
Windows 2000 or higher and is automatically available on all domain controllers. A generic 
LDAP directory is an additional component that you must install separately on a UNIX or 
Windows server. 

Features 

SAP Logon 
Instead of using a fixed list of systems and message servers, you can configure the SAP 
Logon in the sapmsg.ini configuration file to find SAP systems and their message servers 
from the directory. If you configure SAP logon to use the LDAP directory, it queries the 
directory each time Server or Group selection is chosen to fetch up-to-date information on 
available SAP systems. 

To use LDAP operation mode, make sure that the sapmsg.ini file contains the following: 

[Address] 

Mode=LDAPdirectory 

LDAPserver= 

LDAPnode= 

LDAPoptions= 

Distinguish the following cases: 

• If you use an Active Directory, you must set LDAPoptions=“DirType=NT5ADS”. For 
more information, see the SAP system profile parameter ldap/options. 

• You must specify the directory servers (for example, LDAPserver=pcintel6 
p24709) if either of the following is true: 

 The client is not located in the same domain forest as the Active Directory 

 The operating system does not have a directory service client (Windows NT4.0 
and Windows 9X without installed dsclient). 

For more information, see the SAP system profile parameter ldap/servers. 

• For other directory services, you can use LDAPnode to specify the distinguished name 
of the SAP root node. For more information, see the SAP system profile parameter 
ldap/saproot. 

MMC  
The MMC is a graphical user interface (GUI) for administering and monitoring SAP systems 
from a central location. If the SAP system has been prepared correctly, the MMC presents 
and analyses system information that it gathers from various sources, including the Active 
Directory.  

Integrating the Active Directory as a source of information has advantages for the MMC. It 
can read system information straight from the directory that automatically registers changes 
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to the system landscape. As a result, up-to-date information about all SAP application 
servers, their status, and parameter settings is always available in the MMC.  

If you need to administer distributed systems, we especially recommend that you use the 
MMC together with Active Directory services. For example, you can simplify administration by 
using the MMC in a distributed environment that implements the mySAP Business Suite 
components SAP BW, SAP EBP, SAP APO, and SAP CRM. You can keep track of significant 
events in all of the systems from a single MMC interface. You do not need to manually 
register changes in the system configuration. Instead, such changes are automatically 
updated in the directory and subsequently reflected in the MMC. 

Activities 

Active Directory 
To enable an SAP system to make use of the features offered by the Active Directory, you 
must configure both the Active Directory and the SAP system:  
... 

1. You prepare the Active Directory so that it can store SAP data. 

This involves extending the schema for the SAP data types, creating a root container 
for the storage of SAP-specific information, and defining accounts that allow directory 
access. You perform all these tasks using the R3SETUP tool with the option Configure 
Active directory for SAP. 

For more information, see Preparing the Active Directory for Use with the SAP System 
[Page 68] 

2. You configure the SAP system to enable interaction with the Active Directory. 

You do this during the central instance installation using the SAPinst tool. SAPinst 
prompts you for information about the Active Directory and then configures the system 
accordingly. 

Generic LDAP Directories 
To prepare the SAP system to use generic LDAP services, you must perform several steps to 
configure both the LDAP directory and the SAP system:  
... 

1. You configure the LDAP directory to store SAP data. 

This involves extending the directory schema and creating a container for the SAP 
data. 

2. You configure the SAP system to enable interaction with the LDAP directory. 

3. You do this during the central instance installation using the SAPinst tool. SAPinst 
prompts you for information about the Active Directory and then configures the 
system accordingly. 

4. You set up a user with a password on the server where the SAP system is running 
to permit the system to access and modify the LDAP directory. 

You do this by running the script ldappasswd. 

For more information on how to enable interaction between a generic LDAP directory and the 
SAP system, see the documentation R/3 System Information in Directory Services on SAP 
Service Marketplace at service.sap.com/msplatforms →  Microsoft → Windows 
Server 
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1.4.4 System Configuration 
System Configuration 

• You and your hardware partner generally plan the system configuration before the 
installation. Key aspects of the planning include: 

 Central system or standalone database system 

 Domain or local installation 

 How many dialog instances and front ends are required 

• You and your hardware partner work out a high-performance configuration based on 
sizing information that reflects the system workload, such as: 

 The set of applications to be deployed 

 How intensively the applications are to be used 

 The number of users 

• You decide whether you want to perform a local or a domain installation: 

 Local installation 

You need to be Local Administrator of the host involved. In a local 
installation, all Windows account and user information is stored locally on one 
host and is not visible to any other hosts in the system.  

If the SAP system is to run on a single host, you can perform a local 
installation. 

 
Performing a local installation for a distributed system leads to authorization 
problems that have to be resolved. 

 Domain installation 

You need to be Domain Administrator of the domain involved, and all hosts 
in the system must belong to the same domain. In a domain installation, the 
user information is stored centrally on the domain controller and is accessible to 
all hosts in the system.  

 
If the system is to be distributed across more than one host, we strongly 
recommend a domain installation.  

A domain installation requires a domain controller to store user and account 
information centrally for the whole system. For performance and security 
reasons the domain controller must not be located on a host where the central 
instance or database is running.  

 
If for any reason, you are not granted domain administration rights, you can 
perform the installation as a domain user who is a member of the local 
administrator group. However, the domain administrator has to prepare the 
system appropriately for you. For more information, see Performing a Domain 
Installation Without Being a Domain Administrator [Page 59]. 

See also: 
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Granting User Rights for the Installation [Page 57]. 

1.4.4.1  Distribution of Components to Disks 
When you install the SAP system, the installation tools prompt you to enter drive letters for 
the main components of the system. This gives you the opportunity to distribute components 
to disks in the system as you wish. The way in which you do this significantly affects system 
throughput and data security, and must therefore be carefully planned. The best distribution 
depends on your specific environment and must take into consideration factors such as the 
size of the components involved, security requirements and the expected workload.  

When you work out the assignment of components to disks, you first need to get an overview 
of the main components and their corresponding directories. Then, on the basis of sample 
configurations and the recommendations provided in this documentation, you can decide 
which assignment is best for your particular system.  

SAP systems are normally installed on RAID arrays that ensure data redundancy. This 
documentation therefore focuses on RAID subsystems and drives. 

Minimal Configuration 
The following illustrates a disk configuration for a small test or demo system. As security and 
performance play a less crucial role in this type of system, many different configurations are 
feasible. The following shows one of the possible options. 

 
Use the illustrated configuration exclusively for test or demo systems with a final 
database size of less than 10 GB. It is unsuitable for production systems 
because it only minimally satisfies security and performance requirements.  

Distribution of Components to Disks 

Archived Log
Files

DB Data

DB Data

SAP R/3 Kernel

DBMS Software

SAPDBA Directories Mirrored Logs

Redo Logs

 

Distribution of Directories to Disks 
Disk Directories 

Disk 1 \ORACLE\<DBSID>\920 

\ORACLE\<DBSID>\sapreorg 
\ORACLE\<DBSID>\origlogA 
\ORACLE\<DBSID>\origlogB 

\ORACLE\<DBSID>\sapdata1 
\ORACLE\<DBSID>\sapdata2 



1   Standard Installation   

1.4   Installation Planning 

44 August 2004 

Disk 2 \ORACLE\<DBSID>\mirrlogA 
\ORACLE\<DBSID>\mirrlogB 
\ORACLE\<DBSID>\saptrace 
\ORACLE\<DBSID>\sapbackup 
\ORACLE\<DBSID>\sapcheck 

\usr\sap 

\ORACLE\<DBSID>\sapdata3 
\ORACLE\<DBSID>\sapdata4 

Disk 3 \ORACLE\<DBSID>\saparch 

 

Comments 
• The configuration ensures that no data can be lost, but the process for recovering a 

damaged database is complicated and time-consuming. 

• The redo logs and database files are located on the same disks. This means that a 
single disk failure can result in the loss of both the redo logs and database data. 

• The I/O-intensive redo logs are on the same disk volumes as the data files. This can 
impede performance. 

• An equally good alternative would be to simply place all components on a single RAID 
5 array. 

1.4.4.2  SAP Directories 
Definition 
The following SAP directory is created during the central instance installation: 

• \usr\sap 

 Created on the central instance 

 Contains general SAP software 

This directory is global, that is, it is accessed by all of the hosts in the SAP system. Therefore, 
it has a name that follows the Universal Naming Convention (UNC). 

We distinguish between a global, local, and database host: 

• Global host 

Machine on which the central instance is running 

• Local host 

Current machine on which an SAP instance is running 

• DB host 

Machine on which the database server is running 

Use 

\usr\sap 
The SAP software is stored in the \usr\sap directory: 
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• On global hosts, the \usr\sap directory contains global and local (instance-specific) 
data. 

• On local hosts, \usr\sap contains only instance-specific data and copies of the SAP 
executables. The executables on the local host are replicated from those on the global 
host each time the local instance is started. 

The installation program creates the \usr\sap directory on the global host and shares it with 
the names sapmnt and saploc. The same directory on the local host is shared as saploc. 

 
Since SAP traces for the instance are created in \usr\sap, make sure there is 
sufficient space available in this directory. Changes in SAP profiles can also 
affect the disk space.  

If you create the subdirectory ......\SYS (global data) locally on application or 
front-end servers, you have to distribute the software for the SAP system 
manually when upgrading to a new SAP release. SAP does not support this. 

Structure 
The following graphics show how the physical directory \usr\sap is shared on the global 
host and in a distributed installation. In both cases, UNC names are used as follows: 

• \\<SAPGLOBALHOST>\sapmnt to access global directories 

• \\<SAPLOCALHOST>\saploc to access local instance-specific data 

32-Bit Directory Structure on the Global (Central Instance) Host 

Instance Directories

\\<SAPLOCALHOST>\saploc

(UNC name)

log

Physical Directory 
Structure

Global Directories

\\<SAPGLOBALHOST>\sapmnt

(UNC name)

<instance name>

sap

usr

<SID>

opt

datawork

dbg

run

sys

globalprofileexe

refers torefers to

 
 

 



1   Standard Installation   

1.4   Installation Planning 

46 August 2004 

32/64-Bit Directory Structure on the Global (Central Instance) Host  

The graphic shows the directory structure if you install your SAP system in mixed 
environments, for example you use a Windows and UNIX system, or you use a 32-bit and 64-
bit Windows system. 

Instance Directories

\\<SAPLOCALHOST>\saploc

(UNC name)

log

Physical Directory 
Structure

Global Directories

\\<SAPGLOBALHOST>\sapmnt

(UNC name)

<instance name>

sap

usr

<SID>

opt

datawork

dbg

sys

globalprofileexe

refers torefers to

<charset>

<platform>

run

Key
<charset>: nuc for non-Unicode, uc for Unicode
<platform>: ntintel for 32-bit, ntia64 for 64-bit 

 
The above graphics show the directory structure on the global (central instance) host. The 
global data (binaries) is stored in the global directories on the global host and physically 
exists only once for each SAP system. Other application server access the data using the 
UNC name, \\<SAPGLOBALHOST>\sapmnt, where SAPGLOBALHOST is replaced by the 
SAP system with the name of the global host. The global host accesses its own instance-
specific data using the UNC name \\<SAPLOCALHOST>\saploc. On the central instance 
host, the parameters SAPGLOBALHOST and SAPLOCALHOST have the same value. 

Everytime an application server starts, the SAP copy program sapcpe compares the binaries 
in the <platform>-directory on the central instance host and the binaries in the run-
directory on the application server.  If the binaries in the run directory are elder than those in 
the <platform>-directory, sapcpe replaces them with the newer version of the central 
instance host. 

Directory Structure of a Distributed Installation 

The above graphic shows how the central instance, which runs on the global host, interacts 
with a distributed instance running on another computer. On a distributed instance host, the 
parameters SAPGLOBALHOST and SAPLOCALHOST have different values. Distributed 
instances use SAPGLOBALHOST to access global data on a separate host, that is, the global 
host with the central instance. 
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\\<SAPLOCALHOST>\saploc

(UNC name)

log

Access to local
instance directories

\\<SAPGLOBALHOST>\sapmnt

(UNC name)

<instance name>

datawork

Distributed InstanceDistributed InstanceCentral InstanceCentral Instance

Access to
global directories

sap

usr
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1.4.5  Hardware and Software Requirements  
Purpose 
You check the hardware and software requirements using the requirements checklists in the 
following sections. They give the minimum requirements for small SAP system installations 
and do not include customer data. Depending on the amount of data involved, the 
requirements might change. For a more precise sizing definition that reflects your particular 
system load: 

• Use the SAP Quick Sizer tool available from SAP Service Marketplace 

• You enter information on your planned system and the tool calculates the 
requirements. 

You can find more information on SAP Service Marketplace at 
service.sap.com/sizing 

• Contact a hardware vendor. The vendor can analyze the load and calculate suitable 
hardware sizing for you. 

• Contact the person in charge of installation or your Competence Center 

Prerequisites 
• Hardware certification 

You are only allowed to install an SAP system on certified hardware. AddOn 
Technology Center for SAP (AddOn TCS) certifies hardware platforms for SAP on 
Microsoft Windows. You can then run the SAP system on the respective platform for all 
the combinations of the SAP system and databases released by SAP for the specified 
release of MS Windows.  

You can find more information about certified platforms at www.saponwin.com 

• For more information on the released operating systems, see SAP Note 407328. 

• Use Windows 2000 Server or Windows Server 2003 as operating system. 
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With Windows, you must use the English (International) version of the operating 
system, but you can use a different language for the graphical user interface 
(GUI). For more information, see SAP Note 362379. You specify the operating 
system language when you install the operating system. 

Process Flow 
... 

1. You see the requirements checklists of the SAP system instances you want to 
install:  

 Central instance [Page 49] 

 Database instance [Page 51] 

 If you want to install SAP R/3 Enterprise ABAP+Java, also take into account the 
requirements of the central services instance listed in the documentation 
Installation Guide – SAP Web Application Server Java 6.40 on Windows: 
Oracle, section Requirements Checklist for SAP Central Services Instance. 

 Dialog or gateway instance [Page 53], if you want to install additional dialog 
instances or a gateway instance. 

 
• If you install multiple SAP system instances on one host, the 

requirements are cumulative. 

For example, if you install a central system, you have to add the space 
and the RAM requirements of the central instance checklist and the 
database instance checklist. 

• Be aware that Unicode SAP systems require additional hardware 
resources. You can find more information about Unicode SAP systems 
on SAP Service Marketplace at service.sap.com/unicode. 

2. You check the network requirements. For more information, see the documentation 
Network Integration of SAP Servers on SAP Service Marketplace at 
service.sap.com/network  

For more information on SAP software in PC networks, see SAP Note 5324. 

 
If you do not fully meet the relevant requirements, you might experience 
problems when working with the SAP system. 
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1.4.5.1  Requirements Checklist for the Central Instance 
The central instance host must meet the following requirements. 

Requirement Type Requirement 

Hardware  • Suitable backup system. 

• Minimum disk space 

 Central instance: 4 GB (not including virtual memory) 

 4.3 GB of temporary disk space for every required 
installation DVD you have to copy to a local hard 
disk (see Preparing the Installation CDs and DVDs 
[Page 66]) 

... 

To check disk space: 

a. Choose Start → Programs → Administrative Tools → 
Computer Management → Disk Management 

b. Select the local drive. 

c. Choose Properties. 

• Minimum RAM: 

 Central instance of an SAP R/3 Enterprise ABAP 
system: 

• Non-Unicode SAP system: 512 MB 

• Unicode SAP system : 1 GB 

 Central instance of SAP R/3 Enterprise ABAP+Java: 

• Non-Unicode SAP system: 768 MB 

• Unicode SAP system: 1.2 GB 

 J2EE Engine (if required): Between 64 MB and 4096 
MB RAM are required, depending on the load of your 
SAP system 

 
Make sure that you do not enter a value larger than 
the maximum Java heap size of your platform. For 
more information, see the documentation for your 
Java Development Kit (JDK). 

To check RAM, in the Windows Explorer choose Help → 
About Windows. 

• Paging File Size (also known as virtual memory):  

 32-bit: 1 GB plus 3 times RAM. Maximum required is 
10 GB.  

 64-bit: At least 20 GB is recommended for standard 
installations (for more information, see SAP Note 
153641). If you want to install only a small system, 
contact your hardware partner for appropriate swap 
space values.  
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Requirement Type Requirement 

To check paging file size: 

a. Right-click My Computer and choose Properties. 

b. Choose Advanced → Performance Options. 

c. If required, in section Virtual Memory, choose 
Change. 

Software • Oracle 9.2.0 for Windows, 

• Current patch set, and hot fix if available. 

 
For more information on the current patch set and 
hot fix, see SAP Note 578683. 

• English international version of one of the following: 

 Windows Server 2003, Standard Edition  

 Windows Server 2003, Enterprise Edition  

 Windows Server 2003, Datacenter Edition  

 Windows 2000 Server 

 Windows 2000 Advanced Server   

 Windows 2000 Datacenter Server 

 
For any version of Windows 2000, you need at least 
service pack 4. For more information on the latest 
service pack supported by SAP, see SAP Note 
30478. 

To check your Windows version: 
... 

a. Choose Start → Programs → Accessories → Command 
Prompt. 

b. Enter the command winver  

• Make sure that the required fonts/code pages are installed. 

• Make sure that NLS and corresponding saplocales are 
installed. 

• Suitable Windows Resource Kit is strongly recommended 

Other  • Make sure that the host name fulfills the requirements listed 
in SAP Note 611361 (for example, the host name must not 
be longer than 13 characters). 

• If you want to install a printer on a decentralized host for the 
SAP system, make sure that the printer can be accessed 
under Windows. 

• Check that the network, dialog instance, and operating 
system requirements of are met. 
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1.4.5.2  Requirements Checklist for the Database Instance 
The database instance host must meet the following requirements: 

Requirement Type Requirement 

Hardware  • Suitable backup system 

• Minimum disk space (not including virtual memory): 

 Oracle database software: 2 GB 

 Database instance: 50 GB 

 4.3 GB of temporary disk space for every required 
installation DVD [Page 64] you have to copy to a 
local hard disk. 

To check disk space: 
... 

a. Choose Start → Programs →  Administrative Tools → 
Computer Management → Storage → Disk 
Management 

b. Select the local drive. 

c. Choose Properties. 

• Minimum RAM 

 Non-Unicode SAP system: 512 MB 

 Unicode SAP system: 1 GB 

 J2EE Engine (if required): Between 64 MB and 4096 
MB RAM are required, depending on the load of your 
SAP system 

 
Make sure that you do not enter a value larger than 
the maximum Java heap size of your platform. For 
more information, see the documentation for your 
Java Development Kit (JDK). 

To check RAM, in the Windows Explorer choose Help → 
About Windows. 

• Paging File Size (also known as virtual memory) of 1.5 
times RAM (recommended by Microsoft). 

To check paging file size: 
... 

a. Right-click My Computer and choose Properties. 

b. Choose Advanced → Performance Options. 

c. If required, in section Virtual Memory, choose Change. 

Software  • Oracle 9.2.0 

• Current Oracle patch set and hot fix, if available. 

 
For more information on the current patch set, see 
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Requirement Type Requirement 
SAP Note 578683. 

• English international version of one of the following: 

 Windows Server 2003, Standard Edition  

 Windows Server 2003, Enterprise Edition  

 Windows Server 2003, Datacenter Edition  

 Windows 2000 Server 

 Windows 2000 Advanced Server 

 Windows 2000 Datacenter Server 

 
For any version of Windows 2000, you need at least 
service pack 4. For more information on the latest 
service pack supported by SAP, see SAP Note 
30478. 

To check the Windows version: 
... 

a. Choose Start → Programs → Accessories → Command 
Prompt. 

b. Enter the command winver 

• Make sure that the required fonts/code pages are installed. 

• Make sure that NLS and corresponding saplocales are 
installed.  

• Suitable Windows Resource Kit is strongly recommended 

Other  • Make sure that the host name fulfills the requirements listed 
in SAP Note 611361 (for example, the host name must not 
be longer than 13 characters). 

• If you want to install a printer on a decentralized host for the 
SAP system, make sure that the printer can be accessed 
under Windows. 

• Check that the network, dialog instance, and operating 
system requirements of are met. 
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1.4.5.3  Requirements Checklist for a Dialog or Gateway 
Instance 
The dialog or gateway instance host must meet the following requirements: 

Requirement Type Requirement 

Hardware  • Suitable backup system. 

• Minimum disk space 

 Dialog instance: 4 GB (not including virtual memory) 

 Gateway instance: 1 GB 

 4.3 GB of temporary disk space every required 
installation DVD [Page 66] you have to copy to a 
local hard disk. 

To check disk space: 
... 
... 

a. Choose Start → Programs → Administrative Tools → 
Computer Management → Storage → Disk 
Management 

b. Select the local drive. 

c. Choose Properties. 

• Minimum RAM 

 Dialog or Gateway instance of an SAP R/3 
Enterprise ABAP system: 

• Non-Unicode SAP system: 512 MB 

• Unicode SAP system : 1 GB 

 Dialog or Gateway instance of SAP R/3 Enterprise 
ABAP+Java: 

• Non-Unicode SAP system: 768 MB 

• Unicode SAP system: 1 GB 

 J2EE Engine (if required): Between 64 MB and 4096 
MB, depending on the load of your SAP system. 

 
Make sure that you do not enter a value larger than 
the maximum Java heap size of your platform. For 
more information, see the documentation for your 
Java Development Kit (JDK). 

To check RAM, in the Windows Explorer choose Help → 
About Windows. 

• Paging file size (also known as virtual memory)  

• Paging File Size (also known as virtual memory):  

 32-bit: 1 GB plus 3 times RAM. Maximum required is 
10 GB.  
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Requirement Type Requirement 

 64-bit: At least 20 GB is recommended for standard 
installations (for more information, see SAP Note 
153641). If you want to install only a small system, 
contact your hardware partner for appropriate swap 
space values. 

To check paging file size: 
... 

a. Right-click My Computer and choose 
Properties. 

b. Choose Advanced → Performance Options. 

c. If required, in section Virtual Memory, 
choose Change. 

Software  • Dialog instance: 
Oracle 9.2.0 client software for Windows, 

• Current Oracle patch set and hot fix if available. 

 
For more information on the current patch set, see 
SAP Note 578683. 

• English international version of one of the following: 

 Windows Server 2003, Standard Edition  

 Windows Server 2003, Enterprise Edition  

 Windows Server 2003, Datacenter Edition 

 Windows 2000 Server 

 Windows 2000 Advanced Server 

 Windows 2000 Datacenter Server 

 
Note the following:  

For any version of Windows 2000, you need at least 
service pack 4. For more information on the latest 
service pack supported by SAP, see SAP Note 
30478. 

To check the Windows version: 
... 

a. Choose Start → Programs → Accessories → Command 
Prompt. 

b. Enter the command winver 

• Suitable Windows Resource Kit is strongly recommended. 

Other  • Make sure that the host name fulfills the requirements listed 
in SAP Note 611361 (for example, the host name must not 
be longer than 13 characters). 

• If you want to install a printer on a decentralized host for the 
e printers for the SAP system, make sure that the printer 
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Requirement Type Requirement 
can be accessed under Windows. 

• Check that the network, dialog instance and operating 
system requirements are met. 
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1.5  Installation Preparations 
 

Make sure that you read the Installation Checklists [Page 22] before you start 
the installation preparations. 

1.5.1  Checking for the Windows File System 
Use 
You need to check that you are using the Windows File System (NTFS) on hosts where you 
want to install the SAP system and database. NTFS supports full Windows security and long 
file names. 

 
You must use NTFS for an SAP system installation.  

Do not install the SAP directories on an FAT partition. 

Procedure 
... 

1. Open the Windows Explorer. 

2. Select the root directory. 

3. Choose File → Properties → General. 

4. The system displays the type of file system in use. 

5. Check that the file system is NTFS. 

1.5.2  Checking the Windows Domain Structure 
Use 
In Windows, you can implement either of the following domain models for the SAP system: 

• Extra domain 

In this model, the SAP system is embedded in its own domain, which is specially 
defined for SAP. A second domain exists for the user accounts. 

In Windows, the SAP domain and user domain must be incorporated in a domain tree. 
In this tree, the user accounts must form the root domain and the SAP domain must be 
a child domain of this. 

• Single domain 

In this model, the SAP system and the user accounts are included in a single domain. 

Prerequisites 
• You are performing a domain installation. 

• You are familiar with checking Windows domain structures. For more information, see 
the Windows documentation. 
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You cannot create local users and groups on the host that is used as domain 
controller. Therefore, we do not support running an SAP instance (including 
the database instance) on the host where the Domain Name System (DNS)  
service is installed.  

Procedure 
For a domain installation, we recommend that you check that all SAP system and database 
hosts are members of a single Windows domain. We recommend this for all SAP system 
setups.  

 
You do not need this step for a local installation. 

1.5.3  Reducing the Size of the File Cache 
Use 
The Windows file cache directly competes with SAP programs for working memory by 
pushing them out of the memory. Therefore, you should minimize the file cache as described 
below. 

Procedure 
... 

1. Do one of the following: 

 Windows Server 2003: 

Choose Start → Control Panel → Network Connections → Local Area 
Connections. 

 Windows 2000: 

Choose Start → Settings → Control Panel → Network and Dial-up Connections 
and double-click Local Area Connections. 

2. In the Local Area Connection Status dialog box, choose Properties. 

3. In the Local Area Connection Properties dialog box, double-click File and Printer 
Sharing for Microsoft Networks. 

 
If you cannot select File and Printer Sharing for Microsoft Networks, this option 
has not yet been installed. To install it, you need the Windows Server CDs. 

4. Select Maximize data throughput for network applications. 

5. To confirm your entries, choose OK. 

 

1.5.4  Granting User Rights for the Installation 
Use 
You need to make sure that you have the required rights and privileges that authorize you to 
install the SAPinst tool and the SAP system. 
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If you attempt the installation without the required authorization, the system 
aborts.  

If necessary, you have to ask the system administrator to grant you the necessary 
authorization before you start the installation. 

Prerequisites 
• The authorization required depends on whether you intend to perform a domain or local 

installation. For more information, see the sections Installation Planning and System 
Configuration. 

• A domain installation requires a domain controller to store user and account 
information centrally for the whole system. 

  
For performance and security reasons, make sure that you do not run an SAP 
instance (including the database instance) on the host where the domain 
controller is running.  

Never perform a local installation on a domain controller. 

Procedure 

Local Installation  
... 

1. Check that you have Local Administration rights for the central instance 
host. 

In a local installation, all Windows account and user information is stored locally on one 
host and is not visible to any other hosts in the system. 

2. If required, obtain these rights by asking the system administrator to enter you as a 
member of the Local Admins group. 

Domain Installation 
... 

1. Check that you have Domain Administration rights. 

In a domain installation, the user information is stored centrally on the domain 
controller and is accessible to all hosts in the system. 

2. If required, obtain these rights by asking the system administrator to enter you as a 
member of the Domain Admins group. 

 
If you are not granted domain administration rights, you can perform the 
installation as a domain user who is a member of the local administrator group. 
However, the domain administrator has to prepare the system appropriately for 
you.  

For more information, see Performing a Domain Installation without being a 
Domain Administrator [Page 58]. 
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1.5.4.1  Performing a Domain Installation Without Being a 
Domain Administrator 
Use 
If you are not granted domain administrator rights, you can perform the installation as a 
domain user who is a member of the local administrator group. In this case, the domain 
administrator must prepare the system for you appropriately, as described in this section. 

 
You normally perform a domain installation of the SAP system as a user with 
domain administration rights, as described in Granting User Rights for the 
Installation [Page 57].  

The domain administrator has to: 
... 

1. Create the new global group SAP_<SAPSID>_GlobalAdmin. 

2. Create the two new SAP system users <sapsid>adm and 
SAPService<SAPSID>.  

3. Add the users <sapsid>adm and SAPService<SAPSID> to the newly created 
group SAP_<SAPSID>_GlobalAdmin. 

Prerequisites 
You must perform this procedure as a domain administrator.  

Procedure 

Creating the New Global Group SAP_<SAPSID>_GlobalAdmin 
... 

1. Log on as domain administrator. 

2. To start the Active Directory Users and Computers Console, choose: 

Start → Programs → Administrative Tools → Active Directory Users and Computers  

 
If you cannot find Active Directory Users and Computers, start it as follows: 

a. Choose Start → Run and enter mmc. 

b. Choose Console → Add/Remove Snap-in... → Add. 

c. Select Active Directory Users and Computers. 

d. Choose Add. 

e. Choose Close → OK. 

3. Right-click Users in Tree, and choose: 

New → Group 

4. Enter the following: 

Group name: SAP_<SAPSID>_GlobalAdmin 



1   Standard Installation   

1.5   Installation Preparations 

60 August 2004 

 

Enter the SAP_<SAPSID>_GlobalAdmin group exactly as specified in the 
correct uppercase and lowercase. 

5. Select the following: 

a. Group scope:  Global 

b. Group type:  Security 

6. Choose OK. 

Creating the New SAP System Users <sapsid>adm and 
SAPService<SAPSID> 
... 

1. In Active Directory Users and Computers Console, right-click Users in Tree and 
choose: 

New → User 

2. Enter the following: 

 
Enter the <sapsid>adm and SAPService<SAPSID> user exactly as specified 
in the correct uppercase and lowercase. 

Field Input for  

<sapsid>adm 

Input for 
SAPService<SAPSID> 

First name: None None 

Initials: None None 

Last name: None None 

Full name: <sapsid>adm SAPService<SAPSID> 

User logon name: <sapsid>adm SAPService<SAPSID> 

User logon name  
(before Windows 2000): 

<sapsid>adm SAPService<SAPSID> 

3. Choose Next and enter the following: 

Password: <password> 

Confirm password: <password> 

4. Select Password never expires 

 
Make sure that no other options are selected. 

5. Choose Next → Finish. 

Adding the <sapsid>adm User to the SAP_<SAPSID>_GlobalAdmin 
Group 
... 

1. In the Users folder, double-click the newly created user account in the list on the 
right. 

2. Choose Member → Add. 
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3. Select the new SAP_<SAPSID>_GlobalAdmin group and choose Add to add it to 
the list. 

 
By default, the user is also a member of the Domain Users group. 

4. Choose OK twice. 

Adding the SAPService<SAPSID> User to the 
SAP_<SAPSID>_GlobalAdmin Group 
... 

1. In the Users folder, double-click the newly created user account 
SAPService<SAPSID> in the list on the right. 

2. Choose Member → Add. 

3. Select the new SAP_<SAPSID>_GlobalAdmin group. 

4. Choose Add to add it to the list. 

5. Choose OK. 

 
The SAPService<SAPSID> user must not be a member of the domain users 
group.  

To remove this group from the Member of list: 

i. Select the SAP_<SAPSID>_GlobalAdmin group. 

ii. Choose Set Primary Group. 

iii. Select the domain users group. 

iv. Choose Remove to delete it from the Member of list. 

6. Choose OK to close SAPService<SAPSID> Properties. 

7. Close the Active Directory Users and Computers Management Console. 

1.5.5  Choosing the SAP System IDs 
Use 
You need to choose an SAP system ID that identifies the whole system. This ID has to be 
entered for the variable <SAPSID> when you install the central instance.  

 
• You cannot change the SAP system ID after the installation. 

• If you want to install a standalone gateway you must choose a SAP 
System ID that is different from the SAP System ID of the central 
instance. 

Procedure 
... 

Make sure that you system IDs: 

• Are unique throughout your organization 

• Consist of exactly three alphanumeric characters 
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• Contain only uppercase letters 

• Have a letter for the first character 

• Do not include any of the following, which are reserved IDs: 

ADD ALL AND ANY ASC COM DBA END EPS FOR GID IBM INT KEY LOG MON 
NIX NOT OFF OMS RAW ROW SAP SET SGA SHG SID SQL SYS TMP UID USR 
VAR 

 
Choose your SAP system ID carefully. Renaming is complicated and requires 
you to re-install the SAP system. 

 
If you intend to install a dialog instance on the database host, make sure that 
the DBSID is different from the dialog name, otherwise the installation will not 
continue. 

The dialog instance name is made up as follows: letter D (system setting) and 
instance number (user setting), for example D01.  

1.5.6  Preparing the SAP System Transport Host 
Use 
You need to prepare one transport host in the SAP system. This host has the function of 
controlling the import or export of files between the current SAP system and other SAP 
systems (for example, a test or development system). 

The transport host uses the usr\sap\trans directory to temporarily store files that have 
been exported from one system and are waiting to be imported into another system. 
Depending on your requirements, you can decide to use the central instance host, the dialog 
instance host, or any other host as the transport host. 

 
For more information on preparing the SAP system transport host, see SAP 
Note 360515. 

Procedure 
... 

1. Map the IP address of the transport host to the alias SAPTRANSHOST, using one of 
the following methods: 

 On the DNS server 

If a DNS server is available for your system, ask your administrator to map the 
IP address of the transport host to the alias SAPTRANSHOST. 

The DNS server is a database that contains a set of files with information about 
the TCP/IP network, including the mapping of host names or aliases to IP 
addresses.  

 In the hosts files 

If no DNS server is available, you can map the IP address to the alias 
SAPTRANSHOST in the hosts file, which you can find in the Windows default 
directory:  
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<Drive>:\%windir%\system32\drivers\etc  

Perform the mapping as follows: 
... 

i. Open the hosts file with an editor. 

ii. Add the following line: 

<IP_address> <hostname> SAPTRANSHOST 

This step assigns the alias SAPTRANSHOST to the transport host. 

iii. Copy the newly edited hosts file to all hosts where an SAP instance is 
to run. 

 
If the transport host has more than one network card, take special care when 
you determine the IP address that is entered in the hosts file or on the DNS 
server: 

• Make sure that you enter the main IP address and that the binding order 
is correctly defined. 

• To check the binding order, choose: 

Start → Settings → Network and Dial-up Connections → Advanced → 
Advanced Settings 

2. If your transport host is not the central instance host, you have to create the 
transport directory as follows: 

... 

a. On the transport host, create the directory \usr\sap\trans. 

b. Grant  Everyone the permission Full Control for the directory. 

 
These permissions are only necessary during the SAPinst installation.  

After the installation, you only need grant Full Control on the directory to the 
SAP_<SID>_GlobalAdmin groups of all the systems that are part of your 
transport infrastructure. SAPinst assigns the appropriate rights with the help of 
an additional SAP_LocalAdmin group.  

For more information, see Automatic Creation of Accounts and Groups [Page 
126]. 

c. If no SAP instance is to be installed on the transport host, share the 
usr\sap directory on the transport host as SAPMNT. 

This enables SAPinst to address the transport directory in the standard way as 
\\SAPTRANSHOST\SAPMNT\trans. 

Result 
You have configured your system so that the installation tool SAPinst can recognize the 
transport host. 
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1.5.7 Preparing the System for SAPinst 
Use 
You use this procedure to prepare your installation host for SAPinst.  

The installation tool SAPinst uses the Java-based graphical user interface SAPinst GUI.  

 
If required, you can perform a remote installation using a standalone SAPinst 
GUI on a separate Windows or UNIX host. This enables you to perform the 
installation on a remote host while monitoring it with the SAPinst GUI from a 
local host. If you want to perform a remote installation, see Remote Installation 
with SAPinst [Page 114]. In this case, prepare both the local and the remote 
host for SAPinst. 

To prepare the system for SAPinst and SAPinst GUI you need to do the following: 

• Check your Java Runtime Environment (JRE) on the host where SAPinst GUI runs, 
because the JRE cannot be integrated into the SAPinst GUI executable for all platforms 
due to licensing issues. 

• Set the DISPLAY environment variable if you are installing on UNIX. 

Procedure 
... 

1. Check that a released Java Runtime Environment (JRE) exists on the host where 
the SAPinst GUI is to run:  

Platform Required JRE for the SAPinst GUI 

Windows 64 
bit (ia64), 
Linux (ia64), 
Linux for 
zSeries 
(s390x),  

z/OS (OS390 
resp. z/OS) 

The required JRE version is the same as for SAP Web AS 6.40. For the actual 
required JRE version see SAP Service Marketplace at 
service.sap.com/platforms →  Product Availability Matrix  → SAP 
NetWeaver  → SAP NetWeaver 04  → JSE Platforms 

 
• JRE is not part of the SAP shipment. If necessary, you need to 

download and install it. 

• To check the version of an already installed JRE, enter:  
java –version 

• If you have more than one Java Virtual Machine (JVM) installed 
on your system (for example, you have two JREs with different 
versions installed), make sure that the SAPINST_JRE_HOME 
environment variable (on UNIX: for user root) is set to the valid 
<JAVA_HOME> directory. 

 

UNIX only: 
You must include the path to a valid <JAVA_HOME>/bin directory in the path for 
user root or set the SAPINST_JRE_HOME environment variable for the user root 
to the valid <JAVA_HOME> directory as follows: 

Shell Used Command 

Bourne shell SAPINST_JRE_HOME=<path_to_JAVA_HOME> 



  1   Standard Installation 

  1.5.7 Preparing the System for SAPinst 

August 2004 65 

(sh) export SAPINST_JRE_HOME 

C shell (csh) setenv SAPINST_JRE_HOME <path_to_ 
JAVA_HOME> 

Korn shell (ksh) export SAPINST_JRE_HOME=<path_to_ 
JAVA_HOME> 

 

 

Windows 32 
bit (x86), 

HP-UX (PA-
Risc), 

HP-UX (ia64), 

Solaris 
(sun4u) 

No special JRE is required for the SAPinst GUI, because the JRE is integrated in 
the SAPinst GUI executable. 

 
As the JRE is temporary extracted on your host, you need at least 
about 40 – 80 MB of free disk space for that purpose. 
After the installation, SAPinst removes this JRE from your host 
automatically. 

 

Other 
platforms 

The required JRE is 1.3.0 or higher. 

 
• JRE is not part of the SAP shipment. If necessary you need to 

download and install it. 

• To check the version of an already installed JRE, enter: java –
version 

• If you have more than one Java Virtual Machine (JVM) installed 
on your system (for example, you have two JREs with different 
versions installed), make sure that the SAPINST_JRE_HOME 
environment variable (on UNIX: for user root) is set to the valid 
<JAVA_HOME> directory. 

UNIX only: 
You must include the path to a valid <JAVA_HOME>/bin directory in the path for 
user root or set the SAPINST_JRE_HOME environment variable for the user root 
to the valid <JAVA_HOME> directory as follows: 

Shell Used Command 

Bourne shell 
(sh) 

SAPINST_JRE_HOME=<path_to_JAVA_HOME> 

export SAPINST_JRE_HOME 

C shell (csh) setenv SAPINST_JRE_HOME <path_to_ 
JAVA_HOME> 

Korn shell (ksh) export SAPINST_JRE_HOME=<path_to_ 
JAVA_HOME>  

 

2. UNIX only:  
Make sure that your DISPLAY environment variable is set to <host_name>:0.0, 
where <host_name> is the host on which the SAPinst GUI is to be displayed. 
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3.  

Shell Used Command 

Bourne shell 
(sh) 

DISPLAY=<host_name>:0.0 

export DISPLAY 

C shell (csh) setenv DISPLAY <host_name>:0.0 

Korn shell 
(ksh) 

export DISPLAY=<host_name>:0.0 

 

1.5.8  Preparing the Installation CDs and DVDs 
Use 
You use this procedure to prepare the installation CDs and DVDs. 

 

Procedure 
1. Using Media Information for SAP R/3 Enterprise, identify the required CDs and DVDs for 

your installation and keep them separate from the remaining CDs and DVDs. This avoids 
mistakes between CDs and DVDs with similar names, so that you use the correct CDs 
and DVDs for your installation. 

 
The CD and DVD names in the table below are abbreviated.  

You can find the full names in Media Information for mySAP R/3 Enterprise on 
SAP Service Marketplace at: service.sap.com/instguides  SAP 
Components  SAP R/3 Enterprise  SAP R/3 Enterprise Core 4.70 / Ext. Set 
2.00 (SR1) 

The following table shows the required CDs and DVDs: 

SAP Instance 
Installation 

Required CDs or DVDs 

SAP Installation Master DVD 

SAP Kernel CD 

SAP Web AS Java DVD (includes CD IGS folder 
IGS_SOFT for the installation of IGS) 

Central instance 

Database DVD 

SAP Installation Master DVD 

SAP Kernel CD 

All Export CDs 

Database instance for a 
non-MCOD installation 

Database DVD 

SAP Installation Master DVD 

SAP Kernel CD 

Database instance for an 
MCOD installation 

All Export CDs 
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SAP Installation Master DVD 

SAP Kernel CD 

SAP Web AS Java DVD (includes CD IGS folder 
IGS_SOFT for the installation of IGS) 

Dialog instance  

Database DVD  

Gateway instance SAP Presentation DVD 

 
For the installation of a Unicode SAP system, the Unicode SAP Kernel CD is 
required. For the installation of a non-Unicode SAP system, the non-Unicode 
SAP Kernel CD is required. 

... 

 
We recommend that you make all required CDs and DVDs available in parallel. 

2. Use one of the following methods to make CDs and DVDs available in parallel: 

 Before the installation: 

 Have sufficient CD and DVD drives 

 Copy CDs and DVDs manually to local hard disks 

 
Do not use network drives for your CDs and DVDs. 

 During the installation: 

Use the SAPinst CD Browser dialog [Page 67], that is, you can check the 
entered location and then copy the entire CD or DVD to the path you entered in 
column Copy Package to. 

1.5.8.1  Using the CD Browser Dialog 
Use 
During the installation procedure SAPinst first checks and finally verifies the availability 
and location of the required installation CDs and DVDs. SAPinst does this by displaying a CD 
Browser dialog, which prompts you for the file LABEL.ASC, which contains information about 
the software package to be installed. 

 
To find the correct location of the file LABEL.ASC, look in the file README.TXT  
if available, located in the root directory of the relevant CD and DVD. 

Procedure 
SAPinst displays the CD Browser dialog in the following situations: 

• SAPinst wants to check the availability of the software package in advance. 

In this case, you see Check Location displayed in the CD Browser window. 

Choose one of the following actions: 

Situation Action Result 
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Situation Action Result 

You are not yet 
sure where to 
set up the 
software 
package. 

Do not enter any Package 
Location and do not select 
Check Location. 

SAPinst skips the check and you can 
continue the installation procedure. 
However, SAPinst asks later for the 
missing LABEL.ASC (see final bullet 
point below). 

You know where 
the software 
package will be 
but have not yet 
set it up. 

Enter the path in Package 
Location but do not select 
Check Location. 

SAPinst skips checking the label 
location, but your entered package 
locations are used later for the 
installation. 
SAPinst only asks again for a 
missing LABEL.ASC if the package 
location is incorrect (see final bullet 
point below). 

You have 
already set up 
the software 
package at a 
specific location. 

Enter the path in Package 
Location and select Check 
Location. 

 

SAPinst checks the label location 
and displays an error message if the 
location is incorrect. 

If all locations are correct, SAPinst 
does not ask again for the 
LABEL.ASC files. 

 

• SAPinst cannot find the correct LABEL.ASC but needs the location of the software to 
process the installation now. 

You can recognize this situation because Check Location in the CD Browser window is 
empty. You must now enter the path to the correct LABEL.ASC. Otherwise, the 
installation cannot continue. 

 
When SAPinst prompts for a folder <FOLDER_NAME> on a CD or DVD, make 
sure that you enter the path to the corresponding directory on this DVD 
(<CD_or_DVD>\<FOLDER_NAME>). 

In addition, you can copy the installation package by entering a location in the column 
Copy Package to. 

1.5.9  Preparing the Active Directory 
Use 
If you decided to use LDAP directory services [Page 39], you need to prepare the Active 
Directory. The SAP system can then use the Active Directory to store and access data. 

To prepare the directory, you use the R3SETUP tool to automatically: 

• Extend the Active Directory schema to include the SAP-specific data types 

• Create the domain accounts required to enable the SAP system to access and modify 
the Active Directory. These are the group SAP_LDAP and the user sapldap. 

• Create the root container where information related to SAP is stored 

• Control access to the container for SAP data by giving members of the SAP_LDAP 
group permission to read and write to the directory 
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For more information on how to set up a Netscape / iPlanet directory server, see 
the documentation R/3 System Information in Directory Services on SAP 
Service Marketplace at  service.sap.com/msplatforms → Microsoft → 
Windows Server. 

Prerequisites 
• A Windows domain controller with an Active Directory must be installed on the network. 

• You must have an SAP Kernel CD of an SAP system installation that is based on SAP 
Web Application 6.10, SAP Basis 4.6D, or lower and contains the previous installation 
tool R3SETUP. 

 
If you do not have an SAP Kernel CD with R3SETUP, you can download one 
from SAP Service Marketplace at service.sap.com/installations → 
SAP Installations and Upgrades  Entry by Application Group  SAP 
NetWeaver Components  SAP NetWeaver Components ( < SAP NW 04 )  
SAP Web AS → SAP Web AS 6.10 → NT/I386 → <your_database>. 

Procedure 

Installing the R3SETUP Tool 
You use this procedure to install the R3SETUP tool on the domain controller where the Active 
Directory is located. 
... 

1. Log on to the domain controller as domain administrator. 

2. Check that the TEMP environment variable has been set: 

a. Right-click My Computer on the Windows desktop 

b. Choose Properties → Advanced → Environment Variables. 

TEMP is normally set to: 

%userprofile%\Local Settings\Temp 

For more information, see SAP Note 387745. 

3. Insert the SAP Kernel CD. 

4. Start the program R3SETUP.BAT from the directory 

<CD_DRIVE>:\NT\COMMON 

The R3SETUP window opens. 

5. Enter the following when R3SETUP prompts you: 

 The name of your SAP system <SAPSID> 

 The directory on your hard disk that the R3SETUP files are to be copied to. The 
default directory is <DRIVE>:\USERS\<SAPSID>ADM\INSTALL 

When you have made all the required entries, the R3SETUP tool is automatically 
installed. 

6. Choose Yes when a dialog box appears prompting you to log off or reboot. 

The R3SETUP tool now automatically logs off or reboots. 
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Configuring the Active Directory 
... 

1. Log on as the same user that installed the R3SETUP tool. 

2. Choose Start → Programs → SAP system Setup for <SAPSID> → Configure 
Active Directory for SAP. 

3. When you are prompted: 

 Confirm the name of the domain where the SAP_LDAP group is to be created. 
This is the domain that you are logged on to. 

 Enter the password of the sapldap user. 

When you have made these entries, the R3SETUP tool automatically configures the 
Active Directory. 
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1.6  Installation Process 
 

Make sure that you read the Installation Checklists [Page 22] before you start 
the installation. 

1.6.1  Installing the Oracle Database Software 
Use 
You install the Oracle 9.2.0 database software.  

• For a 32-bit system there are three RDBMS CDs. They are located on the RDBMS 
DVD for 32-bit in the directories ORA92_1 to ORA92_3. 

• For a 64-bit system there are two RDBMS CDs. They are located on the RDBMS DVD 
for 64-bit in the directories ORA92_1 to ORA92_2. 

 
During the installation, you are prompted to specify the correct path to CD2 and 
CD3, if applicable. To avoid this, you can copy the CDs to disk as follows 
before the installation: 

a. Copy the contents of ORA92_1\NT\<platform> on the RDBMS DVD to 
\disk1 on your hard disk.  

b. Repeat this for the second CD. 

c. For a 32-bit system, also repeat this for the third CD. 

\disk1 to \disk3 can be on a network drive if required. 

 
You must run different files to install the client and the server software. 

 
MSCS only: 
Install the Oracle 9.2.0 software on both nodes. 

Procedure 
... 

1. Start the Oracle Universal Installer as follows: 

 Place the Oracle RDBMS DVD for 32-bit or 64-bit in the DVD drive and start 
from <DVD_DRIVE>:\ORA92_1\NT\<platform> 

 If you have copied the CDs to disk, start from \disk1 

On the database server, double-click the file sapserver.cmd 

On the database client double-click the file sapclient.cmd  

2. Enter the information as shown in the following table. 

Window Entry 
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Window Entry 

File Locations Under Source: 

For Path: 

Shows the path to the Oracle source software. Do not change 
the path. 

Under Destination: 

For Name: 

Enter the name of the new Oracle Home directory. We 
recommend that you use the name 
<SAPSID><ORACLE_VERSION>, for example, C11920 

For Path 
Enter the path of a new Oracle Home directory. We recommend 
that you use the path: 

<DRIVE>:\ORACLE\<DBSID>\<ORA_VERS>, for example,  

C:\ORACLE\C11\920 

 
Do not specify an already existing Oracle Home 
directory. You must specify a new directory. 

You need 2.2 GB disk space for the Oracle 9.2.0 
server software and about 250 MB for the Oracle 
9.2.0 client software 

Choose Next. 

Oracle Server Software 
only: 

Create Database 

Choose No and then Next. 

Summary Choose Install. 

Oracle Server Software 
only: 

Oracle Net 
Configuration 
Assistant: Welcome 

If this dialog appears, select Perform typical configuration.  

File Locations / End of 
Installation 

Choose Exit. 

 

3. Install the latest patch set and hot fix (if available) as described in SAP Note 
578683 and the patch_note.htm file on the patch CD. 

 
MSCS only: 

You have to install the current Oracle patch set and hot fix (if available) on both 
nodes. 
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1.6.2  Running SAPinst 
Use 
This procedure tells you how to run SAPinst to install one or more SAP instances. 

It describes an installation where SAPinst GUI and SAPinst server are running on the same 
host. If you want to perform a remote installation (SAPinst GUI is running on another host), 
see Remote Installation with SAPinst [Page 114]. 

SAPinst normally creates the installation directory sapinst_instdir directly below the 
Program Files directory. 

 
Each SAP instance requires a separate installation directory. 

The SAPinst Self-Extractor extracts the executables to a temporary directory ($TEMP, $TMP, 
$TMPDIR, or $SystemRoot). These executables are deleted after SAPinst has stopped 
running. Directories with the name sapinst_exe.xxxxxx.xxxx sometimes remain in the 
temporary directory. You can safely delete them. 

 
In the temporary directory you can also find the SAPinst Self-Extractor log file 
dev_selfex.out, which might be useful if an error occurs. 

If you want to terminate SAPinst and the SAPinst Self-Extractor, do one of the following: 

• Right-click the icon for the SAPinst output window located in the Windows tray and 
choose Exit. 

• Click the icon for the SAPinst output window located in the Windows tray and choose 
File → Exit.  

Prerequisites 
• You need at least 50 MB of free space in the installation directory for each ABAP 

installation service. In addition, you need 60-200 MB free space for the SAPinst 
executables. If you are not able to provide 200 MB free space in the temporary 
directory, you can set one of the environment variables TEMP, TMP or TMPDIR to 
another directory with 200 MB free space for the SAPinst executables. 

 
We recommend that you keep all installation directories until the system is 
completely and correctly installed.  

 
If SAPinst cannot find a temporary directory, the installation terminates with the 
error FCO-00058. 

• If you are installing a second or subsequent SAP system into an existing database, 
make sure that the database is up and running before starting the installation. For 
more information, see Installation of Multiple Components in One Database [Page 36]. 

SAPinst GUI Handling 

The following push buttons are available on the different SAPinst GUI dialogs (input screens, 
installation progress screen, message boxes): 
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Push 
Button 

Meaning 

Back Displays the previous dialog for editing. 

Next Displays the next dialog for editing. 

Cancel Cancels the installation with the following options: 

− Stop 
Stops the installation without further changing the installation files. You 
can continue the installation later from this point. 

− Reset 
Resets all installation input files. All files in the installation directory are 
removed from the system and no log files are saved. You must restart 
the installation from the beginning. 

Log Off Cancels the connection to the SAPinst GUI only. The SAPinst server keeps 
on running. 

 
Typical use case: 

You need to log off during the installation (for what reason ever) 
from the host where you control the installation with SAPinst 
GUI. 
Then you can connect from another host to the running 
installation. Be aware that you need the SAP Installation Master 
DVD for that. 

For more information on running SAPinst GUI standalone, see 
Starting SAPinst GUI on the Local Host [Page 115]. 

View Log Displays the content of the sapinst.log file during the installation. 

Retry Performs the installation step again (if an error has occurred). 

Stop Stops the installation without further changing the installation files. You can 
continue the installation later from this point. 

Reset Resets all installation input files. All files in the installation directory are 
removed from the system and no log files are saved. You must restart the 
installation from the beginning. 

Continue Continues with the option you have chosen before. 

 
If a message box comes up and you choose Cancel, SAPinst 
then offers you the options Continue, Stop, Reset. Do not 
choose Continue, but choose Stop or Reset. If you choose 
Continue an error occurs. 

 

Procedure 
... 

1. Log on to your host as a user who is a member of the local administration group. 

2. Insert the SAP Installation Master DVD in your DVD drive or mount it locally. 
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If you want to install a gateway instance you have to use the SAP Presentation 
DVD. In this case, replace <SAP Installation Master DVD> with <SAP 
Presentation DVD> in this section. 

3. Start SAPinst from the SAP Installation Master DVD in one of the following ways: 

 Using the default installation directory 

Double-click sapinst.exe from the following path: 

<DVD drive>:\IM<x>\SAPINST\NT\<platform> 

 

To find the SAPinst executable in your platform-specific IM<x> directory, look in 
the README.TXT file on the SAP Installation Master DVD. 

 
On Windows 64-bit, the path to SAPinst is as follows: 
<SAP_Installation_Master_DVD>\IM1\SAPINST\NT\IA64 

SAPinst creates an installation directory where it keeps its log files. By default 
the installation directory is located below 
%ProgramFiles%\sapinst_instdir. The exact name of the subdirectory 
depends on the installation service chosen by you. 

 Using an alternative installation directory 

If you want SAPinst to use a directory other than the default, you can create a 
new one manually: 

i. Open a command prompt and enter: mkdir <SAPinst_INSTDIR>. 

ii. Change to the installation directory: cd <SAPinst_INSTDIR>. 

iii. Enter 
<SAP_Installation_Master_DVD>\IM<x>\SAPINST\NT\<platfo
rm>\ 

SAPinst uses your installation directory as the current working directory for the 
installation. It does not create an installation directory called 
sapinst_instdir. 

SAPinst GUI starts automatically by displaying the Welcome screen.  

However, if there is only one component to install, SAPinst directly displays the first 
input dialog without presenting the Welcome screen. 

 
SAPinst uses the ports 21212 and 21213 during the installation for 
communication with SAPinst GUI. You get an error message if one of these 
ports is already used by another service. In this case, open a command prompt 
and change to <DVD drive>:\IM<x>\SAPINST\NT\<platform>. Run: 
.\sapinst.exe SAPINST_DIALOG_PORT=<free_port_number>.  
For example, if you enter 60000 as <free_port_number>, SAPinst uses the 
ports 60000 and 60001. 

4. In the Welcome screen, select the corresponding installation service from the tree 
structure as listed in the table below and choose Next. 
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Installation Procedure Installation Tasks in SAPinst 

Installing a central instance  SAP R3E 4.7x200 SR1  ABAP System   
<Unicode or non-Unicode>  Install a 
Central Instance 

Installing a database instance SAP R3E 4.7x200 SR1  ABAP System   
<Unicode or non-Unicode>  Install a 
Database Instance 

Installing a dialog instance SAP R3E 4.7x200 SR1  ABAP System   
<Unicode or non-Unicode>  Install a Dialog 
Instance 

Installing a gateway instance Install SAP Gateway 

SAPinst creates a subdirectory for the chosen installation service below the current 
working directory. If you started SAPinst using the default installation directory, the 
directory structure is: 

<sapinst_instdir>\<installation_service> 

5. If SAPinst prompts you to log off from your system, log off and log on again.  

SAPinst restarts automatically. 

6. Follow the instructions in the SAPinst dialogs. 

After you have entered all required input information, SAPinst starts the installation and 
displays the progress of the installation. If the installation was successful, the screen 
Finished installation is displayed. 

Troubleshooting 
• If an error occurs during the dialog phase, SAPinst: 

 Stops the installation 

 Displays a dialog informing you about the error 

You can now directly view the log file by choosing View Logs 

You must abort the installation with Stop or Reset, and try to solve the problem.  

• If an error occurs during the processing phase, SAPinst: 

 Stops the installation 

 Displays a dialog informing you about the error 

You can now: 

 Directly view the log file by choosing View Logs 

 Try to solve the problem 

 Continue the installation by choosing Retry. 

 Stop or Reset the installation 

For more information, see Interrupted Installation with SAPinst [Page 116]. 
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1.6.3  Input for the Installation 
The following table lists prompts that are required for the installation of the central, database, 
dialog and gateway instance. 

 
The table does not necessarily reflect the actual order in which the input 
windows appear during the installation. 

 

Throughout this section, the following abbreviations are used: 

• CI: Central instance 

• DB: Database instance 

• DI: Dialog instance 

• GW: Gateway instance 

 
If you install a gateway instance, SAP Gateway may appear in some of the 
screens nstead of ABAP. For example SAP Gateway > Definining the LDAP 
Parameters. 

 

 

Window Prompt Action 

SAPinst CD 
Browser > 
Checking Software 
Packages 

CD Name 

Package Location 

Check Location 

Copy Package To 
CI/DB/DI/GW 

This dialog only appears if the system wants 
to check or cannot find the file LABEL.ASC 
that contains the relevant installation 
information. For more information on the CD 
Browser dialog, see Preparing the installation 
CDs and DVDs [Page 66]. 

• CI, DI, DB, GW: 
Under Package Location, enter the path 
to the directory where the file 
LABEL.ASC is located.  

 
• To find the correct 

location of the 
installation 
package, look in 
the file 
README.TXT 
located in the root 
directory of the 
relevant CD or 
DVD. 

• When SAPinst 
prompts for a folder 
<FOLDER_NAME> 
on a DVD, make 
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Window Prompt Action 
sure that you enter 
the path to the 
corresponding 
directory on this 
DVD 
(<CD_or_DVD>\<
FOLDER_NAME>). 

 
DB only: 

If SAPinst prompts for a CD or 
DVD that is not required for your 
operating system or database, do 
not enter a Package Location and 
deselect the flag Check Location 
for this CD or DVD (see Preparing 
the installation CDs and DVDs 
[Page 66]. 

ABAP System > 
Specifying Logon 
Data for RFC 
Connection 

Password 
DI/DB 

This prompt only appears if: 

• The DDIC password is not set to its 
default value during the installation (for 
example, as you logged on to the SAP 
system during the installation and the 
SAP system prompted automatically for 
a new password). 

In this case, enter the changed password 
of user DDIC. 

• The SAP system is not running or can 
not be accessed on the network. 

In this case, eliminate the cause (for 
example, start your SAP system), enter 
the default DDIC password and continue 
the installation. 

Welcome Select the service 
to install 
CI/DB/DI/GW 

Choose SAP R3E 4.7x200 SR1 →  ABAP 
System → <Unicode or non-Unicode> and 
choose the installation service you want to 
install:  

 
When you install the SAP system 
for the first time, you first have to 
install the central instance before 
you install the database instance. 

• CI: Install a  Central Instance 

• DB: Install a Database Instance 

• DI: Install a Dialog Instance 

• GW: Install SAP Gateway 
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Window Prompt Action 

ABAP System > 
Selecting the SAP 
System ID 

SAP System 
Identification: 

SAP System ID 
(SAPSID) 
DB 

Enter exactly the name of the SAP system 
<SAPSID> that you have entered during the 
central instance installation. 
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Window Prompt Action 

ABAP System > 
Selecting the 
Database Instance 
Installation Method 

Database 
Installation 
Method 
DB 

• If you want to install a new SAP system,  
choose Standard Installation 

• If you want to copy or migrate an existing 
SAP system, choose one of the following 
methods. For more information on each 
method, see the documentation 
Homogeneous and Heterogeneous 
System Copy for SAP Systems Based on 
SAP Web Application Server 6.40. 

 If you want to copy or migrate an 
existing SAP system with the 
R3load method, choose System 
Copy / Migration (R3load). 

 If you want to reinstall the target 
database while keeping the SAP 
settings, choose System Copy / 
Migration by Reload: Refresh the 
database content (R3load). With 
this option, data stored in the 
target database will be deleted. 
Then, data from the source 
database will be reloaded. The 
reload service is not available for 
MCOD systems!  

 If you want to install the target 
system with the Migration Monitor 
to run export and import in 
parallel, choose System Copy / 
Migration using Migration 
Monitors (R3load). This option 
requires the installation of Java 
SDK 1.4 on both source and 
target database host. 

 If you want use a homogeneous 
system copy to generate a 
database instance System 
choose System Copy/Oracle 
Backup/Restore. With this option, 
you generate users and groups 
and the environment, if 
necessary.  
SAPinst stops the installation and 
asks you to generate the 
database manually via database 
copy or backup restore. When you 
have finished, SAPinst performs 
some post-installations steps, for 
example, initializing the work 
bench, generating temporary 
license keys, consistency checks. 
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Window Prompt Action 

ABAP System > 
Deciding Usage of 
Existing Database  

Usage of Existing 
Database 
DB  

• To install a system into an existing 
database (MCOD), select Yes, existing 
Database (additional SAP system). 

• In all other cases, select No, new 
Database (first SAP system). 

SAP System 
Instance 
Identification: 

SAP System ID 
DI 

Enter exactly the name of the SAP system 
<SAPSID> that you have entered during the 
central instance installation. 

Instance number 
DI 

Enter a number of the dialog instance. You 
can assign a value from 0 to 97, but not the 
numbers 2, 25, 43, 60, 72, or 89.  

If more than one SAP instance is running on 
the same host, these instances must be 
assigned different numbers. 

ABAP System > 
Specifying the 
Dialog Instance 
Common 
Parameters 

Instance Host 
DI 

Enter exactly the central instance number that 
you have entered during the central instance 
installation. 
To find out the instance number, look under 
the SAP directory 
usr\sap\<SAPSID>\DVEBMGS<nn>. The 
value <nn> is the number assigned to the 
central instance. 

SAP System 
Instance 
Indentification: 

SAP System ID 
(SAPSID) 
CI/DB/DI/GW 

• CI: 
Enter the SAP system <SAPSID> ID, for 
example, C11. For more information, see 
Choosing the SAP System IDs [Page 
61]. 

• DB/DI: 
Enter exactly the name of the SAP 
system <SAPSID> that you have entered 
during the central instance installation.  

ABAP System > 
Specifying the 
Central Instance 
Common  
Parameters 

SAP System 
Instance 
Indentification: 

Instance Number 
CI/DB/DI 

• CI: 
Enter the number of the central instance. 
You can assign a value from 0 to 97, but 
not the numbers 2, 25, 43, 72, or 89. 

• DB/DI: 
Enter exactly the central instance 
number that you have entered during the 
central instance installation. 
To find out the instance number, look 
under the SAP directory 
usr\sap\<SAPSID>\DVEBMGS<nn>. 
The value <nn> is the number assigned 
to the central instance. 
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Window Prompt Action 

 SAP System 
Instance 
Indentification: 

Instance Host 
CI/DB/GW 

• CI: 
Enter the name of the central instance 
host. 

• DB/DI: 
Enter exactly the name of the central 
instance host that you have entered 
during the central instance host. 

To find out the host name, enter 
hostname at the command prompt of 
the central instance host. 

• GW: 
Enter the name of the gateway instance 
host. 

Database 
Parameters: 

Database ID 
(DBSID) 
CI/DB/DI 

• CI: 
Enter the name of the database instance 
<DBSID>. 

 
If you install a system into an 
existing database (MCOD), enter 
exactly the name of the existing 
database. 

• DB, DI: 
Enter exactly the name of the database 
instance <DBSID> that you have 
entered during the central instance 
installation. 

ABAP System > 
Specifying the 
Database Instance 
Common 
Parameters 

Database 
Parameters: 

Database Host  
CI/DB/DI 

• CI, DB: 
Enter the name of the database host. To 
find out the host name, enter hostname 
at the command prompt of the database 
host. 

 
If you install a central system (that 
is, you want to install the central 
instance and the database 
instance on one host), enter the 
name of the central instance host. 

• DI: 
Enter exactly the name of the database 
instance host that you have entered 
during the central instance installation. 
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Window Prompt Action 

Instance Memory 
Management:  

Instance RAM 
(MB) 
CI/DB/DI/GW 

Enter RAM space that is reserved for the SAP 
instance. The default value is the entire RAM  
space.  

Be sure to reserve at least the minimum 
values required for your instance. 

ABAP System > 
Specifying the SAP 
Instance Host 
Parameters 

Domain 
Information for 
the SAP System 
Accounts 
CI/DB/DI 

Choose one of the following: 

• Local installation 

• Installation in the domain of the current 
user 

• Installation in a different domain 

Gateway 
Parameters: 

SAP System ID 
GW 

Enter the SAP system <SAPSID>, for 
example, G11. For more information, see 
Choosing the SAP System IDs. 

SAP Gateway > 
Specifiying the 
Gateway Instance 
Parameters 

Gateway 
Parameters: 

Instance number 
GW 

Enter the number of the gateway instance. 
You can assign a value from 0 to 97, but not 
the numbers 2, 25, 43, 60, 72, or 89. 
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Window Prompt Action 

LDAP Support 
CI/DI/GW 

If you want to use LDAP for SAP Logon or the 
Microsoft Management Console (MMC), 
choose the type of LDAP integration you want 
to configure for the SAP system. Otherwise, 
choose No LDAP: 

• Via Active Directory Service 

Select this option to integrate Windows 
Active Directory services. An Active 
Directory must be available on the 
network.  
(Profile parameter 
ldap/options=DirType=NT5ADS) 

• Via Generic LDAP Directory 

Select this option to configure the system 
to support LDAP directories that are 
running on Windows or UNIX machines. 
A generic LDAP directory must be 
available on the network.  

• No LDAP 

Select this option if you do not want to 
use LDAP for SAP Logon and/or MMC or 
if you do not want to use LDAP at all. 

Required Input  

Depending on your selection the information 
below is required. If you choose No LDAP, 
none of the LDAP parameters listed below 
has to be specified. 

ABAP System > 
Defining the LDAP 
Parameters 

Management 
Domain 

Specifies a container in the Active Directory 
where information related to the new SAP 
system is to be stored. Use the distinguished 
name syntax. The name of the container 
(management domain) can reflect the 
organizational structure of your company. For 
example, if the system is for corporate finance 
and located in Walldorf, the name can be: 
CN=Finance, CN=Walldorf.  

Profile parameter: ldap/saprdn 

You need not specify this. 

However in a large system landscape, we 
recommend setting this parameter to reflect 
the structure of multiple SAP installations. 
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Window Prompt Action 

LDAP Server Enter the DNS host name of the server on 
which the LDAP directory is running. If the 
directory is replicated on other servers in the 
network, specify these as well. For example: 
ldapsrv1 ldapsrv2. 

Profile parameter: ldap/servers. 

Note that the replica must be writeable. 

• Via Active Directory Service: 

We do not recommend setting this 
parameter. If you do not set this 
parameter, the system automatically 
finds the best ADS Server. 

• Via Generic LDAP Directory 

You must specify one or more LDAP 
servers, separated by blanks. 

 

Container for all 
SAP related 
entries 

Specifies the SAP root container in the LDAP 
directory under which all future information 
related to SAP systems is to be stored. Use the 
distinguished name syntax that specifies both 
the name of the container and the path to reach 
it. 

Profile parameter: ldap/saproot 

• Via Active Directory Service: 

We do not recommend setting this 
parameter. If you do no set this 
parameter, the system automatically 
calculates the default value to store 
information in the configuration context 
for Active Directory Service (ADS). 

• Via Generic LDAP Directory 

You must specify this parameter. 

ABAP System > 
Defining the 
Location of the 
SAP System 
Instance 
Directories 

Location of SAP 
System 
Executables 
CI/DB/DI 

• Yes, locate executables on central 
instance host  

This option is the default value, if you 
use a 64-bit Windows system. Select this 
option, also in a 32-bit system, if you 
install your SAP system in a mixed 
environment. For example, you install it 
on Windows and UNIX, or in a 32-bit and 
64-bit system operating system. 

• No preparation for other OS platforms 

This option is the default value in a 32-bit 
system.  Choose this option if you use a 
32-bit system. 
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Window Prompt Action 

Instance 
Installation Drive  
CI/DB/DI/GW 

Select the drive for the SAP base directory 
tree. 

For example, if you select D:, the directory 
usr\sap is created under drive D. 

 
If saploc already exists, you 
cannot select the local drive. 

 

Host with 
transport 
directory 
CI/DB/DI 

Enter the name of the host where the central 
transport directory is located. 

Database 
Instance 
Parameters: 

Database 
Schema 
CI/DB/DI 

Enter the name of the database schema 
(SAP<SCHEMA_ID>, whereas <SCHEMA_ID> 
must be exactly three characters long). 

 
For example, enter SAPDS1. 

 
We recommend not to use the 
default value SAP<SAPSID> for 
the database schema name. For 
more information read SAP Note 
617444.     

Database Home 
Information: 

DB Home 
CI/DB/DI 

Enter the name of the Oracle home. 

Oracle > Selecting 
the Database 
System Common 
Parameters 

Database Server 
Location: 

Drive for server 
directories,  

Drive for redo log 
archives 
(orarach) 
DB 

Select the drives where you want to store your 

• Server directories (saparch, sapbackup, 
sapreorg, sapcheck and saptrace) 

• Redo log archives (oraarch) 

Oracle > Changing 
Server Directory 
Distribution 

– 
DB 

Use the Back button to change the redo log 
file archive, sapbackup, sapreorg directories 
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Window Prompt Action 

SAP Gateway > 
Specifying SAP 
System Instance 
Directories 

Gateway 
Destination: 

Installation Drive 
GW 

Enter the drive where you want to install the 
gateway instance. 

ABAP System > 
Specifying 
Password for User 

OS User 
Parameters:  

SAP System 
Administrator  
 CI/DB/DI/GW 

• CI: 
Enter and confirm the password for this 
user.  

• DB/DI: 
Enter and confirm the same password 
that you used for the central instance. 

• GW: 
Enter and cofirm the password for this 
user.  

 
If the <sapsid>adm user already 
exists, use the same passwords 
that you used for this user. 

ABAP System > 
Specifying 
Password for User 

OS User 
Parameters: 

SAP System 
Service 
Administrator  
CI/DB/DI/GW 

• CI: 
Enter and confirm the password for this 
user.  

• DB/DI: 
Enter and confirm the same password 
that you used for the central instance. 

• GW: 
Enter and cofirm the for this user. 

 
If the SAPService<SAPSID> 
user already exists, use the same 
password that you used for thisd 
user. 

ABAP System > 
Defining SAP 
System Service 
Ports 

SAP System 
Ports:  

Message Port 
CI/DI 

• CI: 
Enter the port number of the Message 
Server. 

• DI: 
The port number of the Message Port 
must be the same as the one on the 
central instance host. 
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Window Prompt Action 

Oracle Listener 
Configuration: 

Listener Name, 

Listener Port 
CI/DB/DI 

• CI: 
Normally, you only have to adapt these 
parameters if the default name or default 
port is already in use. 

• DB: 

 If you are installing on a host 
where no other Oracle database 
is installed, you normally do not 
have to change the default values 
for Listener Name and Listener 
Port. 

 If there is already an Oracle 
database installed on your 
installation host, you can either 
use one listener for both 
databases (in this case, see SAP 
Note 98252 for more information) 
or you have to specify an unused 
Listener Name and an unused 
Listener Port for the new listener. 

• DI: 
The port number must be the same as 
the one on the central instance host. 

Oracle > Specifying 
the Oracle Listener 
Configuration 

Keep Existing 
Network 
Configuration 
Files: 

Keep listener.ora, 

Keep 
tnsnames.ora  
DB  

• If you have already installed an Oracle 
client or Oracle database instance, you 
can select these options to keep these 
files. 

• For a new installation you do not need to 
select these options. 

Oracle > Specifying 
the Database 
Server Parameters 

Advanced 
Configuration  
DB 

Decide whether you want to perform Advanced 
Configuration. With an advanced configuration, 
you can specify if you want to configure: 

• Database file systems 

• Parameters for database creation 

• Rollback segment parameters 

• Tablespace parameters 

 
Advanced database configuration 
should only be performed by 
certified database administrators.  

SAP recommends you to use the 
default settings if possible. 
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Window Prompt Action 

Oracle > Selecting 
the Installation 
Drives 

Destination 
Specification 
DB 

SAP recommends you to use the default 
settings for the database log files, if possible. 

Oracle > 
Configuring the 
Sapdata 
Directories 

Sapdata Drives 
DB 

SAP recommends you to use the default 
settings for the database data files, if 
possible. 

 
If you change the default settings, 
make sure that the total size of 
data and log files is greater than 
or equal to the default size set by 
SAPinst. 

You can change the database configuration 
later with database tools. 

Import Settings 
DB 

• If you are installing a new SAP system, 
this prompt does not appear 

• If you want to import the database dump 
of another SAP system as part of a 
homogeneous SAP system copy, 
leave the field Migration Key blank. For 
more information, see the documentation 
SAP Web Application Server 
Homogeneous and Heterogeneous 
System Copy). 

• If you want to import the database dump 
of another SAP system as part of a 
heterogeneous SAP system copy, 
enter the Migration Key. For more 
information, see the documentation SAP 
Web Application Server Homogeneous 
and Heterogeneous System Copy). 

General Load 
Settings 
DB 

These settings are for experts only. 

SAP Database 
Load > Specifying 
General Load 
Parameters 

Advanced 
Configuration of 
Packages 
DB 

Decide whether you want to perform 
Advanced package configuration.  

 
These settings are for experts 
only and should only be 
performed by certified database 
administrators. 

SAP recommends to use the default settings 
if possible. 
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Window Prompt Action 

ABAP System  > 
Choosing Multi 
National Language 
Support  

(Non-Unicode only) 

Multi National 
Language 
Support 
DB 

• If you do not want to install Multi National 
Language Support (MNLS), choose No 
MNLS Support required 

• If you want to install Multi National 
Language Support (MNLS), choose 
MNLS Support required. The installation 
then will stop before starting the SAP 
system to let you update the MNLS 
tables as described in SAP Note 73606 
before continuing the installation. 

 
You can also install additional 
languages later, but if you install 
any Support Packages in the 
meantime, you have to do one of 
the following: 

• Install the Support Packages 
again 

• Use the report 
RSTLAN_IMPORT_OCS to 
extract the language-relevant 
information from each 
Support Package 

Oracle > Setting 
Passwords of 
Database Users 

Passwords of 
OracleDatabase 
Users 
DB 

Enter and confirm the passwords for the 
following database users if required: 

• schema  

• sys 

• system 

• outln 

• dbsnmp 

Use SLD 
DB  

If you want to use the SAP System 
Landscape Directory, select Use SLD 

SLD Gateway Host 
DB 

Enter the name of the gateway host of the 
SAP System Landscape Directory. 
To find out the host name, enter hostname at 
the command prompt of the gateway host. 

ABAP System > 
Registering in 
System Landscape 
Directory (SLD) 

SLD Gateway 
Instance Number 
DB 

Enter the instance number of the gateway 
instance of the SAP System Landscape 
Directory. 
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Window Prompt Action 

ABAP System > 
Changing Default  
Password of ABAP 
Super User  

User DDIC 
DB 

 
This prompt does only appear if 
the password is still set to its initial 
value. 

Enter and confirm a new password for user 
DDIC. 

ABAP System > 
Changing Default  
Password of ABAP 
Super User  

User SAP*  

User SAPCPIC  
DB 

 
This prompt does only appear if 
the password is still set to its initial 
value. 

If prompted, enter and confirm a new 
password for user SAP*. 
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1.7  Post-Installation Activities 
 

Make sure that you read the Installation Checklists [Page 22] before you start 
the post-installation steps. 

1.7.1  Starting and Stopping the SAP System 
Use 
You use this procedure to check that you can start and stop the SAP system after the 
installation. You use the Microsoft Management Console (MMC) to start and stop the SAP 
system. 

 
The newly installed MMC only allows you to start or stop the SAP system 
locally on the host that you are logged on to. Later you can configure the MMC 
to enable central management of all hosts. 

For more information, choose the following in the SAP Library [Page 36]: 

Solution Life Cycle Management →  Computing Center Management System → 
Monitoring in the CCMS → Microsoft Management Console: Windows 

Prerequisites 
You have logged on to the SAP system host as user <sapsid>adm. 

Procedure 

Starting the SAP System 
... 

1. To start the central services instance, central instance and database instance, do 
the following: 

a. On the SAP system host, choose Start → Programs → SAP Management Console 

b. Right-click the SAP system node and choose Start. 

The central services, central instance, and database start. 

2. If you have installed a dialog instance on another host, repeat the above steps on 
the dialog instance host. 

Stopping the SAP System 
... 

1. If you have installed a dialog instance on a dialog instance host, you first have to 
stop the dialog instance before you stop the central services instances, and the 
database instance. Perform the following steps: 

a. On the dialog instance host, choose Start → Programs → SAP Management 
Console 

b. Right-click the SAP system node and choose Stop. 

2. To stop the central services instance, central instance and database instance, do 
the following: 

... 

a. On the SAP system host, choose Start → Programs → SAP Management Console 
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b. Right-click the SAP system node and choose Stop. 

The database, central services and central instance stop. 

1.7.2  Logging On to the SAP System 
Use 
You need to check that you can log on to the SAP system using the standard users. 

Prerequisites 
You have already started the SAP system and installed a front end. 

There are two standard users in the SAP system after the installation: 

User Initial Password Client 

SAP* 06071992 000, 066 

DDIC 19920706 000 

 
During the installation, SAPinst prompts you to change the passwords for these 
standard users in client 000.  

If for any reason the SAP* and DDIC users still have initial passwords, you 
must change their passwords. Otherwise, there is a serious security risk 
because it is possible for anyone to log on to your SAP system using the initial 
passwords. 

Procedure 
... 

1. Start SAP Logon on the central instance host: 

 SAP GUI for Windows: 

On the machine, where you have installed the front end, choose: 

Start → Programs →  SAP Front End<Release> → SAPlogon 

 SAP GUI for Java: 

Enter the following command from the GUI installation directory: 
guilogon 

The SAP Logon dialog box appears. 

2. Create a logon entry for the newly installed system: 

Field Your Entry 

Description of 
system 

Give a meaningful description, for example, the host 
name of the central instance or the SAP system ID. 

Application Server Specify the name of the central instance host 

System number Specify the number you entered for the central 
instance during the installation. 

When you choose OK, the SAP Logon dialog box reappears and now includes an entry 
for the new system. 

3. Double-click the new system entry. 
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The logon screen for the SAP system appears. 

4. Log on as user SAP*. 

1.7.3  Installing the SAP License 
Use 
When you install your SAP system, a temporary license is automatically installed. This 
temporary license allows you to use the system for four weeks from the date of installation. 
Before the temporary license expires, you must apply for a permanent license key from SAP. 
SAP recommends that you do so as soon as possible after you install your system. 

Procedure 
The procedure to install the SAP license depends on the installation you have performed: 

• If you installed SAP R/3 Enterprise ABAP+Java, see: 

 Solution Life Cycle Management  SAP Licenses  SAP License Key  SAP 
License in the SAP Library [Page 36] 

 SAP Note 94998 

 
When you install the SAP Web AS  license, a license for the J2EE Engine gets 
installed automatically. 

 
You can install several licenses, one for each host running a message server. 

For example, on Windows, this applies if you have an installation with Microsoft 
Cluster Server (MSCS). The SAP system then searches for the current license. 

• If you installed an SAP Web AS Java for SAP R/3 Enterprise, see Solution Life Cycle 
Management  SAP Licenses  SAP License Key  SAP License  Licensing of 
the J2EE Engine in the SAP Library [Page 36]. 

1.7.4  Checking SAP System Services 
Use 
You need to check that the SAP system services are correctly installed.  

 
This helps you to solve problems that you might experience when trying to log 
on or run the system for the first time. 

... 

Prerequisites 
You have logged on to the SAP System [Page 93]. 

If you have trouble logging on, or subsequently experience problems trying to run the 
system, look at the following files located in the directory 
\usr\sap\<SAPSID>\DVEBMGS<no>\WORK\: 

 dev_ms 

 dev_disp 
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 dev_w0 

 dev_rd 

Procedure  
1. Call transaction SM50 to check services. 

The system displays a list of services available for the instance, that is, dialog, update, 
enqueue, batch, and spool. If you cannot see the services, you can find more 
information by looking at the files listed above in the first step. 

2. Call transaction SM51 to check all available instances and their services. 

The system displays a list of all available instances.  

If the display is OK, double-click one instance to display the services available for that 
instance. If the display is empty, you can find more information by looking at the files 
listed above in the first step. 

3. Call transaction SM21 to check the system log. 

1.7.5  Installing the SAP Online Documentation 
Use 
SAP currently provides an HTML-based solution for the online documentation, the SAP 
Library. The Application Help, Glossary, Implementation Guide (IMG), and Release Notes are 
delivered in HTML format. You can display the documentation with a Java-compatible Web 
browser on all front-end platforms supported by SAP. 

Procedure 
Install the SAP online documentation (SAP Library) in your SAP system as described in the 
README.TXT file contained in the root directory of the online documentation DVDs, delivered 
as part of the installation package. 

To access the SAP Library from your SAP system, choose Help → SAP Library. 

1.7.6  Checking the RFC Destination 
Use 
In a system configuration where the central and database instance run on different hosts, 
you have to test whether the database host has been correctly set up as a remote function 
call (RFC) destination. The database host must be defined as an RFC destination to enable 
the system to access monitoring data that is collected for the database and operating system. 

Procedure 
... 

1. Choose Tools → Administration → Network → RFC destinations or call transaction 
SM59. 

The initial screen of the transaction displays the different RFC connection types. 

2. Expand TCP/IP connections and double-click SAPOSCOL_<DB_hostname>. 

A screen displaying information about the selected destination appears. 

3. Choose Test Connection. 

If you find that the destination has not been set up correctly, you have to maintain it. 
For more information, see the following in the SAP Library [Page 36]: 
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Application Platform (SAP Web Application Server) → ABAP Technology   ABAP 
Programming and Runtime Environment  External Programming Interfaces   RFC 
Programming in ABAP  Maintaining Remote Destinations 

1.7.7  Configuring SAProuter and SAPNet – R/3 
Frontend 
Use 
SAProuter increases network security and simplifies network configuration. SAProuter allows 
you to make indirect network connections. The SAProuter software is included in the 
standard SAP system. No additional installation is required. The network administrator 
normally configures SAProuter. 

You require SAProuter if you are using any of the following: 

• SAPNet – R/3 Frontend 

SAPNet – R/3 Frontend is the SAP-based service system and provides the technical 
link between SAP customers and SAP. SAPNet – R/3 Frontend was formerly known as 
the Online Service System (OSS). 

For more information on setting up and using SAPNet – R/3 Frontend, see the 
following: 

 SAP Service Marketplace at service.sap.com/remoteconnection 

 SAP Library [Page 36] 

• EarlyWatch 

For more information on Early Watch, see SAP Service Marketplace at 
service.sap.com/earlywatch 

Procedure 
For a complete list of SAProuter parameters, enter the following at the command line: 
saprouter 

For more information, choose Application Platform (SAP Web Application Server) → ABAP 
Technology → Client/Server Technology → SAProuter in the SAP Library [Page 36]. 

For information on installing SAProuter as a Microsoft Windows service, see SAP Note 
41054. 

1.7.8  Configuring the Transport Management 
System 
Use 
You configure the domain controller in the Transport Management System (TMS) by calling 
transaction STMS. 

Procedure 
1. In your SAP system, call transaction STMS. 

2. Enter the required information to configure the domain controller. 
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If you are not sure how to configure the domain controller, choose Save and 
configure the controller later or choose Information to display the TMS online 
documentation. 

1.7.9  Performing Basic Operations 
Use 
You need to perform some basic operations that are described in the SAP Library.  

Prerequisites 
Open the SAP Library [Page 36]. 

Procedure 
Choose the relevant section to perform the following operations: 

! Operation Section in SAP Help Library  

 Set up operation modes 
– transaction RZ04 

Solution Life Cycle Management → System Management → 
Configuration → Operation Modes 

 Set up logon groups –
transaction SMLG 

Solution Life Cycle Management → System Management → 
Configuration → Dynamic Logon Load Distribution → The 
SAP Logon 

 Set up administrators Solution Life Cycle Management → System Management → 
Background Processing → Authorizations for Background 
Processing 

 Schedule background 
jobs 

Solution Life Cycle Management → System Management → 
Background Processing 

 Install a printer Solution Life Cycle Management → System Management → 
SAP Printing Guide 

 Configure the system 
log 

Solution Life Cycle Management → System Management →  
Tools for for Monitoring the System  → System log → 
Configuring the System Log 

 

1.7.10  Configured Number of Work Processes 
Definition 
SAPinst installs SAP systems with a minimum number of work processes calculated using the 
following formula: 

#dialog_WP = RAM / 256 (min 2, max 18) 

#update_WP = RAM / 768 (min 1, max 6)  

#update2_WP = RAM / 1024 (min 1, max 3)  

#batch_WP = RAM / 1024 (min 2, max 3)  

#enqueue_WP = 1  



1   Standard Installation   

1.7   Post-Installation Activities 

98 August 2004 

#spool_WP = 1 

Use 
This is only an initial configuration to get you started after the installation. It is not detailed 
enough for a production system because the optimal number of each type of work process 
depends on the system resources and on the number of users working in each SAP system 
application.  

For a detailed configuration contact SAP Technical Consulting. 

1.7.11  Installing Additional Languages 
Use 
To install an additional language, you need to perform the following steps: 

• Classify the language 

• Schedule the language transport 

• Schedule the language supplementation 

 
You can also install additional languages later, but if you install any Support 
Packages in the meantime, you have to do one of the following: 

• Install the Support Packages again 

• Use the report RSTLAN_IMPORT_OCS to extract the language-relevant 
information from each Support Package 

 

Procedure 
For more information on how to transport an additional language, see Language Transport, 
which you can find in either of the following: 

• SAP Service Marketplace at service.sap.com/instguidesNW04 → Installation 

• SAP Library [Page 36] by choosing Solution Life Cycle Management → Software 
Change Management → Change and Transport System → Language Transport. 

1.7.12  Activating the Integrated Internet 
Transaction Server 
Use 
The integrated Internet Transaction Server (ITS) was installed automatically with the SAP 
kernel.  

To enable the integrated ITS you have to configure and activate the Internet 
Communication Manager (ICM) and make sure that the webgui service is activated in the 
Internet Communication Framework (ICF).  

For more information, see the SAP Library [Page 36] and choose Application Platform (SAP 
Web Application Server)  ABAP Technology  UI Technology  Web UI Technology  
ITS/SAP@Web Studio  SAP ITS in the SAP Web Application Server 
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There you can also find the necessary information if you do not want to use the integrated 
ITS. 

1.7.13 Importing Support Packages 
Use 
You use this procedure to import Support Packages for your SAP system.  

Procedure 
... 

1. See SAP Note 737696 for more information about Support Packages for SAP R/3 
Enterprise Extension Set 2.00 SR 1. 

2. For up-to-date information on currently recommended combinations of Support 
Packages and patches, also see service.sap.com/sp-stacks. 

3. To import a Support Package, download it from SAP Service Marketplace at: 
service.sap.com/patches 

4. Apply Support Packages to your SAP system with the help of the Support Package 
Manager (formerly called SAP Patch Manager, transaction SPAM). 

For more information on the availability of Support Packages, see SAP Service Marketplace 
at: service.sap.com/ocs-schedules 

 
The SAP Note Assistant lets you load, implement, and organize individual SAP 
Notes efficiently. It also recognizes dependencies between SAP Notes, Support 
Packages, and modifications.  

For more information, see the SAP Service Marketplace at: 
service.sap.com/noteassistant 

1.7.14  Single Sign-On with Microsoft LAN Manager 
SSP 
Use 
Single Sign-On (SSO) is a secure method of logging on to the SAP system that simplifies the 
logon procedure without reducing security. When your system is configured for SSO, an 
authorized user who has logged on to the operating system can access the SAP system 
simply by selecting it in the SAP logon window or clicking the shortcut. No SAP system user 
name or password is necessary. SSO makes it significantly easier for you to manage SAP 
system users. 

In this section, we describe the option that is the easiest to implement when using a full 32-bit 
Microsoft Windows landscape (Windows 9x, Windows ME, Windows NT, Windows 2000 and 
higher). It is a tailored version for SSO with Secure Network Communications (SNC), which 
uses Microsoft’s domain authentication, LAN Manager Security Service Provider (NTLM 
SSP).  

For more information on SNC, see the SNC User's Guide on SAP Service Marketplace at 
service.sap.com/security 

Prerequisites 
• Typically, SNC requires an external security product that adheres to the Generic 

Security Service API V2 (GSS-API V2) interface and that has been certified by the SAP 
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Software Partner Program. However, in this scenario, we provide a library that adheres 
to the GSS-API V2 interface on one side and that communicates with Microsoft’s NTLM 
SSP on the other. Since NTLM SSP is already built into Microsoft Windows 32-bit 
platforms, you do not need to purchase an additional security product to use SSO. 

 
The Microsoft NTLM SSP only provides authentication based on a challenge-
response authentication scheme. It does not provide data integrity or data 
confidentiality protection for the authenticated network connection. All third-party 
BC-SNC certified security products offer data integrity and privacy protection. If 
you want to use these security features, you have to obtain a certified security 
product.  

If you only use Windows 2000 and higher, we offer an alternative library 
(gsskrb5.dll) that uses the Microsoft Kerberos SSP instead of the NTLM 
SSP for authentication. For more information, see The Configuration of 
Kerberos Single Sign-On [Page 104]. 

We distribute two different versions of the wrapper library for Microsoft's NTLM 
SSP. The older version is called gssapi32.dll and the newer version is 
called gssntlm.dll. For more information on how to get  gssntlm.dll, 
see SAP Note 595341. 

For more information on security aspects of this scenario, see SAP Note 
165485. 

• A pure Microsoft Win32 environment is required (Windows 9x, Windows ME, Windows 
NT, Windows 2000 and higher). The Microsoft NTLM SSP is not available for UNIX or 
any other operating system. 

• Bi-directional trust between Windows domains is required if there are separate 
domains for users, front-end PCs, and SAP application servers. 

• The GSS-API V2 library wrapper (gssntlm.dll) must be installed on every 
application server. 

• The GSS-API V2 library wrapper must also be installed on every front-end PC. 

• We recommend that you use the 7-bit ASCII character set for all Windows user IDs. 

When the code page of the SAP system is different from the code page on the 
Windows machines, it is not possible to enter Windows user IDs that contain 8-bit 
characters into the USRACL table (for example, by calling transaction SU01). The 
combination of Windows ANSI (=ISO Latin 1) and the default SAP code page 1100 
provides the same encoding of 8-bit characters and permits the use of 8-bit characters 
with gssntlm.dll. 

Integration 
For more information on how to improve the security of your system with third-party products, 
see the following in the SAP Library [Page 36]: 

Security → Network and Transport Layer Security → Secure Network Communication. 

Activities 
To implement SSO with the Microsoft NTLM SSP you: 
... 

1. Start the service Windows LM Security Support Provider: 

a. Choose Start → Programs → Administrative Tools → Services. 

b. Select the service Windows  LM Security Support Provider. 
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c. Choose General. 

d. Change the startup type from manual to automatic. 

2. Prepare the application server for Single Sign-On [Page 101]. 

3. Prepare SAP GUI and SAP logon for Single Sign-On [Page 102]. 

4. Map SAP system users to Windows users for Single Sign-On [Page 103]. 

1.7.14.1  Preparing the Application Server for Single Sign-
On 
Use 
You need to perform this procedure as part of Single Sign-On with Microsoft LAN Manager 
SSP [Page 98]. 

Procedure 
... 

1. Copy the gssntlm.dll file to the following directory on your central instance: 

<DRIVE>:\USR\SAP\<SAPSID>\SYS\EXE\RUN 

For more information on how to get the gssntlm.dll, file see SAP Note 
595341. 

2. Set the environment variable SNC_LIB to the location of the library. 

3. In the central instance profile, set the following SNC parameters: 
snc/data_protection/max =1 

snc/data_protection/min =1 

snc/data_protection/use =1 

snc/enable =1 

snc/gssapi_lib = 
(<DRIVE>:\USR\SAP\<SAPSID>\SYS\EXE\RUN\<gssntlm.dll>) 

snc/identity/as =p:<DOMAIN_NAME>\SAPService<SAPSID> 

SAPService<SAPSID> is the user who runs the SAP system. 

<DOMAIN_NAME> is the Windows domain of this user. 

 
Although you can freely choose the Windows account under which the SAP 
system runs, it is normally SAPService<SAPSID>. 

 
If you use a local account for SAPService<SAPSID>, most operations are 
successful. However, any operations or communications where the SAP system 
initiates SNC-protected communication to a remote machine, do not work with a 
local account for SAPService<SAPSID>. Therefore, use a domain account.  

Additional SNC Parameters 

The following profile parameters let you continue with password-based access to the 
SAP system when SNC has been enabled. To log on to the SAP system as an 
administrator to maintain the mapping of Windows user accounts to SAP system user 
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IDs (user and client), you have to use these additional parameters at least once after 
enabling SNC. Once the mapping (at least for the administrator) has been entered, you 
can disable further password-based logons by removing the respective profile 
parameters. 
snc/accept_insecure_cpic =1 

snc/accept_insecure_gui =1 

snc/accept_insecure_rfc =1 

snc/permit_insecure_start =1 

snc/permit_insecure_comm =1 

4. Stop and restart the SAP system to activate the profile parameters. Changes to 
SNC profile parameters always require an application server restart to take effect. 

1.7.14.2  Preparing SAP GUI and SAP Logon for Single 
Sign-On 
Use 
You need to perform this procedure as part of Secure Single Sign-On with Microsoft LAN 
Manager SSP. 

Prerequisites 
You have completed Preparing the Application Server for Single Sign-On [Page 101] (SSO). 

Procedure 
... 

1. Copy the gssntlm.dll file to the SAP GUI directory. 

For more information on how to get gssntlm.dll, see SAP Note 595341. 

2. Set the Windows environment variable SNC_LIB on the PC where your SAP GUI 
runs. 

The variable specifies the path to the gssntlm.dll file. You can do this using one of 
the following methods: 

... 

 Copy gssntlm.dll to a location of your choice and set the environment 
variable SNC_LIB to that location, for example, 
<DRIVE>:\<SAPGUI_PATH>\gssntlm.dll 

i. Right-click My Computer and choose Properties → Advanced → 
Environment Variables. 

ii. In User Variables for <user> enter the following: 

Variable: SNC_LIB 

Value: <DRIVE>:\<SAPGUI_PATH>\gssntlm.dll  

iii. Confirm your entries with OK. 

iv. To activate the new environment variable setting, log off system and log 
on again as the same user. 

 Copy gssntlm.dll to a directory of the default search path, for example, 
%SystemRoot%\system32 and rename the file to sncgss32.dll 
This is the default file name that SNC uses when SNC_LIB is neither entered on 
the command line nor available in the environment. 

http://pwdf0148.wdf.sap-ag.de:1080/SAPIKS/~S~9bcb6123d9324a15b344ef2e129d6be2/KW/KW/IWB_EXTHLP~7EB2753A5E831E45E10000000A114084/
http://pwdf0148.wdf.sap-ag.de:1080/SAPIKS/~S~9bcb6123d9324a15b344ef2e129d6be2/KW/KW/IWB_EXTHLP~7EB2753A5E831E45E10000000A114084/


  1   Standard Installation 

  1.7   Post-Installation Activities 

August 2004 103 

3. Set the required logon options to activate SSO: 

a. In the SAP logon window, choose Edit → Advanced 

The Advanced Options dialog box appears. 

b. In the SNC name field, enter: 
p:<DOMAIN_NAME>\SAPService<SAPSID> 

<DOMAIN_NAME> is the Windows domain that the user SAPService<SAPSID> 
belongs to. 

 
If the system HWA is running on account SAPServiceHWA of the DEC_NT 
domain, you enter: 
p:DEC_NT\SAPServiceHWA 

Result 
The SAP Logon window now displays an icon with a small yellow key beside the system 
entry. This indicates that SSO is active.  

When the SAP administrator has entered the mapping [Page 103] between a user's Windows 
account and the user’s SAP system user ID, the next time this SAP system user logs on to 
the system, the application is opened without requiring the user to enter a user name and 
password.  

If only one possible match exists between the Windows account and the SAP system user ID, 
the logon screen is skipped, unless the profile parameter snc/force_login_screen = 1 
is present in the instance profile of the application server. 

1.7.14.3  Mapping SAP System Users to Windows Users for 
Single Sign-On 
Use 
You need to perform this procedure as part of Secure Single Sign-On with Microsoft LAN 
Manager SSP [Page 101]. When you have configured your system, you can enable SAP 
system users to log on with Single Sign-On (SSO) by mapping them to Windows users. 

Prerequisites 
You have completed the following procedures: 

• Preparing the Application Server for Single Sign-On [Page 101] 

• Preparing SAP GUI and SAP Logon for Single Sign-On [Page 102] 

Procedure 
... 

1. Log on to the SAP system. 

2. Choose Tools → Administration → User Maintenance → Users or call transaction 
SU01. 

The User Maintenance window appears. 

3. Enter the name of the SAP system user and choose User names → Change. 

4. Choose SNC. 
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5. In SNC name, use uppercase to enter the name of the Windows user that is to be 
assigned to the SAP system user: 

p:<DOMAIN_NAME>\<NT_USERNAME> 

DOMAIN_NAME> is the Windows domain that the Windows user belongs to 

<NT_USERNAME> is the logon ID of the Windows user.  

p: is a prefix that all SNC names require. 

 
For the Windows user Kissnerj, belonging to the domain SAP_ALL, enter: 

p:SAP_ALL\Kissnerj 

6. Select Insecure communication permitted. 

This lets the user work in a different domain because it permits the user to access the 
system without SSO. 

7. Save your entries. 

Result 
You have now finished setting up SSO. 

1.7.15  Single Sign-On with Microsoft Kerberos 
SSP 
Use 
Kerberos Single Sign-On (SSO) is a secure method of logging on to the SAP system that 
simplifies the logon procedure without reducing security. It is suitable if you only use 
Windows 2000 or higher in your system landscape.  

When your system is configured for SSO, an authorized user who has logged on to Windows 
can access the SAP system simply by selecting it in the SAP logon window or clicking the 
shortcut. No SAP system user name or password is necessary. SSO makes it significantly 
easier for you to manage SAP system users. 

The Application Programming Interface (API) and Kerberos provide the security required for 
authentication. The advantage of the Kerberos SSO solution is that the security information 
that has to be exchanged between the SAP front end and the SAP application server is 
encrypted. In contrast, encryption is not implemented for SSO with Microsoft NTLM SSP 
[Page 98], which is based on the Generic Security Service API (GSS-API) interface 

 
When using gsskrb5.dll, the Microsoft Kerberos Security Service Provider 
(SSP) is interoperable with Kerberos implementations from other vendors and 
suppliers. To use SSO with application servers on UNIX and Windows front 
ends with gsskrb5.dll, you might have to purchase a Kerberos 
implementation for the UNIX machines. 

Prerequisites 
SSO based on Kerberos can only be set up for users that are members of a Windows 
domain. 
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Activities 
To implement SSO with the Microsoft Kerberos NTLM SSP, you have to: 
... 

1. Prepare the central instance [Page 105] 

2. Configure the SAP front ends [Page 106] 

3. Configure the SAP logon [Page 107] 

4. Map SAP users to Windows users [Page 108] 

The sections that follow describe these steps in detail. 

 
In the directory paths specified below, \%win%\ refers to the location of the 
Windows directory. 

1.7.15.1  Preparing the Central Instance 
Use 
To set up Single Sign-On (SSO) for Kerberos [Page 104], you need to adapt the central 
instance profile and make sure that the necessary Dynamic Link Library (DLL) is located in 
the Windows directory.  

Procedure 
... 

1. Copy the gsskrb5.dll file to the following directory on the central instance: 

Drive:\%windir%\system32. 

For more information on how to get the gsskrb5.dll file, see SAP Note 
595341.  

2. In the instance profile of the central instance, set the SAP parameters: 
snc/enable = 1 

snc/gssapi_lib =<DRIVE>:\%windir%\system32\gsskrb5.dll 

snc/identity/as =p:SAPService<SAPSID>@<DOMAIN_NAME> 

<DOMAIN_NAME> is the Windows domain that the SAPService<SAPSID> user 
belongs to, for example, NT5.SAP-AG.DE. 

 
<DOMAIN_NAME> and the SAPService<SAPSID> user are case-sensitive. 
Make sure that you enter uppercase and lowercase correctly, for example: 

p:SAPServiceC11@NT5.SAP-AG.DE. 

 
Although you can freely choose the Windows account under which the SAP 
system runs, it is normally SAPService<SAPSID>. 

If you use a local account for the SAPService<SAPSID> user, most operations 
are successful. However, any operations or communications where the SAP 
system initiates SNC-protected communication to a remote machine, do not 
work with a local account for the SAPService<SAPSID> user. Therefore, use 
a domain account. 
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3. Stop and restart the SAP system so that the profile parameters take effect. 

1.7.15.2  Configuring the SAP Front End 
Use 
To set up Single Sign-On (SSO) for Kerberos [Page 104], you need to configure the SAP 
front ends. 

Prerequisites 
• You have completed Preparing the Central Instance [Page 105]. 

• To prepare the SAP front end for SSO, you choose between the following approaches: 

 Configure each SAP front end individually 

You configure each machine where the SAP front end is running. 

 Configure all SAP front ends automatically 

You define a Group Policy for a Windows domain. This policy causes the wizard 
for configuring SSO to be started automatically in the background the next time 
any member of the domain logs on to an SAP front end. 

These approaches are described below. 

Procedure 

Configuring SAP Front Ends Individually 
... 

1. Log on to the machine where the SAP front end is running. 

2. Copy the SAPSSO.MSI program to a local directory or to a shared directory on the 
network. 

For more information, on how to get the SAPSSO.MSI file, see SAP Note 595341. 

3. Double-click the SAPSSO.MSI file. 

The wizard SAP Kerberos SSO Support automatically starts and configures the SAP front 
end for SSO. 

Configuring SAP Front Ends Automatically 
... 
... 

1. Log on to a front-end machine as domain administrator of the Windows domain. 

2. Copy the program SAPSSO.MSI to a shared directory. 

For more information, on how to get the SAPSSO.MSI file, see SAP Note 595341. 

3. Choose Start → Programs → Administrative tools → Active Directory Users and 
Computers. 

The dialog box Active Directory Users and Computers appears. 

4. Right-click the domain for which you want to set up SSO and choose Properties. 

The dialog box <Domain_Name> Properties appears. 

5. Choose Group Policy → New to start creating a new policy object. 

The dialog box for creating a new policy object appears. 

6. In Group Policy Object Links, enter a name for the new policy object, such as 
SAPSSO. 
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7. Choose Edit to define the contents of the policy. 

8. In the Group Policy Editor choose User Configuration → Software Settings → 
Software Installation. 

The Deploy Software dialog box appears. 

9. Right-click Deploy Software and choose New → Package. 

The Open dialog box appears. 

10. Select the file SAPMSSO.MSI from the shared location. 

11. Specify the path with the UNC name (\\<hostname>\<share>). 

12. Select Assign and confirm with OK. 

You have now created a new Group Policy. 

The next time any user logs on to the domain with the SAP front end, the wizard SAP 
Kerberos SSO Support automatically starts and configures the front end for SSO. 

1.7.15.3  Activating Single Sign-On for the SAP Logon 
Use 
To set up Single Sign-On (SSO) for Kerberos [Page 104], you need to activate the SAP logon 
option for SSO on each SAP front end.  

Prerequisites 
• You have completed the following: 

 Preparing the Central Instance [Page 105] 

 Configuring the SAP Front End [Page 106] 

• The SAP Logon window includes a list of systems or machines that you can log on to. 
For each of the systems or machines in the list for which you want to implement SSO, 
follow the procedure below. 

Procedure 
... 

1. Select an entry in the SAP Logon window and choose Properties → Advanced. 

2. Select Enable Secure Network Communications. 

3. In SNC name, enter: 
p:SAPService<SAPSID>@<DOMAIN_NAME> 

where <DOMAIN_NAME> is, for example, NT5.SAP-AG.DE. 

 
Enter the same string that you entered in the central instance profile for 
snc/identity/as 

If the system C11 is running on account SAPServiceC11 of the domain 
NT5.SAP-AG.DE, you would enter: 

P:SAPServiceC11@NT5.SAP-AG.DE 
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If the entry you selected in the logon dialog box is a group entry, for example, 
C11 (PUBLIC), the SNC name field is already filled. 

4. Choose OK to confirm your entries. 

The SAP Logon window now displays an icon with a key beside the system entry. This 
indicates that Single Sign-On is active for the system. 

1.7.15.4  Mapping SAP Users to Windows Users 
Use 
To set up Single Sign-On (SSO) for Kerberos [Page 104], you need to authorize SAP users to 
log on with SSO by assigning them to Windows users.  

Prerequisites 
You have completed the following: 

• Preparing the Central Instance [Page 105] 

• Configuring the SAP Front End [Page 106] 

• Activating Single Sign-On for the SAP Logon [Page 107] 

Procedure 
... 

1. Log on to the SAP system as administrator. 

2. Choose Tools → Administration → Maintain Users → Users or call transaction 
SU01. 

The User Maintenance window appears. 

3. Enter the name of the SAP user and choose User names → Change. 

4. Choose SNC. 

5. In SNC name, use uppercase to enter the name of the Windows user that is to be 
assigned to the SAP user: 

p:<WINNT_USERNAME>@<DOMAIN_NAME> 

where <WINNT_USERNAME> is the logon ID of the Windows user and <DOMAIN_NAME> 
is the Windows domain that the user is logged on to. 

 
For the user Kissnerj, belonging to the domain NT5.SAP-AG.DE , enter: 

p:kissnerj@NT5.SAP-AG.DE 

6. Select Insecure communication permitted. 

This lets the user work in a different domain because it permits the user to access the 
system without SSO. 

7. Save your entries. 

Result 
Kerberos SSO is now set up. 
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1.7.16  Performing the Client Copy 
Use 
You use this procedure to perform the client copy, which consists of the following steps: 

• Maintain the client with transaction SCC4 

• Copy the client with local transaction SCCL 

• Copy the log files with transaction SCC3 

Procedure 
For more detailed information on how to perform the client copy, see the separate 
documentation in the SAP Library [Page 36]: 

Solution and Life Cycle Management → Software Change Management → Change and 
Transport System → Client Copy and Transport 

1.7.17 Scheduling Asynchronous Indexing and 
Deindexing 
Use 

 
This step is only needed if you use the Knowledge Provider (KPRO) component. 
For more information on KPRO see SAP Library [Page 36] and choose 
Application Platform (SAP Web Application Server)  Business Services  
Knowledge Provider. 

 

Asynchronous indexing and deindexing is triggered using the report RSTTIRIDX.  You should 
schedule this report as a daily background process. 

 
The report RSTIRIDX starts the indexing and deindexing of scheduled 
documents, and logs indexing errors in the productive system. The chosen 
recipient can view the contents of the report using the transaction SO01. If an 
error occurs, check check in IMS Monitoring [Page 110]). 

Prerequisites 
To use a report, you need Batch Administrator authorization for the authorization object Batch 
Processing. 

Procedure 
... 

1. In the SAP system, call transaction SM36 or choose System → Services → Jobs → 
Define Jobs from the menu.  

The Define Background Job screen appears. 

2. In the field Job name, enter  INDEXING. 

3. In the field Job class, choose B. 

4. In the field Target Server, enter the name of the host on which the background 
process is to be performed. 
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5. Choose Spool list Recipient.  

The Recipient Determination dialog box appears . 

6. In the field Recipient, enter the name of the desired recipient. Then select the 
required General Attributes, and choose Copy. 

7. From the application toolbar on the Define Background Job screen, choose Start 
condition. 

The Start Time dialog box appears. 

8. Choose Date/Time. 

9. Enter the required start date and time. 

10. Select the option Periodic Job anf choose Period Values 

The Period Values dialog box appears. 

11. Choose Daily. 

12. Choose Save. 

13. On the Start Time dialog box, choose Save again. 

14. From the application toolbar, choose Step. 

The Create Step dialog box appears. 

15. Choose ABAP program. 

16. In the ABAP Program group box, enter the name RSTIRIDX  in the Name field. 

17. Choose Print specifications. 

The Background Print Parameters dialog box appears. 

18. Enter the name of the output device and choose Properties. 

The Spool Request Attributes dialog box appears  

a. On the Overview tab, select General Properties and double-click Time of Printing. 

b. In the group box Other Properties “Time of Printing”, choose the option Print out 
immediately from the listbox. 

c. Confirm your entries with O.K. 

1.7.176.1 Checking for Problems in IMS Monitoring 

 
This step is only needed if you use the Knowledge Provider (KPRO) component.  

Procedure 
1. In the SAP system, choose transaction SKPR07. 

2. In the Extras area, choose Scheduled Documents. 
... 

The system displays a list of documents to be indexed or deindexed. The following 
information is available: 

 Client 

 Name of index category (32-place GUID) 

 Document class 

 Document language 
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 Processing type (I = indexing, D = deindexing) 

 The number of scheduled documents for this index category 

3. To see details on the scheduled documents, select the required list entry and choose 
View. 

4. To see the number of attempts to index or deindex individual documents, select the 
required documents and choose View. 

If an error has occurred whilst a document was being indexed or deindexed, it is 
scheduled for the process again. If the number of retries is large, there is probably an 
error that is preventing the indexing or deindexing of the document in general. Select 
such documents in the list of scheduled documents, and delete them. 

Documents that could not be indexed or deindexed at the first attempt (including those 
documents that you have deleted from the list of scheduled documents manually) are 
treated by the system as problem cases. 

5. To see a list of problem cases, call transaction SKRPR07 and choose Problems. 

You can filter this list by document class and by the number of attempts to index or 
deindex a document. 

You can delete the listed documents, or you can mark them to be indexed or deindexed 
again. 

1.7.18  Performing a Full Backup 
Use 
You must perform an offline full backup at the end of the installation. 

Prerequisites 
• You have completed client maintenance (for example, client copy). 

• You have stopped: 

 The SAP system 

 SAP-related services (SAP<SAPSID>_<instance> and SAPOSCol) 

 The database 

• You are logged on as user <sapsid>adm. 

• You have shut down the SAP system and database. 

Procedure 
... 

1. Save the registry: 

a. Choose Start → Programs → Accessories → System Tools → Backup 

b. Choose Emergency Repair Disk. 

c. The Emergency Repair Diskette dialog box appears. 

d. Select Also Backup the Registry to the Repair directory… 

When you confirm your entry, the registry is written to diskette. 

2. Save the system state data: 

a. Choose Start → Programs → Accessories → System Tools → Backup. 
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b. Choose Backup Wizard → Next. 

c. Select Only back up the System State data and choose Next. 

d. In Where to Store the Backup, select the Backup media type and enter the Backup 
media or file name. 

e. Choose Next.   

f. Check the information displayed and choose Finish to start the backup. 

3. Back up all SAP-specific and all database-related directories: 

a. Choose Start → Programs → Accessories → System Tools → Backup. 

b. Choose Backup Wizard → Next. 

c. Select Back up selected files, drives, or network data and choose Next. 

d. In What to back up, select the Windows directory and all SAP and database-related 
directories, including: 

\USR\SAP 

\USR\SAP\TRANS 

<HOMEDIR> of <sapsid>adm 

\%WINDIR% 

 
The directory \USR\SAP\TRANS is only required for SAP systems that have the 
ABAP engine installed. 

e. Choose Next. 

f. In Where to Store the Backup, select the Backup media type and enter the Backup 
media or file name for the backup. 

g. Choose Next. 

h. Check the information displayed and then choose Finish to start the backup. 

1.7.19  Changing Passwords of Created Users 
Use 
You need to change the passwords of the users that SAPinst creates during the installation. 
The table below lists these users. You also need to remove the contents of the installation 
directory and store them securely because otherwise they might represent a security risk. 

Procedure 
... 

Change the passwords of these users according to the SAP Security Guide. 

For more information, see SAP Service Marketplace at 
service.sap.com/securityguide 

 
• SAP system users might exist in more SAP system clients than listed 

below (for example, if a user was copied as part of the client copy [Page 
109]. 
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• We strongly recommend that you change the initial passwords even if 
SAPinst prompted for a new password during the installation procedure. 

 

User Type User Comment 

SAP* User exists at least in SAP system client 
000 

DDIC User exists at least in SAP system 
clients 000 and 066 

EARLYWATCH User exists at least in SAP system client 
066 

SAP system user 

SAPCPIC User exists at least in SAP system client 
000 

SAP<SCHEMA_ID>  Oracle database owner (the owner of 
the database tables) 

SYSTEM – 

SYS – 

OUTLN – 

Oracle database 
user 

DBSNMP – 
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1.8  Additional Information 

1.8.1  Remote Installation with SAPinst 
Purpose 
You can run the SAPinst GUI in standalone mode to perform a remote installation. 

This enables you to install an SAP system on another host (the remote host) while monitoring 
the installation with the SAPinst GUI on your local Windows or UNIX computer (the local 
host). 

Prerequisites 
• Make sure that you have performed the preparation activities for your local host 

(SAPinst GUI host) and your remote host. 

For more information, see Installation Preparations in this documentation. 

• Both computers are in the same network and can ping each other. 

To test this: 

 Log on to your remote host and enter the command ping <local host>. 

 Log on to the local host and enter the command ping <remote host>. 

Process Flow 
... 

1. You start SAPinst on the remote host [Page 114]. 

2. You start SAPinst GUI on the local host [Page 115]. 

3. You perform the installation using the SAPinst GUI. 

1.8.1.1  Starting SAPinst on the Remote Host 
Use 
You use this procedure to run SAPinst on the remote host when you want to run SAPinst as 
a remote installation [Page 114]. The remote host is the host where you want to install the 
SAP system. 

Procedure 

Your Remote Host Runs on a Windows Platform 
... 

1. Log on to your remote host as a user who is a member of the local administration 
group. 

2. Insert the installation DVD in your DVD drive. 

3. Enter the following commands from the Windows command prompt: 
cd <DVD drive>:\IM<x>\SAPINST\NT\<platform> 

sapinst.exe SAPINST_START_GUI=false 

SAPinst now starts and waits for the connection to the SAPinst GUI. That is, you see 
the following at the command prompt: 



  1   Standard Installation 

  1.8   Additional Information 

August 2004 115 

guiengine: no GUI connected; waiting for a connection on host 
<host_name>, port <port_number> to continue with the 
installation 

4. Start SAPinst GUI on your local host, as described in Starting SAPinst GUI on the 
Local Host [Page 115]. 

Your Remote Host Runs on a UNIX Platform 
... 

1. Log on to your remote host as user root. 

2. Mount the Installation Master DVD. 

3. Enter the following commands: 
cd <SAP_Installation_Master_DVD>/IM<x>/SAPINST/UNIX/<OS> 

sapinst SAPINST_START_GUI=false 

SAPinst now starts and waits for the connection to the SAPinst GUI. That is, you see 
the following at the command prompt: 

guiengine: no GUI connected; waiting for a connection on host 
<host_name>, port <port_number> to continue with the 
installation. 

4. Start the SAPinst GUI on your local host, as described in Starting SAPinst GUI on 
the Local Host [Page 115]. 

1.8.1.2  Starting SAPinst GUI on the Local Host 
Use 
You use this procedure to run SAPinst GUI on the local host when you want to run SAPinst 
as a remote installation [Page 114]. The local host is the host where you want to control the 
installation with the SAPinst GUI. 

Procedure 

Your Local Host Runs on a Windows Platform 
... 

1. Log on to your local Windows host. 

2. Insert the Installation Master DVD into your DVD drive. 

3. Enter the following commands from the Windows command prompt: 
cd <DVD drive>:\IM<x>\SAPINST\NT\<platform> 

startinstgui.bat 

SAPinst GUI now gets started and connects automatically to the host that is waiting for 
a connection. The SAP Installation GUI Connection dialog appears. 

4. Enter the host name of the Installation Host and the same Port as SAPinst uses on 
the remote host and choose OK. 

SAPinst GUI now connects to the SAPinst server and the first dialog of the installation 
appears. 

5. Perform the installation from your local host. 

Your Local Host Runs on a UNIX Platform 
... 

1. Log on to your local UNIX host as user root. 
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2. Mount your Installation Master DVD. 

3. Enter the following commands: 
cd <SAP_Installation_Master_DVD>/IM<x>/SAPINST/UNIX/<OS> 

./startInstGui.sh 

The SAPinst GUI now gets started and connects automatically to the host that is 
waiting for a connection. The SAP Installation GUI Connection dialog appears. 

4. Enter the host name of the Installation Host and the same Port as SAPinst uses on 
the remote host and choose OK. 

SAPinst GUI now connects to the SAPinst server and the first dialog of the installation 
appears. 

5. Perform the installation from your local host. 

1.8.2  Interrupted Installation with SAPinst 
Purpose 
SAPinst does not abort the installation in error situations. Therefore, you can continue an 
interrupted installation when you have: 

• Not canceled the installation 

That is, the error dialog box is still displayed and SAPinst is waiting for your input. You 
proceed by choosing Retry in the error dialog box. 

SAPinst now retries the installation step. 

• Already canceled the installation 

That is, the installation was aborted. There are the following situations: 

 

If you have 
canceled 
with… 

Meaning 

Stop Since SAPinst records the installation progress in the keydb.xml file, 
you can continue the installation from the failed step without repeating 
previous steps. 

During this procedure, you can Reset the installation, too, if required. 

Reset You must restart from the beginning, that is, with the default 
keydb.xml file as delivered. 

 
In some cases, you must uninstall already installed 
components, before repeating the installation from the 
beginning. For example, this applies to an SAP system 
installation. For more information, see the description on 
how to de-install a component in the corresponding 
installation guide. 
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If you do not want to continue the installation and you want to terminate 
SAPinst, do one of the following:  

• Right-click the icon for the SAPinst output window located in the 
Windows tray and choose Exit. 

• Click the icon for the SAPinst output window located in the 
Windows tray and choose File → Exit.  

Prerequisites 
You have solved the problem that caused the error situation. 

Procedure 
1. Log on to your remote host as a user who is a member of the local administration 

group. 

2. Insert the Installation Master DVD in your DVD drive. 

3. Enter the following command from the Windows command prompt: 
cd <DVD drive>:\IM<x>\SAPINST\NT\<platform> 

sapinst.exe 

4. From the tree structure in the Welcome screen, select the installation task that you 
want to continue and choose Next. 

The What do you want to do? screen appears. 

 
If there is only one component to install, SAPinst directly displays the dialog 
What do you want to do? without presenting the Welcome screen. 

5. In the What do you want to do? screen, decide between the following alternatives 
and choose OK. 

Alternative Behavior 

Run a new 
Installation 

The installation will not be continued. 

Instead, SAPinst deletes the mentioned installation directory for the 
chosen installation service and starts the installation from the 
beginning. 

The log files from the old installation are put into a backup directory 
with the following naming convention: 
<log_day_month_year_hours_minutes_seconds> (for 
example, log_01_Oct_2003_13_47_56). 

Continue old 
installation 

The installation of the mentioned installation service will be 
continued from the point of failure. 

UNIX 

1. Log on to your local UNIX host as user root. 

2. Mount your Installation Master DVD. 

 
Mount the DVD locally. We do not recommend using Network File System 
(NFS). 
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3. Enter the following command: 
cd <SAP_Installation_Master_DVD>/IM<x>/SAPINST/UNIX/<OS> 

./sapinst 

4. From the tree structure in the Welcome screen, select the installation task that you 
want to continue and choose Next. 

.  

If there is only one component to install, SAPinst directly displays the dialog 
What do you want to do? without presenting the Welcome screen. 

 

The What do you want to do? screen appears. 

5. In the What do you want to do? screen, decide between the following alternatives 
and choose OK. 

Alternative Behavior 

Run a new 
Installation 

The installation will not be continued. 

Instead, SAPinst deletes the mentioned installation directory for the 
chosen installation service and starts the installation from the 
beginning. 

The log files from the old installation are put into a backup directory 
with the following naming convention: 
<log_day_month_year_hours_minutes_seconds> (for 
example, log_01_Oct_2003_13_47_56). 

Continue old 
installation 

The installation of the mentioned installation service will be 
continued from the point of failure. 

1.8.3  Deletion of an SAP System Installation 
(ABAP) 
Purpose 
This section describes how to delete a (J2EE) dialog instance, a J2EE Add-In installation, or 
a complete SAP system. 

Process Flow 

 
If you delete network-wide users, groups or service entries in an environment 
with Network Information System (NIS), other SAP installations might also be 
affected. Make sure that the users, groups, and service entries to be deleted are 
no longer required. 

Deleting a J2EE Dialog Instance 
You delete the J2EE dialog instance. For more information, see Deleting an SAP Instance 
[Page 119]. 
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Deleting a J2EE Add-In Installation 
... 

 If you have an SAP system based on SAP Web AS ABAP+Java and you only want to delete 
the J2EE Add-In installation (that is, the SAP system (ABAP) is not deleted), see the 
documentation Installation Guide – SAP Web Application Server Java 6.40 on Windows: 
Oracle, section Deletion of an SAP System Installation (J2EE). 

Deleting a Complete SAP System 
... 

1. You delete all SAP instances [Page 119], including the (J2EE) dialog instances, if 
there are any. 

2. You delete the database instance (see the corresponding section below). 

1.8.3.1  Deleting an SAP Instance 
Use 
You use this procedure to delete particular SAP instances, for example, a (J2EE) dialog 
instance, or a a complete SAP system.  

 
When you delete a SAP system installation [Page 118], you need to uninstall 
the SAP instance software.  

Prerequisites 
The SAP system is stopped and the database is shut down.  

Procedure 

 
We recommend to use perform this procedure only, if you have performed a full 
backup of your SAP system.  

 
If you want to delete a J2EE dialog instance in an SAP R/3 Enterprise 
ABAP+Java installation which is installed on the same host than the central 
instance, you have to use the procedure as described in Deletion of an SAP 
System Installation [Page 118]. 

... 

1. Log on as a user with domain administration rights. 

2. Choose Start → Settings → Control Panel → Add/Remove Programs. 

3. The Add/Remove Programs dialog box appears. 

4. Find the SAP entries. 

 
Each SAP instance that is installed on the computer is listed with an entry like 
SAP Application Server for System <SAPSID>instance 

5. Choose Remove. 

The SAP Uninstall Wizard starts. 

6. Choose Next in the Welcome window. 
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The dialog box Uninstalling SAP System appears for you to select an uninstall method: 

 
Depending on your selection, note the following when using the checkbox to 
delete an SAP instance: 

• If your checkbox is marked gray, you delete or uninstall the following: 

• The SAP instance directory, for example: 
usr\sap<SAPSID>\D00 

• Services, for example SAP<SAPSID>_00 

• The whole system directory, for example 
usr\sap\<SAPSID>\* 

• If your checkbox is marked black, you delete or uninstall the following: 

• The SAP instance directory, for example: 
usr\sap<SAPSID>\D00 

• Services, for example SAP<SAPSID>_00 

• The whole system directory, for example 
usr\sap\<SAPSID>\* 

• Local and domain user accounts 

• If you have different SAP instances that use the same <SAPSID>, you 
can delete the instance directory only. 

 

Uninstall 
Method 

Action 

Typical Select this if you want to completely uninstall the selected 
SAP instance(s). 

 
• If you uninstall the central instance, the 

checkbox is marked black. 

• If you uninstall the dialog instance, the 
checkbox is marked gray. 

Choose Finish to delete the SAP instance. 

Complete  Select this if you want to uninstall all the SAP instances that 
are installed on the local computer.  

 
• All instances are marked with a black 

checkbox. 

• This uninstall method removes all the 
SAP instances listed in the Add/Remove 
Programs Properties dialog box, 
regardless of the highlighted selection. 

Choose Finish to delete all local SAP instances. 



  1   Standard Installation 

  1.8   Additional Information 

August 2004 121 

Uninstall 
Method 

Action 

Select Custom and choose Next to access the Select 
Components dialog box that allows you to mark the 
instances you want to remove.  

In the Select Components dialog box, use the check box 
beside an instance to indicate whether only the instance 
involved or the entire system, with global accounts, is to be 
deleted. 

Uninstall instance-independent components 

Select this additional option, if there is no other SAP system 
on the local machine. With this option you can delete for 
example the saposcol program. 

Add 

Choose this option to manually add instances you want to 
delete if they do not appear on the list. 

Custom 

Finish  

Choose to start the deletion. 

 

The wizard informs you when the SAP system or selected instances have been deleted 
successfully. 

1.8.3.2  Deleting the Oracle Database  
Use 

 
If you have multiple components installed in one database (MCOD), delete the 
database only if you want to delete all contained components as well. 
Otherwise, delete components on a selective basis (see SAP Note 399910). 

This section describes how to delete an database instance and the Oracle database that you 
have installed.  

For the SAP R/3 Enterprise ABAP+Java installation, you also have to delete the J2EE 
database schema that was installed into the existing database of SAP R/3 Enterprise. 

Prerequisites 
• Before deleting the database or the J2EE database schema, stop all SAP instances 

belonging to this database or to this J2EE database schema. 

• We recommend you to delete the SAP instances before deleting the database instance 
or the J2EE database schema. 

• You have stopped or already deleted the SAP central instance. 

Procedure 
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Use the following procedure if there is only a single Oracle_Home in your 
system. 

If the instance of a second SAP system is running on the same machine as the 
database, this means the database software still has to be accessed by the 
second system.  

Deleting the Database Instance 
To delete the database instance: 
... 

1. Log on as local administrator. 

2. Delete the Oracle instance: 
... 

a. Open a command prompt and switch to the directory 

<DRIVE:\Oracle_Home\bin 

b. Enter: 
oradim -delete -sid <DBSID> 

3. Delete the ORACLE\<DBSID> directories on all drives. This includes the directories 
containing the SAP data. 

4. Delete the following files from the directory <DRIVE>:\ORACLE_HOME\database\ 

init<DBSID>.dba 

init<DBSID>.ora 

init<DBSID>.sap 

5. Delete the following files from the directory 
<DRIVE>:\ORACLE_HOME\Network\Admin 

listener.ora 

tnsnames.ora 

sqlnet.ora 

 
If a second instance is installed on the host do not delete these files. Open the 
files listener.ora and tnsnames.ora in an editor and remove all 
references that include the name of the system <DBSID> that is being removed.  

6. Delete the groups ORA_<DBSID>_DBA and ORA_<DBSID>_OPER: 
... 

a. Choose: 

Start → Programs → Administrative Tools → Computer Management 

b. Choose Local Users and Groups → Groups. 

c. Select and delete the local groups ORA_<DBSID>_DBA and ORA_<DBSID>_OPER 
with Action → Delete 
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Deleting the Oracle Database Software 

 
The Oracle software is installed on all hosts where an SAP instance is running: 
on a central instance host, database host and dialog instance host. Do not 
delete the database software, if another SAP instance is running on the same 
host. 

... 

1. Stop all Oracle Services and the Microsoft Distributed Transaction Coordinator. To 
access the services choose Start → Programs → Administrative Tools → Services 
Select a service and then choose Action → All Tasks → Stop 

2. Delete the Oracle home directory and all its subdirectories under 
<DRIVE>:\ORACLE_HOME 

3. Edit the Oracle Registry entries as follows: 
... 

a. Choose Start → Run and enter REGEDIT 

b. Delete the key HKEY_LOCAL_MACHINE → SOFTWARE → ORACLE 

c. Delete all Oracle references under HKEY_LOCAL_MACHINE → SYSTEM→ 
CURRENTCONTROLSET → SERVICES 

4. Delete all Oracle references from the Windows user and system environment: 

a. Choose Start → Programs →  System. 

b. Choose the Advanced tab and then click Environment Variables. 

c. For example, delete the variables: 
 TNS_ADMIN, NLS_LANG, ORACLE_HOME 

d. Also delete Oracle from the PATH variable. 

5. Delete the Oracle entries from the Start menu: 
... 

a. Choose Start → Settings → Taskbar & Start Menu 

b. On the Advanced tab, click Advanced. 

c. On the Start Menu screen, look under 
 All Users\Start Menu\Programs 
 Select and delete the folders for Oracle with File → Delete 

d. Delete the Oracle shortcut from the desktop. 

SAP R/3 Enterprise ABAP+Java: Deleting the J2EE Database Schema 

 
Before deleting the J2EE database schema, make sure that you have a recent 
offline database backup. 

... 

1. Log on as user who is a member of the local administration group. 

2. Start sqlplus and shutdown the database with the following commands: 

sqlplus /nolog 

SQLPLUS> connect / as sysdba 

SQLPLUS> shutdown immediate 
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3. Enter the following command to delete the database objects of the database 
schema: 

SQLPLUS> drop user SAP<SAPSID>DB cascade; 

4. Enter the following command to get the file name of the corresponding data file in 
the file system: 

SQLPLUS> select file_name from dba_data_files where   \ 

  tablespace_name = 'PSAP<SAPSID>DB'; 

5. Enter the following command to delete the tablespace of the database schema: 
SQLPLUS> drop tablespace PSAP<SAPSID>DB including contents; 

6. Exit sqlplus with the command: 

SQLPLUS> exit 

7. Delete the data file of tablespace PSAP<SAPSID>DB from the file system. 

1.8.4  SAP System Security on Windows 
In a standard SAP system installation, SAPinst automatically performs all steps relevant for 
security. Although SAPinst makes sure that the system is protected against unauthorized 
access, you must still check that no security breaches can occur. 

For central and straightforward administration of the SAP system, you have to install 
distributed SAP systems with multiple application servers in a Windows domain. This section 
describes the user accounts and groups that SAPinst creates during a domain installation 
and shows how these are related to the SAP directories. 

User Accounts 
SAPinst creates the following accounts for SAP system administration: 

• <sapsid>adm 

This is the SAP system administrator account that enables interactive administration of 
the system.  

• SAPService<SID>  

This is the virtual user account that is required to start the SAP system. It has the local 
user right to log on as a service and is a member of the local administrator’s group. 

The advantage of the additional SAPService<SAPSID> account is that it does not allow an 
interactive logon, which prevents abuse of the account. Therefore, you do not need to set an 
expiration date for the password and you do not have to set the option user must change 
password at next logon. 

Groups 
SAPinst creates the following groups during a domain installation: 

• SAP_<SAPSID>_GlobalAdmin 

This global group is a domain-level SAP administration group for organizing SAP 
system administrators. The only function of a global group is to group users at the 
domain level so that they can be placed in the appropriate local groups. 

• SAP_<SAPSID>_LocalAdmin 
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Only local groups are created and maintained on an application server. A local group 
can only be given permissions and rights to the system where it is located. The system 
is part of a particular domain, and the local group can contain users and global groups 
from this domain. 

• SAP_LocalAdmin 

This group is created on all hosts, but is particularly important for the transport host. 
Members of the group have full control over the transport directory (\usr\sap\trans) 
that allows transports to take place between systems.  

The SAP_<SAPSID>_GlobalAdmin groups of all the SAP systems that are part of the 
transport infrastructure are added to the SAP_LocalAdmin group. As a consequence, 
the users <sapsid>adm and SAPService<SAPSID> of all systems in the transport 
infrastructure are members of the SAP_LocalAdmin group and have the required 
authorizations necessary to initiate and execute transports.  

SAP Directories 
SAPinst protects the SAP directories under \usr\sap\<SAPSID> by only granting the group 
SAP_<SAPSID>_LocalAdmin full control over these directories. 

The following graphic illustrates the user accounts and groups created by SAPinst in a 
system infrastructure consisting of two SAP systems.  

User Groups and Accounts 
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Full control

Local Group

member of

member of

Domain

       Users

Users:
<sapsid_1>adm
SAPService<SAPSID_1>
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SAP_<SAPSID>_LocalAdmin

       Users
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<sapsid_2>adm
SAPService<SAPSID_2>
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Global Group

SAP_<SAPSID_2>_GlobalAdmin

usr\sap\<SAPSID>

Transport
Host

Full control

Local Group

SAP_LocalAdmin

usr
sap

trans
prfclog

member of

System 1 System 2
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An access control list (ACL) controls access to SAP system objects. For 
maximum security in the SAP system, only the following are members of all 
SAP system object ACLs: 

• Local group SAP_<SAPSID>_LocalAdmin 

• Group Administrators 

• Account SYSTEM 

1.8.4.1  Automatic Creation of Accounts and Groups 
Use 
SAPinst automatically creates the accounts and groups required for the secure operation of 
the SAP system with Windows [Page 124] during the installation. 

Features 
The following graphic shows the steps that SAPinst performs to create the users and groups 
for a domain installation. 
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SAP  Administrator :
SAP Service Account:

Creation of SAP Domain User AccountsCreation of accounts
<sapsid>adm
SAPService<SAPSID>
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global group in the 
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Global Group : SAP_<SAPSID>_GlobalAdmin

Addition of <sapsid>adm and
SAPService<SAPSID> to group
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Addition of <sapsid>adm and
SAPService<SAPSID> to the NT local
Administrators Group
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local group on each 
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Local Group : SAP_<SAPSID>_LocalAdmin

Addition of the global group
SAP_<SAPSID>_GlobalAdmin to the local group
SAP_<SAPSID>_LocalAdmin

Creation of a local group on the application 
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Local Group : SAP_LocalAdmin
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SAP_LocalAdmin on the application server
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1.8.4.2  Manually Granting User Rights for the Installation 
Use 
Although the rights required for the installation are automatically granted to the user who 
installs the SAPinst tool, you might need to manually grant user rights for the installation to 
another user, as described in this section.  

Prerequisites 
The Windows user that performs the SAP system installation must be authorized to perform 
the actions necessary for the installation. For a domain installation, this means that the user 
must belong to the Domain Admins group and be authorized to: 

• Act as part of the operating system 

• Increase quotas (Windows 2000) 

• Adjust memory quotas for a process (Windows Server 2003)  

• Replace a process-level token 

The procedure below assigns these rights to a user of your choice. 

 
Be aware that domain policies override locally defined policies. This means that 
if you want to grant domain administration rights for a local user, make sure tthat 
you have also defined domain administration rights for this user on domain 
level.  

Procedure 
... 

1. Choose Start → Settings → Control Panel → Administrative Tools → Local 
Security Policy. 

2. In the Local Security Settings window, choose Local Policies → User Rights 
Assignment. 

3. For Windows 2000, double-click the respective right under Policy and choose Add. 

4. For Windows Server 2003, double-click the respective right under Policy and 
choose Add User or Group. 

5. In the Select Users and Groups window, choose the required user and choose 
Add. 

The selected user appears in the box below. 

6. Confirm your entry and then repeat the steps for each remaining policy that the 
user requires for the installation. 

7. Log off from your system and log on again to apply the changes. 

See also: 

Granting User Rights for the Installation [Page 57] 
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2  Cluster Installation with MSCS 
Purpose 
When you install an SAP system, you can decide to set up a Microsoft Cluster Server 
(MSCS) configuration. For this type of installation, you have to set up the system on two 
clustered hosts (called “nodes”) and configure it so that it can take advantage of the MSCS 
software. The MSCS software offers features that can improve the availability of the system 
and safeguard it against failure and unplanned downtime. Ideally it enables 24-hour 
operation, 365 days a year.  

With an MSCS installation you set up the database and central instance on two separate 
clustered machines with the aim of enabling critical system components to be automatically 
switched from one machine to the other if hardware problems arise. Under normal production 
operation, the central instance runs on one of the machines and the database on the other. In 
the event of hardware failure, the critical resources located on the failed machine are 
switched over to the healthy machine, so that unplanned system downtime is avoided. With 
the help of this switchover – or failover – mechanism, the system can continue functioning 
normally, even after a critical hardware error has occurred.  

Apart from enabling failover when hardware problems occur, you can also use the cluster 
configuration to avoid downtime when you perform essential system maintenance. For 
example, if you need to maintain the database node, you can deliberately switch the 
database to the node where the central instance is running and operate it there until the 
database node is again ready for production. While maintenance is in progress, the central 
and database instance temporarily operate on the same node. When maintenance work is 
finished, you can easily move the database back to its original node and continue operating it 
there. 

 
• When you are setting up the SAP system in an MSCS configuration, the 

process is a combination of standard installation steps which are 
described in earlier sections of this documentation and supplementary, 
cluster-specific steps which are escribed in detail in this part of the 
documentation. 

• In this documentation the two hosts in the cluster are referred to as 
node A and node B 

Prerequisites 
Read the following installation notes before you begin the installation, as they contain the 
most recent information regarding the installation, as well as corrections to the 
documentation.  

Note Number Title 

751411 Windows-specific information about the SAP R/3 Enterprise 4.7 
Ext. Set 2.00 SR1 installation and corrections to this 
documentation. 

676073 Cluster-specific information about the SAP Web AS 6.40 system 
installation and corrections to that documentation. 

675940 Oracle-specific information about the Web AS 6.40 system 
installation and corrections to this documentation. 
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Process Flow 
The process of setting up a SAP system on an MSCS configuration differs, depending on 
whether you want to:  

• Install a new SAP system on cluster hardware 

• Move an existing SAP system to cluster hardware 

Installing a New SAP System on Cluster Hardware 
If you intend to run a new SAP system on a cluster, the process of installing your system is as 
follows:   
... 

1. Standard Installation for MSCS 

In this phase you perform a standard SAP system installation, but perform a number of 
supplementary steps specially required for the cluster configuration: 

 Since the cluster hardware has two nodes that have access to both local and 
shared storage devices, you have to install some components on both nodes 
and observe special rules for distributing components to local or shared disks. 

 Since the correct configuration of network addresses is absolutely essential to 
enable the cluster to function properly, you have to perform a number of 
additional steps that are necessary to set up and check addressing. 

2. Conversion to MSCS 

In this phase you configure the database and SAP system so that they can take 
advantage of the cluster functionality provided by the MSCS software. 

Moving an Existing SAP System to Cluster Hardware 
If you have an existing SAP system and plan to migrate to a cluster with new hardware, the 
procedure is essentially the same as for a new system. You have to install the SAP system 
on the new hardware and subsequently convert the system for cluster operation.  

However, you install the SAP system using a system copy. Therefore, you have to prepare for 
the installation by creating a copy of the database. Afterwards, instead of loading the 
database from the Export CDs in the installation package, you load it using your exported 
database. 

Depending on your source and target system, you might either have to perform a 
homogeneous or heterogeneous system copy: 

• If the original system and target system have the same operating system and 
database, you perform a homogeneous system copy. 

For more information, see the documentation Homogeneous and Heterogeneous 
System Copy for SAP Systems Based on SAP Web Application Server on SAP Service 
Marketplace at service.sap.com/instguidesNW04 → Installation 

• If the original system and target system have a different database or operating 
system, you perform a heterogeneous system copy. A prerequisite for this type of 
copy is a migration package that you can order from SAP. 

For more information, see the documentation Homogeneous and Heterogeneous 
System Copy for SAP Systems Based on SAP Web Application Server on SAP Service 
Marketplace at service.sap.com/instguidesNW04 → Installation 

For further information, see also: service.sap.com/ 
osdbmigration 
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Once you have installed your system on the new hardware following the instructions for a 
system copy, you can convert your system to a cluster as described in the Conversion to 
MSCS [Page 153]. 

 
The documentation for a homogeneous or heterogeneous system copy does not 
include the cluster-specific information you need for cluster hardware. It is 
therefore important to also carefully read this guide and follow all additional 
instructions given for the cluster. 
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2.1  Installation Planning for MSCS 
Purpose 
You need to plan the installation of the SAP system on cluster hardware using Microsoft 
Cluster Server (MSCS).  

Process Flow 
... 

1. You distribute components to disks for MSCS [Page 132]. 

2. You obtain addresses for MSCS [Page 137]. 

3. You check the hardware requirements for MSCS [Page 140]. 

4. You check the software requirements for MSCS [Page 141]. 

 
The cluster hardware is equipped with two sets of disks: 

• Local disks that are attached directly to one of the nodes 

• Shared disks that can be accessed by both nodes via a shared 
interconnect. 

You need to work out which components have to be stored on local disks, which 
on shared disks, and which have to be separated to different disks for 
performance and security reasons. 

2.1.1  Distribution of Components to Disks for 
MSCS 
Keep in mind that the cluster has the following separate sets of disks:  

• Disk arrays connected locally to node A 

• Disk arrays connected locally to node B 

• Disk arrays connected to both node A and B with a shared bus, providing shared 
storage for both nodes 

You need to install system components in both the following ways: 

• Separately on both node A and B to use the local storage on each node 

• Once on the shared storage that is used in common by nodes A and B 

The following graphic illustrates how you distribute the software to different volumes of a 
RAID system during the installation. You need to locate the database data files, the SAP 
program files (executables), and the quorum resource on different RAID volumes. This 
configuration is required so that the SAP system and database can be switched as separate 
units during failover.  
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Software Distribution on a Cluster System with RAID 

SAP SAP executablesexecutables

NodeNode
A B

Windows Windows 
MSCS SoftwareMSCS Software
Oracle Oracle SoftwareSoftware

Windows Windows 
MSCS SoftwareMSCS Software
Oracle Oracle SoftwareSoftware

Shared Storage

DatabaseDatabase
directoriesdirectories e.g. e.g.

DBDB data data,,
Redo logsRedo logs

QuorumQuorum

 

 
The Oracle server software in the ORACLE HOME directory must have the 
same drive letter and path on both nodes. 

Quorum Disk 
The MSCS quorum disk is unique to a cluster installation and is always owned by one of the 
nodes. It has the following main functions in the cluster:  

• It logs changes to the cluster configuration that are entered in the Registry. 

• It arbitrates between competing nodes, when the communication between nodes 
breaks down. This means that cluster resources are forced to failover to the node that 
owns the quorum disk. 

 
The default quorum log size is 64 MB. If you use a large number of shares, the 
quorum disk size may be too small.  

To increase the quorum log size, carry out the following steps: 
a. Right-click the cluster group and choose Properties. 
b. Select quorum log and increase the value to 4096 in the Size box. 
For more information, see also the Microsoft Knowledge Base Article 225081. 

Database Directories 
As shown in the graphic above, you must distribute the database directories so that they: 

• Do not reside on the same RAID volumes as the SAP program files or the quorum 
resource. 

• Reside on several different RAID volumes, for security and performance reasons 
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Depending on the disks available and the size of your system, various disk configurations are 
possible, but you must always locate the database data and redo logs on separate volumes. 
The following graphic shows a secure method to distribute the database directories to 
volumes. For more information on other options, see Distribution of Components to Disks 
[Page 43].  

i

Archived redoArchived redo logslogs

Redologs setRedologs set BB
Mirrored redoMirrored redo logs logs setset AA

Redologs setRedologs set AA
Mirrored redoMirrored redo logs logs setset BB

Database RAID Volumes

DBDB DataData
RAID  5

RAID  1

 

Note that the BR*Tools directories \sapreorg, \saptrace, \sapbackup,\sapcheck 
are not shown in the graphic. You can locate these directories on any of the database 
volumes as they do not require special security measures. 

2.1.1.1  Directories in an MSCS Configuration 
The following tables show the directories where the main software components for the SAP 
cluster installation are stored: 

Directories on Local RAID Volumes on Both Node A and B 

Component Default Directory Minimum Size 

A supported operating system [Page 
141] 

\%windir% 1.5 GB 

MSCS Software \%windir%\Cluster 10 MB 

SAP cluster files \%windir%\SAPCluster 20 MB 

Oracle server software \oracle\<SAPSID>\920 2.2 GB 

Oracle Fail Safe Software \oracle\OFS 400 MB 

 

Directories on Shared Volumes 

Component Default Directory Minimum Size 

Cluster quorum resource \MSCS 100 KB 

SAP executables \usr\sap ... 1 GB 

SAP data files \ORACLE\<SAPSID>\<SAPSID>DATA1 
... \<SAPSID>DATA<n> 

25 GB approx 
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Online redo logs, set A \ORACLE\<SAPSID>\origlogA 400 MB 

Online redo logs, set B \ORACLE\<SAPSID>\origlogB 400 MB 

Mirrored online redo logs, 
set A 

\ORACLE\<SAPSID>\mirrlogA 400 MB 

Mirrored online redo logs, 
set B 

\ORACLE\<SAPSID>\mirrlogB 400 MB 

Backup of online redo logs  \ORACLE\<SAPSID>\oraarch  5 - 100 GB 

BR*Tools directories ...\sapreorg, \saptrace, 
...\sapbackup, \sapcheck, 

...\saparch 

2 GB 

 

 
In a live system with intense I/O activity, you must reserve at least 3 times the 
minimum amount of space specified above for the redo logs and mirrored redo 
logs. 

SapCluster Directory 
In an SAP cluster installation, an additional directory is created under the system directory: 
%WINDIR%\SapCluster 
This contains all the SAP files required by both cluster nodes, independently of the node the 
SAP instance is running on. The files are database tools and program files (executables)  
used by the operating system monitor (SAPOsCol). 
The directory is added to the path variable of the user <SAPSID>adm. 

 

2.1.2  Addresses in an MSCS Configuration 
A part of the installation process that is unique to a cluster is the configuration of host names 
and IP addresses in the network. This is a particularly important task because the addressing 
plays a key role in the switchover procedure. Addressing must be set up correctly so that the 
system can take advantage of the cluster functionality and switch between nodes when 
hardware problems arise.  

This section explains the different types of addresses and their function in the switchover 
mechanism of the cluster.  

Types of Addresses 
In a correctly configured cluster, there are seven IP addresses and corresponding host 
names. Some of the addresses are physical addresses that are assigned to the network 
adapters (cards), others are virtual addresses that are assigned to the cluster groups. 

Physical IP Addresses Assigned to Network Adapters 
An MSCS configuration usually has two networks: 

• A public network that is used for the communication between the central instance, 
application servers and the LAN. 

• A private network that is used internally for communication between the nodes of the 
cluster. 



2   Cluster Installation with MSCS   

2.1   Installation Planning for MSCS 

136 August 2004 

To set up these two networks, each node needs an adapter for both the private and public 
network. This means that each node must have an adapter for the private network and an 
adapter for the public network and each of these adapters has its own physical IP address 
and corresponding host name.  

 
For more information on network configuration, see also the Microsoft 
Knowledge Base Article 259267. 

The graphic illustrates the adapters required for the public and private networks, and their 
corresponding physical IP addresses. A physical address, as opposed to a virtual one, is 
stationary and permanently mapped to the same adapter.  

Adapter
1

Adapter
3

IP 1

Adapter
2

Adapter
4

Private Network

Public Network

IP 3

IP 2

IP 4

 

Host Names Assigned to Network Adapters 
Each of the physical IP addresses of the network adapters must have a corresponding host 
name. For example, on the left-hand node above, you might assign the IP addresses of the 
public and private network adapters as follows: 

IP Addresses and Host Names 

Network Adapter IP Address Host Name 

Adapter 1 (private network) 10.1.1.1 decc14_priv 

Adapter 3 ( public network) 129.20.5.1 decc14 

 
Make sure that you are aware of the following: 

• The SAP cluster setup might fail due to blank or special characters in the 
network connection name for the private or public network. Therefore, we 
recommend you to rename Adapter 1 and Adapter 3 to Private and 
Public network. 

For more information, see SAP Note 413553. 

• Note that the IP address and host name of the public network adapter is 
also the IP address and name of the machine. In the above example, this 
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means that the machine that is the node on the left has the name 
decc14. 

• Do not confuse the host name with the computer name. Each node 
also has a computer name, which is often the same as the host name, 
but is written in uppercase. 

The computer name is displayed in the node column of the Cluster 
Administrator (for Oracle it is also displayed in the node column of the 
Fail Safe Manager). However, it is not required for the TCP/IP 
communication in the cluster. When you configure IP addresses and 
corresponding names, keep in mind that it is the host names that are 
important for the cluster, not the computer names. 

Virtual IP Addresses Assigned to Cluster Groups 
When you have installed the SAP system and fully configured the cluster, the critical system 
resources are bound together in three different groups. Each of these groups requires a 
virtual IP address and host name that is permanently mapped to the group and not to  a 
particular node. This has the advantage that, whenever a group is moved between nodes, its 
IP address and host name move together with it.  

A cluster configuration has the following groups:  

• SAP cluster group 

• Database cluster group 

• Cluster group 

Each group consists of a set of related resources that work together to offer a service to the 
system. For example, the database cluster group comprises all the resources that enable the 
database server to fulfill the requests of a client. When the group is moved from one node to 
the other, due to node failure, the virtual IP address and host name move with it. Therefore, 
there is a failover not only of resources, but also of the virtual IP address and host name. As 
a result, all clients can still reach the database server with the same address as before. 

The following graphic illustrates how the virtual addresses of the database group and SAP 
group can move from one node to the other when failover occurs. 

Virtual IP 1
Cluster Group

Node

A

Node

B

Virtual IP 2
SAP Group

Virtual IP 3
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2.1.2.1  Obtaining Addresses for MSCS 
Use 
You need to correctly configure addresses for a cluster system. During the installation 
procedure you have to assign seven IP addresses and host names. You normally obtain 
these names and addresses from the system administrator. 

Prerequisites 
• If you are installing Windows for the first time on your system, follow the procedure 

“Obtaining IP Addresses” below. 

• If Windows has already been installed on your system, the host names and IP 
addresses of the network adapters (cards) have already been defined and exist in your 
system. 

This means that you can find out the IP addresses for the network adapters using the 
procedure “Determining Existing IP Addresses” below. 

However, you still need to also use the table “Virtual IP Addresses” in the procedure 
“Obtaining IP Addresses.”  

Procedure 

Obtaining IP Addresses 
Ask the system administrator to give you the addresses and host names listed in the tables 
below. You will need to enter them later during the installation process. 

The column Defined During indicates at which stage of the installation the addresses are 
defined in the system. 

 
Use the names exactly as specified by the system administrator, carefully 
observing upper and lowercase letters. 

Physical IP Addresses 

Component Example for 
Physical IP 
Address 

Example for 
Physical Host 
Name 

Purpose Defined 
During 

Node A: 
adapter for 
private 
network 

10.1.1.1 decc14_priv Address for inter-
node 
communication on 
the private 
network 

Windows 
installation 

Node A: 
adapter for 
public network  

129.20.5.1 decc14 Address of node A 
for communication 
with application 
servers and LAN 
(this is the same 
as the address of 
node A) 

Windows 
installation 

Node B: 
adapter for 

10.1.1.2 decc15_priv Address for inter-
node 

Windows 
installation 
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private 
network  

communication on 
the private 
network 

Node B: 
adapter for 
public network  

129.20.5.2 decc15 Address of node B 
for communication 
with application 
servers and LAN 
(this is the same 
as the address of 
node B) 

Windows 
installation 

 

Virtual IP Addresses 

Component Example for 
Virtual IP 
Address 

Example for 
Name 
(Host Name) 

Purpose Defined During 

Cluster group 129.20.5.3 clusgrp Virtual address 
and name of the 
cluster group. It 
identifies the 
cluster and is used 
for administration 
purposes. 

MSCS 
software 
installation 

SAP cluster 
group 

129.20.5.4 sapgrp Virtual address 
and name for 
accessing the 
group of SAP 
resources, 
regardless of the 
node it is running 
on 

Configuration 
of SAP for the 
cluster using 
SAPinst on 
node A 

Database 
cluster group 

129.20.5.5 dbgrp Virtual address 
and name for 
accessing the 
group of database 
resources, 
regardless of the 
node it is running 
on 

Execution of 
MSCS Wizard 
or database-
specific cluster 
scripts 

 

Determining Existing Addresses 
To find out the existing IP addresses and corresponding host names and addresses, proceed 
as follows:  
... 
... 

1. Choose Start → Settings → Network and dial-up Connections. 

The Network and dial-up Connections window appears. 

2. Select one of the network cards that are displayed and choose File → Properties. 

A dialog box opens. 

3. Choose TCP/IP Protocol → Properties. 
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The TCP/IP Properties dialog box appears and shows the IP address of the initially 
selected network card. 

4. To find out the host name that is mapped to the IP address, use the ping 
command: 

ping -a <IP_Address> 

The system returns the host name assigned to the IP address.  

Do not forget to ping your local machine as well.  

For more information about addresses in the cluster environment, see Using Addresses in an 
MSCS Configuration [Page 135]. 

2.1.3  Checking Hardware Requirements for MSCS 
Use 
When you install the SAP system on cluster hardware, you have to meet the hardware 
requirements shown below. This makes sure that the system can take advantage of the 
MSCS functionality and achieve an acceptable performance level. 

Procedure 
... 

1. Check that your cluster hardware is certified. 

AddOn Technology Center for SAP (Addon TCS) certifies hardware platforms for SAP 
on Microsoft Windows. The cluster must be included in the Microsoft list of certified 
clusters and its components. You can access the lists at: 
www.microsoft.com/hcl 

www.saponwin.com 

2. Make sure that both nodes of the cluster are connected by a private and public 
network: 

 The public network enables communication from the nodes of the cluster to 
other resources in the local area network (LAN). 

 The private network enables internal communication between the nodes. In 
particular, it enables the Cluster Service running on both nodes to regularly 
exchange messages on the state of the nodes so that the failure of resources is 
quickly detected. 

3. Check that sufficient storage space is available. 

Each of the nodes in the cluster must have its own local disks and have access to 
shared disks that can be reached by both nodes via a shared bus. 

All software – except the Windows operating system, the Oracle DBMS executables, 
and the MSCS software – is stored on the shared disks. One of the shared disks must 
be used exclusively by the Quorum resource that stores the cluster registry and 
records information about the state of the cluster.  
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Disks Required Space How to Check 

1 local disk on each node 4 GB 
... 

1. Choose Start → Programs → 
Administrative Tools → 
Computer Management → 
Disk Management. 

4. Right-click the disk and 
choose Properties. 

At least 6 shared disks 25 GB 
... 

1. Choose Start → Programs → 
 Administrative Tools 
→ Computer Management → 
Disk Management. 

5. Right-click the disk and 
choose Properties. 

 

 
All disk controllers must be able to support hardware-based RAID. 

4. Check the RAM and virtual memory on each node: 

Requirement How to Check  

• RAM for a non-Unicode SAP system: 
512 MB 

RAM for a Unicode SAP system: 1 GB 

In the Windows Explorer choose Help → 
About Windows. 

Paging file size of 5 times RAM. 
Maximum required is 10 GB. 

... 

1. Right-click My Computer and 
choose Properties. 

5. Choose Advanced → Performance 
Options. 

6. If required, in section Virtual 
Memory, choose Change. Only 
select the local disks. 

 

2.1.4  Checking Software Requirements for MSCS 
Check that the software you install on the cluster nodes meets the following requirements: 

Software Requirement How to check  

English international version of one of the 
following: 

• Windows Server 2003 Enterprise 
Edition  

• Windows Server 2003 Datacenter 
Edition  

• To check the Windows Version: 

a. Choose Start → 
Programs → 
Accessories → 
Command Prompt 

b. Enter the command 
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• Windows 2000 Advanced Server with 
at least service pack 4 

• Windows 2000 Datacenter Server with 
at least service pack 4 

 
For any version of Windows 
2000, you need at least service 
pack 4. For more information on 
the latest service pack 
supported by SAP, see SAP 
Note 30478. 

winver 

MSCS software  – 

Oracle Enterprise Edition 9.2.0 with the 
current patch. 

For more information on the current patch 
set, see SAP Note 578683. 

 
MSCS only: 

You have to install the Oracle  
patch set  and hot fix (if 
available) on both nodes. 

Oracle Fail Safe software version 3.3.2 – 

Suitable Windows Resource Kit is strongly 
recommended.  

– 
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2.2  Installation Preparations for MSCS 
Purpose 
Before you install the central instance and database of the SAP system, you need to prepare 
the system for cluster installation. 

 Prerequisites 
Make sure that you have finished the installation planning [Page 132], especially the: 

• Hardware requirements [Page 140] 

• Software requirements [Page 141] 

 Process Flow 
The following table lists all the preparatory tasks you need to perform before beginning with 
the installation of the SAP system.  

 
You cannot use a host with a domain controller as a cluster node. 

1. On both nodes, you install the operating system [Page 141] with the option Cluster 
Service. For more information, see the Windows documentation. 

When you install the Cluster Service, you specify a separate, shared disk for the 
quorum resource.  

 
When you install the Cluster Service, you specify a separate, shared disk for the 
quorum resource.  

2. On both nodes, you manually assign drive letters to the shared disks  [Page 143] 
using the Windows Disk Administrator. Both nodes must access the shared disks 
with the same drive letters.  

3. On both nodes, you adjust the size of the paging file and the file cache. For more 
information, see Hardware and Software Requirements [Page 47] and Reducing 
the Size of the File Cache [Page 57] 

4. You map the seven IP addresses to host names [Page 144] on the Domain Name 
Server (DNS) or in the hosts file.  

5. You check the IP address and corresponding host name assignment. For more 
information, see Checking the Mapping of Host Names for MSCS [Page 145]. 

6. On both nodes, you check the binding order. For more information, see Checking 
the Mapping of Host Names for MSCS [Page 145]. 

 

2.2.1  Assigning Drive Letters for MSCS 
Use 
We recommend that you assign drive letters for MSCS. 

In a cluster, the shared disks that can be accessed by both nodes via a common bus must be 
addressed by both nodes with the same drive letters. 
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Procedure 
... 

1. Choose Start → Programs → Administrative Tools → Computer Management → 
Storage → Disk Management. 

2. Select a disk and choose Action → All tasks → Change drive. 

3. Enter a new drive letter. 

2.2.2  Mapping Host Names to IP Addresses for 
MSCS 
Use 
To enable correct operation of the failover mechanism, you have to map all IP addresses in 
the cluster to host names. You can do this on a Domain Name Server (DNS) or in the 
Windows hosts file.  

The mapping enables the system to translate host names into IP addresses. Host names are 
normally used for administrative tasks because they are easier to use than the long, numeric 
IP addresses. However, the system can only respond to host names if they are translated into 
IP addresses with the information stored on a DNS Server or in the hosts file.  

Prerequisites 
• You have the list of addresses [Page 137]. 

• You have installed Windows. 

• Enter all seven IP addresses required for the cluster configuration. 

 
Take care when making your entries because missing or incorrect entries can 
cause problems later during the installation: 

• The names are case-sensitive. 

• You need to enter the names exactly as specified by the system 
administrator. 

• You can perform the mapping either on the DNS server or in the hosts file. 

 
We recommend that you perform the mapping on the DNS server because this 
only requires a single entry.  

If you perform the mapping in the hosts file, you have to maintain several 
versions of the same file because each machine in the system has its own 
hosts file.  

Procedure 
• On the DNS Server 

If your system includes a DNS server, map the host names to IP addresses on this 
server.  

• In the hosts file 
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If you do not have a DNS server in your system infrastructure, map the IP addresses to 
host names in the hosts file. This is located in the default directory for Windows: 

<%SystemRoot%Drive>\system32\drivers\etc 

The hosts file has to be identical on both nodes of the cluster, and on all application 
servers and front ends. Therefore, you have to copy the newly edited file to all these 
locations in the system.  

2.2.3  Checking the Mapping of Host Names for 
MSCS 
Use 
You need to check the mapping of host names to IP addresses [Page 144] because this is 
crucial for cluster operation.  

 
Make sure that you perform this procedure; otherwise you might have serious 
problems later.  

Prerequisites 
• You have mapped IP addresses to host names on the DNS Server or in the hosts file. 

• Make sure that you check all IP addresses. 

Procedure 
... 

1. For each IP address enter the following commands: 
ping -a <IP_Address> 

The system returns the host name that is assigned to the IP address. 
ping hostname 

The system returns the IP address that is assigned to the host name. 

 
When you enter the ping command, you do not get a reply, if the host does not 
yet exist. 

If the address you are checking already exists in the system, you also receive a 
reply from the host. For example, after the installation of Windows and the 
configuration of the network, you get a reply when entering the IP addresses of 
the network adapters. 

2. Compare the output with your own record of addresses and host names and check for 
the following possible errors: 

 If uppercase and lowercase are incorrect in the output, there is an error. Make 
sure that you correct the error before proceeding with the installation. 

 If you enter the name of the public network adapter, which is usually also the 
name of the local host, and the system returns the IP address of the private 
network, there is an error in the network bindings. To correct the network 
bindings, see the procedure below. 

3. If you discover an error in the network bindings, correct it by doing the following on 
both nodes: 



2   Cluster Installation with MSCS   

2.2   Installation Preparations for MSCS 

146 August 2004 

... 

a. Choose Start � Settings � Network and Dial-up Connections 

b. The Network and Dial-up Connections window appears. 

c. Choose Advanced � Advanced Settings → Adapters and Bindings 

d. The network cards of the private and public networks are displayed for 
the current node. 

e. The card of the public network must be displayed before that of the 
private network. 

f. If necessary, change the order in which the cards are listed by using the 
Move Up and Move down arrows. 

g. Repeat this step for any other TCP/IP protocols that are listed. 
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2.3  Central and Database Instance 
Installation for MSCS 
Purpose 
When you have completed the preparation for the cluster installation, you can start the 
installation of the central and database instances for your SAP system.  

Prerequisites 
• You have completed the Installation Preparations for MSCS [Page 143]. 

• To make sure that all preparation steps have been correctly performed, check that you 
can move the disk resources from one node to the other so that they are only 
accessible from a single node at any time. 

Process Flow 
You perform the following steps to install the SAP central and database instance. You are 
logged on as domain administrator, unless otherwise specified. 

 
When you reboot during the installation process [Page 148], resources fail over 
to the second node. Therefore, after each reboot, you have to return the system 
to the state it had before the reboot.  

1. In the Cluster Administrator, you move all Disk groups and the Cluster group to 
node A. For more information, see Moving MSCS Groups [Page 148]. 

On both nodes, you install the Oracle 9.2.0 server software and the current patch set (if 
available) [Page 71].   

2. On both nodes, you install the Oracle Fail Safe Software 3.3.2 [Page 149] 
After the installation you reboot [Page 148]. 

 
Do not install the Fail Safe Software parallely on both nodes.  

3. On node A, in the Cluster Administrator, make sure that all existing cluster groups 
are online. Make sure that you are logged on as a user with domain administration 
rights 

4. On node A, you run SAPinst [Page 73] to install the SAP central instance and the 
database instance.  

Note the following:  

 Make sure that you are logged on as domain administrator.  

 When you are prompted to enter the name for the saptranshost or the 
database, accept or enter the physical host name of node A 

See also: 
Distribution of Components to Disks for MSCS [Page 132] 

Result 
You have installed the central and database instances on the cluster hardware. However, 
they cannot yet use the cluster functionality.  
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In the next stage – the conversion to MSCS [Page 153] – you configure the database and 
SAP system to use the cluster functionality.  

2.3.1  Rebooting During the Installation or 
Conversion for MSCS 
Use 
You need to perform this procedure if you have to reboot during the installation or conversion 
for MSCS. A reboot means that resources fail over to the second node. Therefore, after each 
reboot, you have to return the system to the state it had before the reboot, as described 
below. 

Procedure 
1. In the Cluster Administrator, move all resources back to the original node.  

2. Start the database service, especially OracleService<DBSID>, if it already exists. 

3. If you have already clustered the database, you have to bring the database group online. 

4. Recreate the SAPMNT and SAPLOC shares for the directory usr\sap. 

 
If you use Windows Server 2003, you have to reset the permissions for the 
SAPMNT and SAPLOC shares from Read to Full Control, as follows: 

i. Right-click on the directory usr\sap and choose Sharing and Security. 

ii. Select Sharing and in the Share Name field, enter SAPMNT. 

iii. Under Permissions, make sure that the permission for SAPMNT is set to 
Full Control. 

iv. Repeat this procedure for the SAPLOC share. 

2.3.2  Moving MSCS Groups 
Use 
During various stages of the cluster installation, you have to move the database, SAP or disk 
cluster groups from one node to the other before you can continue.  

  

Prerequisites 
The groups you want to move are configured and are visible in the Cluster Administrator. 

Procedure 
... 

1. Start the Cluster Administrator with Start → Programs → Administrative Tools → 
Cluster Administrator. 

2. In the Cluster Administrator, select a group – for example Disk Group 1 – and drag 
it to the required node on the left-hand pane. 

3. Repeat the previous step for each group that you want to move. 
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2.3.3  Installing the Oracle Fail Safe Software 
Use 
To enable the database to take advantage of the cluster functionality, you have to install an 
additional component, the Oracle Fail Safe software.  

 
The Oracle Failsafe Service from previous Oracle releases is now called 
OracleMSCSServices. You might still see the old name in certain SAP Notes.  

Be sure that you always use the new name OracleMSCSServices. 

Prerequisites 
You have installed the Oracle database software locally on both nodes. It must be installed 
on the same home on both nodes! 

Procedure 

 
You have to install the Oracle Fail Safe Software on both nodes: 

The installation procedure differs depending on whether you install the Oracle Fail Safe 
software in a 32-bit or a 64-bit system. The following describes both approaches. 

 

Installing the Oracle Fail Safe Software in a 32-Bit System  

1. In the Cluster Administrator make sure that: 

 The second cluster node is not set to Pause. 

 The SAP group is offline on the node where you are installing. 

2. Make sure that the Cluster Server service is started on both nodes. 

3. Insert the Oracle RDBMS DVD for 32-bit. 

4. Start the Oracle Universal Installer. To do this, double-click the file sapofs.cmd in 
the directory <DVD_DRIVE>:\ORAFS332I386 

The Installer opens and guides you through the installation process in a series of 
screens. Enter the required information as follows: 

 

Screen Entry 

Welcome Choose Next. 
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Screen Entry 

File 
Locations 

Source... 

For Path 

The path to the Oracle software on the DVD is displayed. Do not 
change the path. 

Destination... 

For Name 
Enter the name of the Oracle Home for the Fail Safe software. 
The Fail Safe software must be installed in a separate Oracle 
home directory, for example OFS.  

Use the same Oracle home for both nodes. 

For Path 
Enter the path of the Oracle Home directory for the Fail Safe 
software. It must be on a local disk, for example:  
F:\Oracle\OFS 

Available 
Products 

Select Oracle Fail Safe <current version> and choose Next. 

Installation 
types 

Choose Typical. 

Reboot 
Needed After 
Installation  

Choose Next. 

Summary View the information and choose Install. 

Install Wait while the software is installed.  

Configuration 
Tools 

On the dialog box Oracle Services for MSCS Account/Password 
enter the account and password under which the Fail Safe 
software is to run. This must be the same account as the one 
under which the Cluster Server service is running.  

To find out which account must be entered, choose Start → 
Settings → Control Panel → Administrative Tools → Services. 

Select the Cluster Service and click Startup… 

The logon account for the service is displayed. Enter this account 
for Oracle Fail Safe Account/Password. 

End of 
Installation 

Click Exit to leave the Installer. 

5. Reboot and log on again. 

 
Do not reboot a node, if the installation of OFS 3.3.2 is in progress on the other 
node. 

Installing the Oracle Fail Safe Software in a 64-Bit System 

If you use a 64-bit system you first have to install the 64-bit Fail Safe Server Software, and 
then the 32-bit Fail Safe Client Software. 
... 

1. In the Cluster Administrator make sure that: 



  2   Cluster Installation with MSCS 

  2.3   Central and Database Instance Installation for MSCS 

August 2004 151 

 The second cluster node is not set to Pause. 

 The SAP group is offline on the node where you are installing. 

2. Make sure that the Cluster Server service is started on both nodes. 

3. Insert the Oracle RDBMS DVD for 64 bit to install the Oracle Fail Safe Server 
Software. 

4. Start the Oracle Universal Installer by double-clicking the file sapofs.cmd in the 
directory <DVD_DRIVE>:\ORAFS332. 

5. Enter the required information as follows: 

 

Screen Entry 

Welcome Choose Next. 

File 
Locations 

Source... 

For Path 

The path to the Oracle software on the DVD is displayed. Do not 
change the path. 

Destination... 

For Name 
Enter the name of the Oracle Home for the Fail Safe software. 
The Fail Safe software must be installed in a separate Oracle 
home directory, for example OFSSRV.  

Use the same Oracle home for both nodes. 

For Path 
Enter the path of the Oracle Home directory for the Fail Safe 
software. It must be on a local disk, for example:  
F:\Oracle\OFS\SRV 

Choose Next. 

Installation 
Types 

Choose Typical. 

Reboot 
Needed After 
Installation  

Choose Next. 

Summary View the information and choose Install. 

Install Wait while the software is installed.  

Configuration 
Tools 

On the dialog box Oracle Services for MSCS Account/Password 
enter the account and password under which the Fail Safe 
software is to run. This must be the same account as the one 
under which the Cluster Server service is running.  

To find out which account must be entered, choose Start → 
Settings → Control Panel → Administrative Tools → Services. 

Select the Cluster Service and click Startup… 

The log on account for the service is displayed. Enter this account 
for Oracle Fail Safe Account/Password. 
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Screen Entry 

End of 
Installation 

Click Exit to leave the Installer. 

6. Insert the Oracle RDBMS DVD for 32-bit to install the Oracle Fail Safe Client 
Software. 

7. Start the Oracle Universal Installer by double-clicking the file sapofs.cmd in the 
directory <DVD_DRIVE>:\ORAFS332I386 

8. Enter the required information as follows: 

Screen Entry 

Welcome Choose Next. 

File 
Locations 

Source... 

For Path 

The path to the Oracle software on the DVD is displayed. Do not 
change the path. 

Destination... 

For Name 
Enter the name of the Oracle Home for the Fail Safe software. 
The Fail Safe software must be installed in a separate Oracle 
home directory, for example OFSCLI.  

Use the same Oracle home for both nodes. 

For Path 
Enter the path of the Oracle Home directory for the Fail Safe 
software. It must be on a local disk, for example:  
F:\Oracle\OFS\CLI 

Available 
Products 

Select Oracle Fail Safe 3.3.2.0.0  and choose Next. 

Installation 
Types 

Choose Client Only. 

Summary View the information and choose Install. 

Install Wait while the software is installed.  

End of 
Installation 

Click Exit to leave the Installer. 

9. Reboot and log on again. 

 
Do not reboot a node, if the installation of OFS 3.3.2 is in progress on the other 
node. 
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2.4  The Conversion to MSCS 
Purpose 
The conversion phase of the cluster installation configures the database and the SAP 
instances to interact with the cluster software and use the failover functionality. 

Prerequisites 
• You have completed the installation of the SAP central and database instance, and 

observed all instructions for a cluster.  

• You have installed the Oracle Fail Safe software on both nodes. 

 
Before you start the conversion to MSCS, make sure that you are logged on as 
domain administrator on node A and B.  

Process Flow 

 
When you reboot during the conversion to MSCS [Page 148], resources fail 
over to the second node. Therefore, after each reboot, you have to return the 
system to the state it had before the reboot.  

1. On node A, make sure that the Oracle database group and SAP disk are online. 

2. Configure node A  for MSCS [Page 153] with SAPinst [Page 73] using the option 
Configure MSCS Node A. 

3. On node A, convert the Oracle database to a Fail Safe database. For more 
information, see Converting the DB to a Fail Safe Database [Page 154]. 

4. Check that the database group and SAP cluster group are available on node A. In 
the SAP cluster group, the SAP resource SAP-R/3 <SAPSID> must be offline. All 
other resources of the SAP cluster group must be online. 

5. Configure MSCS Node B  [Page 156] with SAPinst [Page 73], using the option 
Configure MSCS Node B., 

2.4.1  Configuring Node A for MSCS 
Use 
To configure node A so that it functions properly in the cluster, you have to run the cluster 
configuration option offered by the SAPinst tool. When you run this option it: 

• Creates the SAP cluster group 

• Copies tools to the SAPCluster directory 

• Sets the SAPService to manual. 

• Makes sure that the SAPOsCol service is started from the SAPCluster directory 

• Copies the Oracle tnsnames.ora file to node B and adds the account under which 
the Cluster Service runs to the group ORACLE_<SAPSID>_DBA 



2   Cluster Installation with MSCS   

2.4   The Conversion to MSCS 

154 August 2004 

Procedure 
... 

1. Make sure that you are logged on to node A as a user with domain administration 
rights and as the same user that installed the central and database instance.  

2. Run SAPinst [Page 73] and choose Configure MSCS Node A. 

 
If SAPinst prompts you to log off from your system, log off and log on again. 

3. Enter the required parameter values. For more information, see Input for 
Configuring MSCS Node A and Node B [Page 157]. 

Result 
SAPinst converts the SAP instance on node A for cluster operation.  

2.4.2  Converting the Database to a Fail Safe 
Database 
Use 
The database must be cluster-enabled so that it can be switched between nodes as a group 
of resources. To do this, you create an Oracle Fail Safe group and then add the database of 
the SAP system to this group.  

Prerequisites 
You have converted node A for operation in the cluster [Page 153]. 

Procedure 
When you set up the Fail Safe database, you have to convert the database to a Fail Safe 
group and then add the database of the SAP system to this group.  

Creating the Oracle Fail Safe Group 
On node A, create the Fail Safe database group as follows:  
... 

1. Choose Start → Programs →  Oracle - <OFSClient_Home> → Oracle Fail Safe 
Manager. 

The window Add Cluster To Tree appears. 

2. Insert your virtual cluster name. 

3. Right-click the cluster and choose Connect to cluster. 

4. Enter the following and then confirm your entries with OK: 

 

User name <user> (user with the account under which the service 
ClusterServer is running) 

Password <password> 

Cluster Alias <virtual_cluster_name> (name of the cluster you are 
installing) 

Domain <domain_name> 
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5. In the Welcome dialog box, choose Verify Cluster. 

 
Both cluster nodes must be up and running for this step.  

The window Clusterwide Operation: Verifying Fail Safe Cluster shows the steps that 
are executed to verify the cluster. When you are informed that the operation has 
completed successfully, close the window.  

6. In the Oracle Fail Safe Manager, create the Fail Safe group ORACLE<SAPSID>. 

Choose Groups → Create. 

The window Create Group:... appears. 

7. Enter the Group Name ORACLE<SAPSID>.  
In answer to the question Do you want to allow the group to failback to preferred 
node?, select Prevent failback. 

The window Finish Creating the Group appears and displays information about the 
group. Choose OK.  

8. In the window Add Virtual Address, select Yes to indicate that you want to add a 
virtual address to the group. 

The Add Resource to Group: - Virtual Address appears. 

9. Select Show networks accessible by clients and enter the following information: 

Under Network leave the entry public 

Under Virtual Address for Host Name enter <database_group_name> (the virtual 
name for the database group).  

The IP Address is automatically recognized. 

Choose Finish. 

The window Add the Virtual Address to the Fail Group appears. Choose OK. 

 
If the Fail Safe Manager cannot create the Fail Safe group, look at the Windows 
Event Logs on both nodes to find out the reason for the failure.  

Adding the Database of the SAP System to the Fail Safe Group 
Perform the following steps in the Fail Safe Manager on the primary node A: 
... 

1. In the tree on the left, expand <Primary_Node> →  Standalone Resources and then 
select the database <SAPSID>.world. 

2. Choose Resources  → Add to Group. 

3. On the dialog box Add Resource to Group – Resources: 

For Resource Type, select Oracle Database. 

For Group name, select Oracle<SAPSID> 

4. On the dialog box Add Resource to Group – Database Identity, enter the following: 

 

Service Name <SAPSID>.world 
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Instance Name <SAPSID> 

Database Name <SAPSID> 

Parameter File <DRIVE>:\<ORACLE_HOME>\database\init<SAPSID>.ora 

 

 
If a warning appears about the location of init<sapsid>.ora, you can ignore 
it. 

5. When you have made all entries, choose Next. 

6. On the dialog box Confirm Add Database to Group choose Yes to shutdown the 
database. 

7. For each node a Pop-Up appears: The Oracle Net Listener uses a host name in the 
host address parameter. It must be converted to use an IP address. 

Choose Yes to convert to an IP address. 

The SAP database <SAPSID> is now added to the Fail Safe group. 

2.4.3  Configuring Node B for MSCS 
Use 
To configure the second node in the cluster, you have to run the cluster configuration option 
for node B offered by the SAPinst tool. When you run this option it: 

• Creates users and groups 

• Sets the Windows system and user environment 

• Copies tools to the SAPCluster directory 

• Enters required port numbers in the Windows services file 

• Creates the SAPService and SAPOsCol Services 

Prerequisites 
You have already configured node A of the cluster [Page 153]. Node A is the primary cluster 
node.  

Procedure 
... 
... 

1. Make sure that you are logged on to node B as a user with domain administration 
rights and as the same user that installed the SAP central and database instance. 

2. Run SAPinst [Page 73] and choose Configure MSCS Node B. 

 
If SAPinst prompts you to log off from your system, log off and log on again. 

3. Enter the required parameter values. For more information, see Input for 
Configuring MSCS Node A and B [Page 157]. 

When all required entries have been made, SAPinst begins processing and converts 
the SAP instance on node B for operation in the cluster. 

4. When SAPinst has finished, start the SAP resource SAP-R/3 <SAPSID>: 



  2   Cluster Installation with MSCS 

  2.4   The Conversion to MSCS 

August 2004 157 

a. Open the Cluster Administrator with Start → Programs → Administration 
Tools → Cluster Administrator. 

b. Expand the SAP group. 

c. Select the SAP resource. 

d. Choose File → Bring Online. 

2.4.4  Input for Configuring MSCS Node A and B  
 

Window Prompt Meaning 

Welcome Select the service 
to install 

Choose SAP R3E 4.7x200 SR1 → ABAP 
System → <Unicode or non-Unicode> and 
choose one of the following: 

• Node A:  
Choose Configure MSCS Node A  

• Node B:  
Choose Configure MSCS Node B. 

SAPinst CD 
Browser > 
Checking Software 
Packages: 

CD Name 

Package Location 

Check Location 

Copy Package To 

 

This dialog only appears if the system wants 
to check or cannot find the file LABEL.ASC 
that contains the relevant installation 
information. For more information on the CD 
Browser dialog, see Preparing the 
Installation CDs and DVDs [Page 66]. 

Under Package Location, enter the path to 
the directory where the file LABEL.ASC is 
located.  

 
• To find the correct 

location of the 
installation 
package, look in 
the file 
README.TXT 
located in the root 
directory of the 
relevant CD or 
DVD. 

• When SAPinst 
prompts for a 
folder 
<FOLDER_NAME> 
on a CD or DVD, 
make sure that 
you enter the path 
to the 
corresponding 
directory on this 
CD or DVD  
(<CD_or_DVD>\
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Window Prompt Meaning 
<FOLDER_NAME>
). 

MSCS > Selecting 
Cluster Parameter 

SAP System 
Network Name, 

Database Network 
Name 

• Enter the SAP system network name 
(virtual host name of the SAP cluster 
group). 

• Enter the database network name 
(virtual host name of the database 
cluster group). 

MSCS > Specifying 
the SAP System 
Common 
Parameters  

SAP System 
Instance 
Identification: 

 

• SAP System ID (SAPSID) 

Enter the SAP system <SAPSID> ID for 
your cluster. 

 
Use the same <SAPSID> ID 
that you entered during the 
central instance installation. 

• Instance number 

Enter exactly the instance number that 
you have entered during the central 
instance installation. 

To find out the instance number, look 
under the SAP directory 
usr\sap\<SAPSID>\DVEBMGS<nn>. 
The value <nn> is the number 
assigned to the central instance 

MSCS > SAP 
System Common 
Parameters 

Database 
Parameters : 

Database ID 
(DBSID) 

Enter the database system ID. 

Instance Memory 
Management: 

Instance RAM [MB]  

 

Enter the RAM space that is reserved for 
the SAP instance. The default value is the 
entire RAM space.  

Make sure that you reserve at least the 
minimum values required for your instance.  

MSCS > Specifying 
the SAP Instance 
Host Parameters 

Domain 
Information for the 
SAP System 
Accounts  

Choose one of the following 

• Installation in the domain of the current 
user 

• Installation in a different domain 
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Window Prompt Meaning 

LDAP Support 

 

If you want to use LDAP for SAP Logon or 
the Microsoft Management Console (MMC), 
choose the type of LDAP integration you 
want to configure for the SAP system. 
Otherwise, choose No LDAP: 

• Via Active Directory Service 

Select this option to integrate Windows 
Active Directory services. An Active 
Directory must be available on the 
network.  
(Profile parameter 
ldap/options=DirType=NT5ADS) 

• Via Generic LDAP Directory 

Select this option to configure the 
system to support LDAP directories 
that are running on Windows or UNIX 
machines. A generic LDAP directory 
must be available on the network.  

• No LDAP 

Select this option if you do not want to 
use LDAP for SAP Logon and/or MMC 
or if you do not want to use LDAP at all. 

Required Input  

Depending on your selection the information 
below is required. If you choose No LDAP, 
none of the LDAP parameters listed below 
has to be specified. 

ABAP System > 
Defining the LDAP 
Parameters  

(Node A) 

Management 
Domain 

Specifies a container in the Active Directory 
where information related to the new SAP 
system is to be stored. Use the 
distinguished name syntax. The name of the 
container (management domain) can reflect 
the organizational structure of your 
company. For example, if the system is for 
corporate finance and located in Walldorf, 
the name can be: CN=Finance, 
CN=Walldorf.  

Profile parameter: ldap/saprdn 

You need not specify this. 

However in a large system landscape, we 
recommend setting this parameter to reflect 
the structure of multiple SAP installations. 
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Window Prompt Meaning 

Container for all 
SAP-related entries 

Specifies the SAP root container in the LDAP 
directory under which all future information 
related to SAP systems is to be stored. Use 
the distinguished name syntax that specifies 
both the name of the container and the path 
to reach it. 

Profile parameter: ldap/saproot 

• Via Active Directory Service: 

We do not recommend setting this 
parameter. If you do no set this 
parameter, the system automatically 
calculates the default value to store 
information in the configuration context 
for Active Directory Service (ADS). 

• Via Generic LDAP Directory 

You must specify this parameter. 

 

LDAP Server Enter the DNS host name of the server on 
which the LDAP directory is running. If the 
directory is replicated on other servers in the 
network, specify these as well. For example: 
ldapsrv1 ldapsrv2. 

Profile parameter: ldap/servers. 

Note that the replica must be writeable. 

• Via Active Directory Service: 

We do not recommend setting this 
parameter. If you do not set this 
parameter, the system automatically 
finds the best ADS Server. 

• Via Generic LDAP Directory 

You must specify one or more LDAP 
servers, separated by blanks. 

ABAP System > 
Defining the 
Location of the 
SAP System 
Instance 
Directories 

Location of SAP 
System 
Executables  

• Yes, locate executables on central 
instance host  

This option is the default value, if you 
use a 64-bit Windows system. Select 
this option, also in a 32-bit system, if 
you install your SAP system in a mixed 
environment. For example, you install it 
on Windows and UNIX, or in a 32-bit 
and 64-bit system operating system. 

• No preparation for other OS platforms 

This option is the default value in a 32-
bit system.  Choose this option if you 
use a 32-bit system. 
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Window Prompt Meaning 

Instance 
Installation Drive   

Select the drive for the SAP base directory 
tree. 

For example, if you select D:, the directory 
usr\sap is located under drive D. 

 
If saploc already exists, you 
cannot select the local drive. 

 

Host with transport 
directory 

Enter the name of the host where the 
transport directory is located. 

 
If the transport directory is 
located in the cluster you have 
to enter the virtual host name of 
the SAP system. 

Database Instance 
Parameters : 

Database Schema 

Enter the name of the database schema 
(SAP<SCHEMA_ID>, whereas 
<SCHEMA_ID> must be exactly three 
characters long). 

 
For example, enter SAPDS1. 

Oracle > Selecting 
the Database 
System Common 
Parameters  

(Node A) 

Database Home 
Inforation :  

DB Home 

Enter the name of the Oracle home. 

ABAP System > 
Specifying 
Password for User 

 

OS User 
Parameters: 

SAP System 
Administrator  

Enter and confirm the password for the 
<sapsid>adm user. 

 
Enter and confirm the same 
password that you used for the 
central instance. 

ABAP System > 
Specifying 
Password for User 

 

OS User 
Parameters: SAP 
System Service 
Administrator  

Enter and confirm the password for the 
SAPService<SAPSID> user. 

 
Enter and confirm the same 
password that you used for the 
central instance. 
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Window Prompt Meaning 

ABAP System > 
Defining SAP 
System Service 
Ports  

(Node B) 

 

SAP System Ports: 

Message Port  

Enter the port number of the Message 
Server. 

 
The port number of the Message 
Port must be the same as the 
one on the central instance host. 

Use SLD If you want to use the SAP System 
Landscape Directory, select Use SLD.  

SLD Gateway Host Enter the name of the gateway host of the 
SAP System Landscape Directory. 
To find out the host name, enter hostname 
at the command prompt of the gateway 
host. 

 

ABAP System > 
Registering in 
System Landscape 
Directory (SLD) 

SLD Gateway 
Instance Number 

Enter the instance number of the gateway 
instance of the SAP System Landscape 
Directory 
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2.5  Post-Installation Activities for MSCS 
Purpose 
This section describes how to complete and check the installation of the SAP MSCS system. 

Prerequisites 
You have completed the installation steps explained in previous sections of this 
documentation and you have installed at least one SAP front end.  

For more information on installing the front-end software, see the documentation [Page 35]: 

• SAP Front End Installation Guide (English version) 

• SAP Frontend-Installationsleitfaden (German version) 

Process Flow 
... 

1. You start and stop the SAP system [Page 163]. 

2. You log on to the SAP system [Page 93]. 

When you create the logon entry, make sure that you enter the virtual host name in 
the Application Server field. 

3. You install the SAP license [Page 94]. 

4. On both nodes, you check SAP system services [Page 94]. 

5. You install the online documentation [Page 95]. 

6. You configure SAProuter and SAPNet - R/3 Frontend [Page 96]. 

7. You configure the Transport Management System (TMS) [Page 96]. 

8. You perform basic operations [Page 97]. 

9. You check and, if required, adapt the configured number of work processes [Page 
97]. 

10. If required, you install additional languages [Page 98]. 

11. You activate or deactivate the integrated Internet Transaction Server (ITS) [Page 
98]. 

12. If required, you import Support Packages [Page 99]. 

13. If required, you set up Secure Single Sign-On [Page 98] or Kerberos Single Sign-
On [Page 104]. 

14. You perform the client copy [Page 109]. 

15. You perform a full installation backup [Page 111]. 

16. Prepare the SAP system for using business applications, which includes 
customizing the SAP R/3 Enterprise and the business components. 

For more information, choose Solution Life Cycle Management → Customizing in the 
SAP Library [Page 36]. 

17. You change passwords of created users [Page 112]. 
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2.5.1  Starting and Stopping the SAP System in an 
MSCS Configuration 
Use 
You use this procedure to start or stop the SAP system in an MSCS configuration.  

Procedure 

Starting the System 
... 

1. Start the Cluster Administrator by choosing Start → Programs → Administrative 
Tools → Cluster Administrator. 

2. Right-click the SAP group SAP-R/3 <SAPSID> and choose Bring online. 

The SAP system is started. 

Stopping the System 
... 

1. Start the Cluster Administrator by choosing Start → Programs → Administrative Tools → 
Cluster Administrator. 

2. Double-click the group SAP-R/3 <SAPSID> to display the resources belonging to the 
SAP group. 

3. Right-click the resource SAP-R/3 <SAPSID> and choose Take offline. 

The SAP system is stopped. 
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